WoW, a Laptop, a mouse

Over the last few days, my USB thumball mouse has not been responding properly when I play WoW. The mouse moves fine. The problem is the clicking part. Frequently, it just doesn’t respond.

I have tried another mouse, same kind, that we had on the desktop computer. I have used all 4 USB ports.

So, it’s not the port and it’s not the mouse.

I have tried turning the touchpad on and off. I checked the driver for the USB mouse. I read through everything else in my computer and game settings and can’t see anything obvious.

I hadn’t changed anything before the problem started. Well, I turned the touchpad off because of a typing problem. But, I still have the problem when I turn it back on.

I have been using this same style mouse ever since I started playing WoW 3 or 4 years ago. I used it on CoH too. I never had this problem before.

So, why did it all of a sudden stop responding properly in the game?

Did you recently play an Alliance toon? That’s my bet for what screwed things up for you.



I always play Alliance.

you computer is trying to tell you something. FOUR YEARS IS ENOUGH. go find a drug habbit.


I should point out that my life doesn’t revolve around the game. Even though I’ve been out of work for 3 months (surgery), I haven’t played any more than I did while I was working.

does the mouse respond incorrectly while you’re playing other games, or just WoW? Have you tried deleting your wtf folder?

I don’t really play any other games. I have no trouble with things like Bejeweled though.

I’ve been trying to install City of Heroes again but I’m having all kinds of graphics problems with that so I haven’t really noticed any problems with the mouse.

What is a wtf folder? How do I delete it? Why would I want to delete it?

In all seriousness, my prime suspect here would be any addons you have installed for the game. Go into your addons folder and delete any mods you’ve downloaded. After that, if you’re still having problems, run the repair utility in the WoW directory. Pretty sure the file is called “repair”. It takes about 45 minutes on an average computer. If the problem with your mouse interactivity with WoW is a software issue in the game itself, that’s 99% certain to fix it.

Another possibility is that you’ve changed some settings inside the game. Go over each of the settings (there are 3 or 4 that relate to mouse performance) and tinker with them to see if any combination of settings fixes the problem. If you recently changed settings and remember what the original settings were, that’s a good place to start.

I have no addons so I’ll try the repair.