WTF is up with my taskbar?

I have a laptop at work connected to a docking station, with a 17" monitor attached. While at work, I use the dual monitor setup to keep the LCD on the laptop and the monitor both going at the same time, it dramatically increases my efficiency of reading the dope.


Anyhow, lately it has started acting wierd. Usually the taskbar (you know, the little bar with the START button on it) is on the laptop LCD, along with all of the icons normally on the primary monitor. But lately, when I boot up, it’s deciding it would rather be on the 17" monitor instead. All of the regular icons remain on the laptop monitor, however, and the laptop monitor identifies itself as monitor 1.

If I fire up the laptop sans docking station, it behaves as it should, with the taskbar appearing in the normal place. But every time I boot up with it connected to the dock, I have to move the taskbar back to the laptop. I’m at a loss for what to do about this…I have no idea what setting I woudl mess with to adjust this.

Is the taskbar locked? It is possible you dragged it over to the other monitor, and you are sure the one monitor is set as the primary because it would the taskbar and icons by default

If you right click on the desktop, choose “Properties” and then choose the “settings” tab, you should see a picture with two blue rectangles numbered 1 and 2, representing your two monitors. Click the one that you want to be the primary monitor, and check the “Use this device as the primary monitor” checkbox that should be at the bottom of the dialog box. The secondary monitor should only have the “Extend my Windows desktop onto this display” box checked.

On the other hand, if you already know about this setting and that’s what you meant by “move the taskbar back to the laptop”, then I’m stumped too.

Yes, the Laptop is identified as the primary monitor, and the other is the “extend my desktop to this monitor”

I never dragged the taskbar over there, ever.

When I boot up, I get the standard icons (Internet explorer, recycle bin, etc) on the laptop monitor, but the taskbar shows up on the other one. It’s mystifying.

This Microsoft KB article suggests that the way to fix it is to go into the desktop settings, and unset then reset the extension on to the second monitor. Hope this works for you…

I’ll give that a shot, even though I h ave never changed the primary monitor on this PC. We’ll see how it works when I boot it up next.

I am happy to report that seems to have solved the problem. Thanks, Dead_Badger!