The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 03-18-2007, 02:13 AM
diggleblop diggleblop is offline
BANNED
 
Join Date: Jun 2006
Posts: 1,870
How do I set which program opens my pictures in XP?

Every time I click on a jpeg, Photoshop opens the pic. I know there is a way to change which program opens pictures, but I forgot and Windows built in Help isn't helping me.
Reply With Quote
Advertisements  
  #2  
Old 03-18-2007, 02:23 AM
ParentalAdvisory ParentalAdvisory is offline
Guest
 
Join Date: Apr 2003
Right click on the file. You'll see "Open With", and a submenu for "Choose Program..."

After you've chosen your program, there's a check box that will give you the option to "Always use the selected program to open this type of file".

But in case you change your mind in the future and do want to open the file with Photoshop, you can always go back to the "Open With" menu and Photoshop will be an option in the list of compatible programs for that type of file.

Last edited by ParentalAdvisory; 03-18-2007 at 02:25 AM..
Reply With Quote
  #3  
Old 03-18-2007, 06:02 AM
Chief Pedant Chief Pedant is offline
Guest
 
Join Date: Feb 2007
Quote:
Originally Posted by diggleblop
Every time I click on a jpeg, Photoshop opens the pic. I know there is a way to change which program opens pictures, but I forgot and Windows built in Help isn't helping me.
Try this:

http://support.microsoft.com/kb/306551

There is a checkbox to "Always use the selected program to open this kind of file."

I think that's what you are looking for.
Reply With Quote
  #4  
Old 03-18-2007, 06:09 AM
Chief Pedant Chief Pedant is offline
Guest
 
Join Date: Feb 2007
Quote:
Originally Posted by diggleblop
Every time I click on a jpeg, Photoshop opens the pic. I know there is a way to change which program opens pictures, but I forgot and Windows built in Help isn't helping me.
I leave the file associations with the apps I want to use most of the time and use Open With for the the times I want to make an exception.

How to Associate a Program with a File Type

To specify the program that opens files with certain file name extensions:

1. Click Start, click My Computer, and then locate and open the folder that contains the file type that you want to use.
2. Right-click the file that you want, and then click Properties.

File Types That Are Recognized by Windows

If the file type is recognized by Windows, the type of file and the program that is used to open the file appears next to Type of file and Opens with on the General tab.

To change the program that is used to open this type of file:

1. On the General tab, click Change. The Opens With dialog box appears. Use one of the following methods to select the program that you want to use to open this type of file:

In the Programs list, click the program that you want.
Click Browse, locate and click the program that you want to use, and then click OK.
Click Look for the appropriate program on the Web to browse for the program that you want on the Internet.

2. Click to select the Always use the selected program to open this kind of file check box if it is not already selected.

3. Click OK, and then click OK.
Reply With Quote
  #5  
Old 03-18-2007, 11:14 AM
YWalker YWalker is offline
Charter Member
 
Join Date: Feb 2001
Location: NC
Posts: 1,126
I have a similar problem, but the file in question isn't one that I have in a folder that I can set properties on.

I've had trouble in the last few weeks getting updates for my computer. I recently installed Paint Shop Pro, and ever since then, I haven't been able to do the updates. I get the prompt that there is an update available, and then I hit OK to download the update. This automatically opens up Paint Shop Pro, and then I get a message saying that it can't open the .msp file (that presumably contains the updates.)

So, apparently Paint Shop thinks that everything with the .msp extension belongs to it, but it it not the appropriate application for this. Any suggestions?
Reply With Quote
  #6  
Old 03-18-2007, 04:08 PM
diggleblop diggleblop is offline
BANNED
 
Join Date: Jun 2006
Posts: 1,870
thanks, guys !
Reply With Quote
  #7  
Old 03-19-2007, 01:00 PM
rowrrbazzle rowrrbazzle is offline
Guest
 
Join Date: Jul 1999
Quote:
Originally Posted by YWalker
I have a similar problem, but the file in question isn't one that I have in a folder that I can set properties on.
Here's something you can try, but apparently you need to be an admin to do it. In XP, start Windows Explorer, click on tools/folder options, then click on the "file types" tab. Find the extension, and then you can change the association.
Reply With Quote
Reply



Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.