The Straight Dope

Go Back   Straight Dope Message Board > Main > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 06-20-2007, 08:11 PM
chorpler chorpler is offline
Charter Member
 
Join Date: Apr 2002
Location: Vegas, baby!
Posts: 3,253
Why do quotes show up as """ in some places?

Sorry if this topic has been addressed, but I can't seem to get Google or the search engine here to properly search for """. This seems like it should be something simple, but to my everlasting shame I can't figure it out.

If I recall correctly, there are lots of HTML (and presumably XML) codes for symbols like the quotation mark, the ampersand, etc. And you can put them in your document using these codes. So how come my browsers don't always convert " into a quote? Do I have some setting wrong, or is this a problem with those sites? I'm using Opera 9.20, but the same thing happens on Internet Explorer and Firefox, so I don't think it's the browser's fault (though of course I could be missing something).

The particular instance that has irritated me enough to ask this question, thus opening myself up to the extremely high likelihood of looking like a moron, is that I'm trying to read the forums for the illustrious webcomic The Order of the Stick. Their forums use the same software the SDMB uses, vBulletin. But for some reason, lots of their quote marks show up as " instead of quote marks. Take a look here:

http://www.giantitp.com/forums/showthread.php?t=4992

The second post shows up like this for me:

Code:
Well, I always figured Vaarsuvius was pronounced like Vesuvius, jsut
with an "ar" in place of the initial "e". And Xykon I
always thought was "Zie (rhymes with die or fly)- Kon (rhymes with
pawn or gone)"
Obviously it's difficult to read posts that are filled with that kind of thing.

I've tried changing the encoding on my browser to UTF-8, or ISO-8859-1, or ASCII, or ANSI, or ... etc., and I've fiddled with a lot of other settings, but nothing has changed it so far. Could somebody please point out what I need to do, so I can get on with hanging my head in shame at my idiocy? It would be greatly appreciated.
Reply With Quote
Advertisements  
  #2  
Old 06-20-2007, 08:17 PM
Arnold Winkelried Arnold Winkelried is offline
Charter Member
Charter Member
 
Join Date: Oct 1999
Location: Irvine, California, USA
Posts: 14,822
I get the impression that in vBulletin (at least the version we use at the SDMB) HTML name codes don't work but HTML number codes. For example, the quote mark is decimal 34.

If I type in " it will end up like this: "
If I type in " it will end up like this: "

(for examples of name codes and number codes you can see here:

http://home.earthlink.net/~awinkelri...shortcuts.html )

Last edited by Arnold Winkelried; 06-20-2007 at 08:18 PM.. Reason: fixed coding
Reply With Quote
  #3  
Old 06-20-2007, 08:21 PM
Arnold Winkelried Arnold Winkelried is offline
Charter Member
Charter Member
 
Join Date: Oct 1999
Location: Irvine, California, USA
Posts: 14,822
So, to be more clear, if the HTML source code contains this: " then your browser will translate it to a quotation mark. If the HTML source code containssomething like this: " then your browser will translate it to "

Is that clear as mud?
Reply With Quote
  #4  
Old 06-20-2007, 08:22 PM
chorpler chorpler is offline
Charter Member
 
Join Date: Apr 2002
Location: Vegas, baby!
Posts: 3,253
Quote:
Originally Posted by Arnold Winkelried
I get the impression that in vBulletin (at least the version we use at the SDMB) HTML name codes don't work but HTML number codes. For example, the quote mark is decimal 34.

If I type in " it will end up like this: "
If I type in " it will end up like this: "

(for examples of name codes and number codes you can see here:

http://home.earthlink.net/~awinkelri...shortcuts.html )
So let me see if I understand ... it's probably caused by the browser software (which people are using to post their messages to the board) rendering quotes as the HTML name code """, and then vBulletin not being able to render those properly when it comes time to display them? Which means there's nothing I can do to fix it?

Funnily enough, the notification of your reply that I received by e-mail, which I read in Pine, showed up like this:

Code:
Hello chorpler,

Arnold Winkelried has just replied to a thread you have subscribed to
entitled - Why do quotes show up as """ in some places? - in the General
Questions forum of Straight Dope Message Board.
Heh heh ... even Pine knows to show HTML name codes as the character they represent, so """ shows up as """. Strange that vBulletin doesn't.
Reply With Quote
  #5  
Old 06-20-2007, 08:27 PM
chorpler chorpler is offline
Charter Member
 
Join Date: Apr 2002
Location: Vegas, baby!
Posts: 3,253
Quote:
Originally Posted by Arnold Winkelried
So, to be more clear, if the HTML source code contains this: " then your browser will translate it to a quotation mark. If the HTML source code containssomething like this: " then your browser will translate it to "

Is that clear as mud?
Wait, so it's not vBulletin having a problem displaying named HTML codes instead of numbered ones, then, but rather a problem of the initial ampersand in the HTML code being converted to an HTML code itself?
Reply With Quote
  #6  
Old 06-20-2007, 08:27 PM
Arnold Winkelried Arnold Winkelried is offline
Charter Member
Charter Member
 
Join Date: Oct 1999
Location: Irvine, California, USA
Posts: 14,822
chorpler, as my second post implies: if I type in " then vBulletin will be "smart" enough to change it to " when it stores the text of my post in the vBulletin database. The text of the post is retrieved as " which your browser correctly renders as "
Reply With Quote
  #7  
Old 06-20-2007, 08:28 PM
Arnold Winkelried Arnold Winkelried is offline
Charter Member
Charter Member
 
Join Date: Oct 1999
Location: Irvine, California, USA
Posts: 14,822
I think you've got it. Try looking at the source code of this page.
Reply With Quote
Reply



Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Send questions for Cecil Adams to: cecil@chicagoreader.com

Send comments about this website to: webmaster@straightdope.com

Terms of Use / Privacy Policy

Advertise on the Straight Dope!
(Your direct line to thousands of the smartest, hippest people on the planet, plus a few total dipsticks.)

Publishers - interested in subscribing to the Straight Dope?
Write to: sdsubscriptions@chicagoreader.com.

Copyright 2013 Sun-Times Media, LLC.