ArcMap/ArcCatalog question

I’m just learning how to use ArcGIS (version 10.0). I want to make a new table, but when I go through the New Table… dialogue box in ArcCatalog, I end up with a table which only has column headings, but no data and no empty cells where I could enter data. What’s going wrong?

Here is an example of some of the test data I’ve been trying to use. I saved it in a text document with the name Test.txt.

I get x, y, ID, and color as column headings, but nothing else.

Alternately, since this is probably too specialized a question for this board, what’s a good place to get help for these sorts of things?

I haven’t used ArcGIS in a long time, but the ESRI forums always helped me when I got stuck. It’s closed to new questions, but chances are someone has had the same question as you:

http://forums.esri.com/forums.asp?c=93/

Are you trying to create a dBase table or a table in a Personal or File Geodatabase?

I have no problem createing a dbase table under a folder. I then can right click on the table to add fields. Then, drop the table in a ArcMap session, start editing and add data.

Usually, you create a shapefile (or other feature class) by either creating the features first – polygons, points, lines, etc. – then, creating attribute fileds (table columns), and then filling in the attributes (there are different ways to do this – directly in the table is one way).

Or, if you want to plug some existing attributes that you already have (say, in an Excel table) to an existing shapefile, you have to make sure that at least one field (column) in both the shapefile and the new table has exactly the same attributes; and then you use the “Join” command.

But it seems like you are interested in creating an attribute table for a shapefile (or other geographic feature class) which doesn’t exist yet. That’s unusual for GIS, but I’m sure it happens. Sounds like you already found a way to do it – “New Table” – but it’s not working the way you want it to. Well, I’m sorry I’m not helping you much with that specific issue, but at least maybe I’m helping you put your stated workplan in the context of how things are more commonly done.

The one time I often create a table all by itself before a shapefile exists in in the case of GPS points. You generate a table by taking points with your GPS, entering attributes in one or more columns (either “in the field”, or back on your computer, using Excel or maybe the GPS’ own software). Then, you convert these into a point shapefile in ArcGIS, using the “Add XY features” command. At least, I think that’s what it’s called. It used to be that this would create a temporary “event” file (stupid name for it – it always made me think of trying to park near a stadium for a rock concert or something!), which you then had to “export” as a permanent point shapefile. That process may have changed in 10.0.

I don’t think you can edit in Catalog. You will need to do it in an ArcMap or ArcView session.

ETA: What enipla said. Right click in the Table of Contents, create a dbase table, create the field names (what you called “column headings”) – being sure to specify if they’re numbers or text – and then enter the data. Careful, there are different options for how to display the Table of Contents(e.g., “selecteble layers”, etc.), and your table name will show up differently depending on this.

It sounds like your basic issue is in failing to understand how ArcGIS demands that you handle the column headings (field names) and the actual entries differently and as separate actions.

And, enpla just made a good point. I didn’t catch that you’re trying to do this in “ArcCatalog”. Nope, that’s just for organizing, copying, etc. your data sets (shapefiles, etc.), and for things like changing the metadata or assigning projections, coordinate systems, and the like. You can SEE your attribute field names there, but you don’t actually DO anything with the data in them there – all that is done in ArcMap.

I had been trying to create a table in a Personal or File Geodatabase (not sure which of those two). I also tried creating a dBase table in a folder just now, to see if that would work better.

In both the personal database table and the dBase table, I can’t right-click to add more data, except adding new fields with “Add Field” under the Table Options button. The same is true in ArcMap. I’m stumped.

My goal is to create a dialect map of an area. Right now, I’m just trying to get some points (representing cities) at specific coordinates on the map, with data (dialect features) associated with them. If you know of another, better way to do this than what I’m trying, I’d love to hear it!

Try this:

Create your table in Excel, with the first row being your future field names.

Then, in ArcMap:

File…Add Data…Add XY Data. Browse to your Excel file.

It’s best to take the moment now to assign the coordinate system. Maybe you’re using decimal degrees? (E.g., 35.034 -82.595)

Then, you should have a temporary point “shapefile” (not really a shapefile, but looks like one) with an attribute table with fields (columns) and data in each column, for each row (feature, that is, each point). I think you still have to then export it to make it a true, permanent shapefile, but I could be wrong about that.

And, as epla said, the Help menu in ArcGIS is actually pretty good, for most things, so give it a try if you get stuck.

You know, that was the first thing I tried, but I ran into a different set of problems. I can import the data with no problem, and I can clearly see the data in the table and plotted on the map. But, then the program tells me that the data needs to have Object IDs, and the way to do that is to export the XY data. I try to export the XY data using Data -> Export…, but when I try to save it, no matter what file name or file path I give it, I get the error “Output name is not valid.” If I try to change the name and then save it, I get the error “An error occurred trying to save the object named (name).” Any idea what’s causing this?

Is this a dbase table? I believe column names are limited to 10 charactors.

That may be true, but it shouldn’t be a factor here. The original column names were only “Latitude” and “Longitude.” But, you’re right that the column names might be an issue, so I renamed them “lat” and “long” to eliminate the possibility that the length or capital letters were causing the problem. I tried to save that again, and got the same set of errors.

Here’s the whole file, if anyone is curious-- should be easy enough to copy/paste it into Excel.

I need to re-read this thread, then I’ll fool around with the data.

Hmmm… worked for me.

When you export the data out of ArcMap, it trys to put it in a .gdb file. Do you have a valid FILE geodatabase to put this table in? If not, you can create one in catalog.

Oh, genius. It wasn’t the problem you identified, but the problem was that I was trying to save it in the wrong file type-- I had been trying to save it as a File and Personal Database file, but, if I just tried saving it as a shape file, .shp, I was fine.

Let me see if I can get everything to work now.

Great. I could email it to you if you want.

Great! Thanks so much. I’ll let you know if I need that.