ArcSoft photostudio 6 no longer supported, and my copy of it no longer works. Fixes?

For long and long I’ve been using ArcSoft photostudio, and last upgraded with photostudio 6 back in 2012, and it did work nicely for me.

But now when I open it, I get a notice asking me for my licensed email and my activation code. Now, I HAVE those things, yet when I enter them it tells me my activation code is incorrect, and directs me to the Arcsoft helpdesk.

However, when I queried the helpdesk about how I could get the damn thing up and running again, I got this response:

:mad: :mad:

Any ideas as to how to jigger this so my faithful old program comes back to me? It had been working after upgrading to Windows 10. It was even working after replacing my hard drive recently.

Or should I just bite the bullet and buy the latest version from them? I am semi-able with their product, or at least had been since starting with the old ArcSoft 2.0 and I’d like to stick with a somewhat known quantity, even though they pissed me off by refusing to help support their old product. Just like iTunes won’t help me with my iPod classic anymore. (Fortunately I was able to workaround Apple’s lack of support for that.

However, I don’t even see that they offer a photostudio product anymore, so I’d really like my old relic to work again, or perhaps someone can suggest a similar one that’s available. Even a free one, I don’t need a ton of bells and whistles.

thanks for your consideration.

It looks like there were no later versions after 6. It seems when they said “this program is no longer being maintained or updated” they meant all versions.

It’s strange that it’s no longer working, though, as it doesn’t seem to be an issue with your OS being upgraded. I’d try contacting them again and getting a non-automated response. Even though it’s no longer being sold, maintained or updated, it should still work.

There’s always Gimp, which is free.

ETA: According to the download available on Softsonic’s website, Windows 7 was the last compatible version. It could be an issue with now using Windows 10. You can try completely uninstalling and reinstalling with the link below and see if your activation code works. If that doesn’t work, I’d assume it’s a Windows compatibility issue.

You have a few options.

  1. the free open source photo editor Gimp might work. It’s a bit of a learning curve as Gimp is positioned as a rival to Photoshop - ie, it is a fully fledged complex image manipulation and design tool. Simple editing is possible but it might take a while to learn the tools.

  2. the “lite” online version of Photoshop - - which does everything I want to do with photos in a familiar way (I used Photoshop 4 & 5 many years ago) - but it is very limited

  3. if you have a valid license for a discontinued product, I dont think that that is a reason to cut off your use of that product. I’m not sure of the legality in your state/country but there are ways to obtain the software that you paid for via… let’s say… alternative means. A Google of the software’s name will give you some hints here.

thanks, you two. I shall explore those options.

This may or may not work, but try setting your computer’s clock back several years.

Hmm, I tried running uninstall, but was told “the specified module could not be found”, in reference to RunDLL32.

Never had that happen before . . .

well, eventually managed to uninstall, re-install, and I still get the demand for email and activation code. So off to try other options. . .

Can you just hit enter at the demand for email & validation codes?

I have some software that does that (Quicken) but I just hit enter then (and it asks twice more), but after the 3rd time it goes on to open the program.

Nope. repeat attempts yield continued failure there

Maybe this is one of those pieces of software that called home every so often to keep it alive/licensed and the company is no longer accepting the “call home”, rendering the software useless.

The smart companies modify this so that for a month or two before turning it off, it sends a reply notifying the user that it will stop working soon. And they include an offer for a special ‘long-time users’ discount on an upgrade to the current version of the software.

But it sounds like this company no longer offers* any version* of this software. In that case, the options are:

  1. find a way to make it work, via an online users group, internet searches, etc. (If it was working in Windows 10 before, that might be possible.)
  2. switch to a new graphics program. I’d look first at the free, open-source ones.

I used Photoshop for years but I now prefer Gimp even aside from cost considerations. Just an FYI, one thing that helped me when I started using Gimp is that if I couldn’t figure out how to do something I Googled for a tutorial on the particular function I was trying to do. It’s incredible how much information is out there for the product, especially with step-by-step videos.

Gimp is sounding better and better. As soon as I get some time I’ll give it a go. It looks like I’m done with Arcsoft. Whatever we had once is gone.

thanks for the tips.

You should, of course, check that your Windows firewall/ AV firewall isn’t blocking the registration request.

I frequently plug Affinity Photo. (Wikipedia link that contains other links.) It’s $50. The interface is a lot closer to Photoshop, and slicker than GIMP.

The company is making a serious push for people who don’t like Adobe’s move to subscription. Their Design program is a valid replacement for Illustrator, and their page-layout app is in beta. There are Mac and Windows versions, as well as tablet versions. The programs do some things better than Adobe, some thing worse, and there are some “missing” features. (No GIF animation, etc.).

Definitely worth a look. There are many well-done tutorial videos.
For me, the biggest learning issue is that everything is on a separate layer, unless you manually group the layers. It’s easy to generate hundreds of layers, and then realize that the reason your Color Balance adjustment isn’t showing up is because it’s being applied to a Contrast adjustment layer.