Athlon 64 X2 only runnin one core!

Man, I feel like such a novice.

Here’s the story: Two months ago I built a new uber-rig. Among other things, it included an Athlon 64 X2 4200+ and an Asus A8N32-SLI Premium motherboard (BIOS rev. 1009). After it was built and Windows installed I installed the proper drivers for the CPU along with the Cool 'n Quiet drivers. Checked device manager, confirmed two drivers (one for each core) were installed. All well and good.

Now, this evening, while trying to troubleshoot another problem I discovered something shocking: After installing a couple of AMD tools I didn’t have before (CPUInfo and AMD Power Monitor) I learned I was only running on one core! ONE. FREAKIN’. CORE.


Anyone have any idea how I’m supposed to enable the second core? I always assumed it was enabled by default!

Here’s some relevant info (apart from the mobo and CPU info above):

OS: Windows XP Service Pack 2
Drivers/patches: X2 drivers (, Microsoft AMD 64 X2 Hotfix, Power Monitor, Cool 'n Quiet

For the record:

  • There are no BIOS options that have anything to do with dual core processors.
  • I’ve scanned the registry but found nothing I could identify as being useful.
  • I’ve googled and failed.

Any ideas here?

I’m not a Windows guy, but does this seem applicable to your situation?

After a month or so of research I’ve that same board on order at the moment and will be installing it tuesday with a x2 3800 cpu.

From the bit of reading I’ve not heard great things about “cool and quiet”. That said, I haven’t dug real deep and I never install the extra motherboard utilites anyway.

Perhaps before doing the registry hack Hoops listed, just uninstall the cool and quiet utility and see if that fixes the problem. If not, you can always reinstall it.

I’m interested to know how this works for you.

Do you have XP home or XP pro? XP home will intentionally run your CPU as if it only has one core.

Another problem I’ve heard about is that some motherboards don’t do a warm shutdown and restart properly. If you completely power down and restart, does it run both cores? I don’t know what the fix is if this is the problem, other than always doing a hard power down when restarting.

I’ve also heard of problems with dynamic clocking and dual CPUs. If your board has an option for dynamic clocking in the bios you might try disabling it.

      • This is false. XP Home does only support one CPU, but it will support dual cores on one CPU–but it will only report the hardware as one core on one CPU. XP Home will not support multiple CPUs.,,7832_8366_7595~95364,00.html

I’m running XP Pro.

I located and installed the hotfix Hoops alludes to but didn’t do the registry hack. I just did, but it didn’t make a difference – I didn’t really think it would as even if the problem listed there did apply to me it would only have been peripheral to the main problem, which is the lack of a second core being in use.

I did disable Cool 'n Quiet on the motherboard and uninstalled it from the system, as well as performed a cold boot, but none of that made any difference. For the hell of it I also set the overclocking profile to “normal” (as opposed to “Overclock” or "A.I. N.O.S.) just on the off chance the CPU would simply run at normal operational speeds, preferably on both cores. Nada.

I even tried deleting the CPU drivers - though it would only let me do one at a time – but that didn’t help either. Maybe it’s time to pay safe mode a visit…

I even went to the Asus website and checked the forums (haven’t posted there yet – I probably should) but there don’t appear to be any posts there pertaining to this problem.

So, thus far, nothing. And I really don’t understand it. BIOS reports that it detects that I have a dual core processor and notes there are two cores there. Windows has installed two CPU drivers, indicating that it is aware that there are (or at least are supposed to be) two cores. It just isn’t using both.

      • While I am not capable of detirmining this with absolute certainty on your computer, XP Home’s own Device Manager will NOT show you multiple cores or CPU’s, even if there is a dual-core CPU in use. It will only EVER show you one core on one CPU, even if you have a dual-core. There’s a webpage on the AMD site that explains this but I could not find it.

…Another possible option you might try is to look up some free benchmarking software that has “ratings” for different setups. Do a CPU test and if your PC is only really using one core, the results will show that because its score will be far below what a dual-core should have scored.

Running XP pro on the new IMac. Task Manager/Performance showing two performance graphs. FWIW.

Have you run any benchmarks to see if the performance is as expected? Maybe it is working and you just can’t see it.

That’s sort of what I’ve been thinking. From what I’ve been told it’s highly unlikely that one core isn’t working, and that even if it was my speed ought to be half of what it is (based on the idea that the X2 4200 is 2x1100MHz cores). I’ll have to reinstall Sandra again and see what it has to say.

Okay, I think I’ve pinpointed where the problem is. It isn’t the processor drivers, it’s the HAL profile. Apparently when I built this system, upon installation, Windows XP, in its infinite wisdom, chose the plain-jane “Advanced Configuration and Power Interface (ACPI) PC” HAL – hal.dll – not the more desirable “Uniprocessor PC” HAL –


. See, with the plain ol’


I have two hardware abstraction layers to choose from: The ACPI profile, and the Generic PC profile. Had XP done the right thing and gone with


I could have simply updated the driver from Uniprocessor to Multiprocessor PC. According to Microsoft, the only way I can alter my HAL now is to reinstall (or I presume perform a repair install) XP, using the F7-at-RAID-prompt trick.

Is there any other kind of shortcut I can take to avoid having to do the repair install? I’d really rather not if it’s at all possible. (Note: I tried the hack wherein one renames and replaces






to fool the OS into using a different HAL; all that did is make my system unbootable, forcing me to load up Winternals and put everything back where it belonged)

Incidentally, reading AMD’s forums confirmed what I feared: If my system isn’t showng individual cores and doesn’t let me view separate graphs for each core, it isn’t actually using both cores, so indeed … my computer is presently half brain-dead.


So yeah. An easier way than repair install? Is there such a beast?

I am a coding moron.

That is all.

Solved it!

For those interested (because apparently this isn’t entirely uncommon) the problem was indeed the wrong choice of HAL on initial installation of Windows. I initiated a repair install and, at the first “Press F6 if you want to install RAID…” prompt, I hit F5 to bring up the manual HAL selection screen (which only shows two items at a time, so scroll to find the one you want) and selected “ACPI Multiprocessor PC” and continued to go on with a repair install. Amazingly, this install went absolutely perfect (where my first install was fraught with problems requiring me to compeltely disable ACPI in order to get Windows to install at all) and in 45 minutes, once all was completed, I was back in my familiar Windows desktop, and task manager’s performance tab was finally showing two CPU graphs!

My status as “moron” has been mitigated. I once again rule my private domain. :smiley: