Both CD drives say "no disk in drive". Any ideas?

I have 2 CD drives, both Lite-Ons. One is CD burner, One is DVD-RW.

For some reason, neither will allow me to write files to a writable CD. When I click the “write these files to cd” line, it asks me for to name the disk (this is normal), then when I click “next”, it says “there is no disk in the drive”.
Has anyone encountered this before?
PS. It’s an emachines (T2542), and Windows Office 2003 OS.
Thanks for any help.

It might be a jumper issue (make sure one is master and one is slave) but more to the point… the CD burner is redundant, as the dvd-rw will burn cds.

I had one computer that did that ALL the time, about the only time I could burn a CD was immediately after a reboot with the blank CD already in the drive. I was able to fix that by using a program called autofix.exe. It is free, and put out by Microsoft. Make sure you only download it from a Microsoft site. You can be reaonably sure it is safe if you get it from there.

I know that is not the problem that program was designed for, but it worked for me.

And Lobsang, many DVD-RW drives, especially older ones, are dreadfully slow at burning CD’s. Especially compared to a $35 52x CD drive. It will also save wear on the more expensive DVD-RW drive, especially if you play a lot of games that read from the CD constantly. It doesn’t seem redundant at all to me, I have both in two of my computers.

Lobsang, I checked the jumpers. Here’s the setup: The end of the ribbon cable is labeled “master” and the connection in the middle of the cable is labeled “slave”. The end of the cable is attached to the DVD-RW, and it (the drive) is jumpered as Master. The middle connection of the cable is attached to the CD-WR drive, and it is jumpered as Slave. I think this is all correct.

MC$E, the only autofix I find on MS’s website is “scandisk/autofix”. Is this what you were recommending?

This is the one I was talking about:


I have had this problem before on various machines. The built in drag-and-drop write files to CD feature of XP relies upon autoplay to tell it you put a blank CD in the drive.

If you have turned off autoplay, either inadvertantly or on purpose, then the write to CD feature never gets the word that you’ve inserted a CD and it sits there foreever compainig that the drive is empty. It isn’t smart enough to look for itself.

The Aotofix.exe that MC$E linked to just resets a couple of registry settings to turn autoplay back to normal, and viola!, you should be in business.

Tried running autofix. It didn’t seem to find anything wrong.

Problem still there.

Should I try disconnecting one of the drives (slave) completely? I can open the case and do that pretty quickly. If I do, what changes do I need to make in the control-panel?

If the computer actually recognizes that the drives are there (they are visible when you double-click on “My Computer”), this is probably not the problem.

Have these drives worked normally in the past?
Do you have a CD or DVD that has worked normally in these drives? Do they still play?

Hmmm. It may be a small goof-up in the registry: if you reboot and have CD XYZ in the drive, then you take it out and put in CD 123, does Windows still insist that XYZ is still in the drive? (As in, you bring up Windows explorer and navigate to the drive, and it’s still showing the contents of XYZ and not 123 like it should no matter how many times you refresh?)

If it’s doing that, and effectively will only deal with 1 CD a reboot, then there’s something to tweak in the registry to get it working properly again.

Unfortunately, I can’t remember what it is at the moment (been awhile since Ive had to do it), but if that’s the symptoms then I’ll hunt around for the fix. If you aren’t comfortable with registry editing, I belive there’s a script I have in my backup files that’ll do it for you.

<< Sith happens. >>

Yes. The drives have worked normally in the past. Right now, the DVD-RW drive is contentedly playing “Out of Gas” (Firefly) while I type. Both drives read OK, and even detect new media placed in them (will start music CDs without asking). They just won’t write anything.

I’m stumped.

The only thing I can think of that changed, would be during the install of my cable-modem (I upgraded to broadband finally). At one point after the install, some of my Malware programs didn’t get along with the new modem software. Something important got deleted (by Spybot) and I had to do a system restore (just went back a few days). I can’t swear that’s when the trouble started, but I know before then I was burning CDs to turn in class homework; So I know it was working before the system restore… I can’t pinpoint exactly when it quit, tho’

Will the DVDR drive refuse to write both CDR and DVDR?

Is the blank media that you are trying to use (that can’t be written) the same type as the blank media that you’ve used in the past?

Can you try a different brand of blank media?

Something else:

It may be that your recent Spybot deletion has caused the drivers for the CDR/DVDR drives to be corrupted, causing Windows to forget that these are recordable drives, and are instead listing them as generic Read Only drives.

Try this - click on “Start”, then “Settings”, then “Control Panel.” Double-click on “System”, then click on the “Hardware” tab. Click the “Device Manager” button and then expand (click on the + sign) the DVD/CD-ROM drives entry.
Your drives will be listed there, and at least one of them should have a “writer” designation associated with the name of the drive.
A right-click on each of these drives will allow you to see details of the drive’s Properties. It will also allow you to update the driver for these drives.

Sorry - I can’t go any further that that because my drives are working OK and I don’t want to screw mine up, but I believe you will be taken to Microsoft’s website to download the correct drivers for the drive, or perhaps allow you to roll back any recent changes.

Using the same media (out of the same box) that I’ve been using.

I went to the device manager, but I’m not sure what the “writer” designation is.
It just shows a little icon of a CD, and its name: “LITEON DVDRW…”.

Maybe we’re onto something here. What does the “writer” designator look like?

Also, which operatimg system are you using?

Windows XP home edition, with an upgrade adding Office 2003. (and I’ve got Service Pack 2, as well)

Simply some verbiage that indicates that the computer knows that it’s a writer instead of a generic DVD/CD-ROM.
The “LITEON DVDRW” indicates that the computer is at least showing the correct name for the drive, and not a “generic drive” title.
I suggest going to the manufacturer’s website and downloading the driver(s) for that drive. Try reloading the drivers.

I would say that either your drive has suddenly taken a dislike to the blank media that you are using (possible due to reduced laser power over time?), or that the drivers need to be reloaded.
It’s also possible that all discs of blank media, even within the same box, is not the same, or even made by the same manufacturer…

I thought of that. But am puzzled why both drives suddenly dislike every single remaining disk in the box. (Could be a manufacturing problem, and all disks below the 10th one are bad?) I’ll try some different media tomorrow. I’ll also check Liteons website for drivers.

I appreciate everyone’s help. I worked on this so long that I forgot to drink any beer tonight. I’ve gotta get my priorities straight. :stuck_out_tongue:

thanks again everyone… g’night

Urethra! I found it!

Bumping this in order to: 1) thank everyone again for their help; and 2) pass on what I found.


  1. I installed a LITE-ON DVD-RW drive in my computer, leaving the old CDROM drive installed as slave.
  2. I installed service pack 2 from Microsoft.
  3. Both drives stopped recognizing the presence of a disk when asked to write files (they did fine reading)

The problem: Both drives were LITEONs (both slightly older models). LITEON reports that some users have had a problem with writing CDs in certains models (guess which one’s I have).

LITEON (via Nero) has a series of patches (6 files) located here which will fix this obscure problem. It was just dumb luck that both my drives were LITEONs and both succumbed when I downloaded service pack 2.

(just passing this on in case anyone can use it)