Can someone explain why this link is failing?

Here’s the thread.

post #2 the last link that ends with .jpg

the roll over preview shows its a link to the photo. But try clicking it. It tries to bring up a straight dope page. :confused:

WTH happened? Maybe a mod could open it and look at the html source. Maybe fix it while you’re there anyway. :smiley:

But seriously, I’d like to know why the link rollover (shown at the bottom of the browser) isn’t what actually tries to load.

Link works fine for me.

I think its you - link(s) worked for me.

What browser is the OP using?

I’m getting a 404 with Chrome/Win7:

I’m getting the same error using safari on my iPad

It worked for me in Chrome, but I just tried in IE and I get a 404 trying to go to Vigilink, which is the ad software that replaces URLs with a hyperlink. I have an ad blocker in Chrome, which I’m guessing is the difference.


Now it’s not working for me either (giving the same message). Either my senility is far more progressed than I thought (what year is it today?) or that link’s behaviour changes!

Firefox. I just tried it on my tower pc. this time I’m getting the 404 not found

Maybe I should have cleared my laptop’s cache. <shrug> anyhow it just kept redirecting back to the SDMB.

This photo was in a slideshow. I had right clicked and view image put it in a new tab. That’s the link I pasted. I just tried it now and pasted the link into a new Tab. Works like a charm.

At first I thought maybe I pressed a key and entered an extra letter into the link without realizing it. But some people are saying the link works. I guess maybe their server is overloaded and sometimes gives the 404 and other times it works. Servers can do weird stuff when they get too many connections.


I think you pasted the link fine. I strongly suspect it is Viglink causing the problem.

I saw a picture at

That’s it. A wall and it’s naked. LOL

Well, I’m glad it’s working for some. Thank you for checking. I was kind of confused for a moment.

How many times now have we seen complaints about Vigilink mucking around with people’s links and getting them f-u’ed up?

I have viglink blocked.

Also, the link is now working for me.

Link inside my thread works great now. Whatever was going on got fixed.

What’s the deal with viglink? Is that part of the SDMB’s software or is it on the other end?

Viglink is a third party link tracking service that the SDMB uses. When you click on a link, instead of going directly to the link, you go to the viglink server, which tracks and counts the click and then forwards you to the link that you clicked on. It is supposed to be transparent to the user. However, if something gets screwed up, then it doesn’t work, or if the viglink server happens to be busy or the network between you and the viglink server is busy then the links can get slow or time out.

If viglink happens to give you problems, then you can disable it either using a script blocker or you can add to your ad blocking add-on’s list of sites to block.

We’ve had enough problems with it here that a lot of folks instinctively blame viglink whenever there is any kind of problem with a link. In this case, I’m not sure viglink was actually the issue since I was getting a 404 earlier on the link and I block viglink with a script blocker (so the 404 couldn’t possibly have been caused by viglink mucking things up). I’m not sure what viglink does if the link ends up going to a 404. Maybe then it redirected you back to the SDMB?

ETA: The SDMB gets money back from viglink for letting them track the links here. Don’t ask me how much money. I’m not involved in that and I have no idea.

This is just a test. These shouldn’t be real links. server not found 404 dude

Viglink apparently doesn’t have a problem with either a server not found or a URL not found (404).
Whatever issue you were having probably wasn’t viglink related.

I might be the outlier. My 404 error was looking for a URL on Viglink, but it sounds like I’m the only one that got that. Oh well, I can blame it on IE, which is the other whipping boy around here.

Interesting information on Viglink. Thanks.

It may have just been that newspaper server. It loaded pretty slow even when I went to it directly.

I use Flashblock for Firefox. That’s the only blocker that I use.