Can two Wifi cards conflict with each other?

Not static IPs, I already checked that.

My new USB wireless network adapter on my laptop will not connect when the desktop computer is on, but will when it is turned off. The desktop is connected to the router/dsl modem (an Actiontec Q1000 from Qwest) so I disabled the drivers but it still prevents the laptop from connecting. I’m going to pull out the card so long term not an issue, I’m just curious what could be causing the problem for future reference or any troubleshooting ideas.

Router/modem - Wireless-N compliant
Linksys USB adapter - Wireless-N compliant
dLink WDA desktop card - Wireless-G compliant.

Could be interference. If the connection is marginal to begin with then adding another client could be too much for your network. You can change the channel the router uses and see if it helps. In wifi there are 3 non-overlapping channels 1, 6, and 11. So if youre on 6, try 1 or 11.

A program called Netstumbler can show you networks in your area and what channels they use. Try to use one that is the least used. Things like cordless phones, baby monitors, and microwave ovens can also interfere. It may be that the desktop wifi is just robust enough to handle it but the laptop cant.

My subconscious tells me the MAC addresses are identical.

It’s a long shot, but theoretically, it could happen. A MAC address spoofer should do the trick, if that is indeed the problem

Doubtful if not impossible since the devices are from different manufacturers.

OP, Are there any issues with your router running dual or mixed mode? The G and N wireless modes might be part of the issue if it’s can’t run both modes at the same time. Is your USB device set up to automatically to drop to G when the desktop is connected?

That’s what I’m checking next. It is a linksys which means the drivers are crap. I pulled the desktop wireless card and got connected for a few seconds so I’m staring to believe it is a driver/windows XP and an astronomical coincidence that it worked the few times that I turned off the desktop.

Nah. I still think it’s a G/N thing conflicting

I have twice in my life had identical MAC addresses. In both cases we had a bulk purchase of identical units from the same manufacturer. One was an X-terminal, the other a Myrinet Card. It took a bit of convincing them that they had screwed up.

However units from different manufuactures is extremely unlikey, manufacureres tend to have allocated blocks of MAC addresses (i.e. the top 24 bits) and only allocate from them. Duplicates I have seen have been somehow not incrementing the low order 24 bits between units. Hence the issue when you get a bulk purchase. It is unlikey in the extreme it is duplicate MAC addesses here.

I would vote for the above suggestion of N versus G and an issue running both on the router.

I’m guessing it’s some sort of interoperation problem with using both .11g and .11n at the same time. This is actually fairly tricky to do right. 802.11n uses two channels simultaneously to get extra bandwidth, and this creates additional complexity when dealing with devices that do not expect such behavior. It’s probably the case that your device’s drivers can’t handle that for whatever reason. You might try disabling .11n on either the laptop or the router. The .11n standard was officially adopted only two months ago, so it’s very possible that you have devices that implement it incompatibly.

I’m rather assuming that this is 2.4 GHz .11n. Technically .11n is either 2.4 GHz or 5 GHz, but I’ve seen very few consumer 5 GHz .11n devices.

Are you using the Linksys Broadcom software to connect to your wireless network?
If so disable it and try using Windows Wireless Connection instead. I had a similar problems and this resolved them.

I think it’s highly unlikely the MACs are the same, but why not just check them?

What IPs are being assigned to the two wireless cards?

I assume you are using DHCP.
I assume Qwest’s router/access point will give out more than one IP address. I just hooked up a new N router to my brother’s Comcast cable modem gateway and I had to call Comcast to have them get the gateway to recognize the new MAC. Very annoying. Your router is an access point and ethernet switch as well and presumably should give out multiple IPs to multiple MACs, though, unless Qwest has crippled that function. In the olden days some providers would refuse to give out more than a single IP in an effort to get people to buy the next tier of service if they wanted to hook up more than one computer…
Can you get into the router config and see what IPs it is assigning? Under the wireless tab there should be a listing of all the IPs it’s assigning to your local network. Only the last set of digits should vary, but they should be different:, etc etc.

I know the USB Adapter works on a WirelessG network and when it does work in this house, it is Wireless N (300 Mb/s). My first instinct was that the router cannot handle both but still sends out the N signal while the desktop uses G so my USB doesn’t bump down to G.

Ah well, something to play with while I’m bored.

Disable N on the router and see if it makes any difference. Are you sure its in mixed mode (able to handle both n and g)?.

Today I tried to login to an unsecured router in the neighborhood and it was a no go. That told me it was either the driver or Windows XP - both of which are nortorious and have given me headaches in the past and not the the router mdem which I have no experience with.

Today I decided to install the linksys wireless manager rather than using the windows manager. Bingo! No problems whatsoever. Connected at 130 Mb/s which I believe is Wireless N on USBv1 port. So the verdict after having to do this twice - Windows XP (even with sp2) sucks @$$ when using their wireless manager. Win7 is much nicer.