Cannot download Updates for Windows

Hey, if anyone can help me out. I’m having trouble downloading updates in Windows, it seems like the firewall is blocking it or something. I can’t figure it out. I looked to find out what port windows updates download on, but I think it’s an HTTP or FTP download, which is odd because I don’t have problems downloading anything else. Anyone have any suggestions? I tried going through and any of the search strings I thought of just weren’t the right ones.


I can get to the Windows update page, and it scans what I need and lists it. The problem occurs after I hit “Download and install updates”

You sure you’re logged in with admin rights on the computer in question?

What happens when you try to download the updates? Does it say something like “Windows Update failed blah blah blah”? Also, you’ll need to make sure that certain services are running in order for it to work. But then again, we also need to know what version of windows you are on and stuff. Post some more details and we can help.

Make sure you have the BITS service running. Go to Control panel -> Administrative Tools -> Services and look for the Background Intelligent Transfer Service. Double click it and make sure it is running. Also, make sure the startup type is set to Automatic.

No Updates Were Installed

The following items failed to install. To try installing them again, click Review and install updates, and then click Install Now again.

Windows SharePoint Services Service Pack 1, English (KB841876)

The OS is Windows Server 2003 SBS and yes, I have administrator rights.

Thanks, :slight_smile:

BITS is running. So does anyone know the method that it downloads with? Is there a port I should look into unblocking? Is it HTTP, FTP???


Sorry, I have no experience with Windows Server. Purhaps some of the other IT guys can help you out. The only other thing I can think of is that purhaps a single prerequisite download or update must be installed first before the others can be installed successfully? Is there a newer service pack purhaps?

Yep, I had this happen on my (brand new) server just last weekend - the same one. I tried a couple dozen things, then just wiped the drive and started over. The Microsoft Knowledge Base has never heard of it. The problem did not recur on the second install; I still don’t know what caused it.

I’ve had many, many, many problems with Windows update on Windows Server 2003 SB – the reason I bought the new server was because the previous one bluescreened and required a repair install of the OS on EVERY windows update.

Best of luck to you.

I can’t quite remember the details of how to do it, but I overcame this by installing a block of required updates manually (it was something like: let the Windows Update thing suggest them, then follow some links to the update catalog, download one, install it, restaret, lather, rinse, repeat).

I think it was either just that some of the later updates were dependent on earlier ones, or that something about the semi-automated update client was (locally) broken and downloading a few things manually replaced it with a working version, because after doing this, the next batch of updates downloaded and installed OK the normal way.

Check your PCs date on the system clock.

I once had the same problem. It turned out that the updates were not downloading because my PCs system clock was set to a future date.

I had this problem and it turned out to be my Linksys router, which needed a different setting in a parameter called something like MTU which was the number of bytes in a packet or something like that.

i just had this problem a couple weeks ago and it was also the mtu setting. the tech at linksys told me to check the mtu setting for dsl it should be 1492 or under. that fixed my prob. i’d most definitely check with my isp first, then with the router mfg.

While it won’t fix the root cause, you can download and install that update manually from here.

OTOH MS/XP-Home is plagued with updates to be installed.
The last time I gave it permission to install SP-2 it screwed up XP something wonderful!
Had to go back to a prior configuration to get anything done.
You should be so lucky. :wink:

Thanks for all the help. For anyone who is interested the router is a Cisco Pix, which I actually don’t know much about administering. I’ll take a look at all the stuff people mentioned here though. I’ll probably download the updates manually.