Cannot print from XP SP2

I recently got a new notebook computer (Compaq Presario V5105CA) running XP SP2. For some reason, I cannot use it to print.

The computer has no serial or parallel port–just USB. I’m using a parallel (at the printer end) to USB (at the computer end) cable. The cable seems to work, and indeed, the computer can tell that there is a printer at the other end when I plug it in. But while it should be plug-'n-play, and everything seems to install just fine–the computer detects the USB plug from the printer and prompts me to load the printer drivers from disk–when I try to print a document, nothing happens. The document just sits there in the print queue. And yes, the printer (Canon ImageClass D680) is plugged in and turned on.

The printer works–I set up my old computer (running Microsoft ME), and it printed documents just fine. I did use the old computer’s parallel-to-serial cable for this test though.

Even though Device Manager does not show a problem with my USB port (and a quick test with a memory stick confirmed that the USB port is working, at least for a memory stick), I have a feeling that XP SP2 has something to do with it. I’ve looked at Microsoft’s support site and found nothing specific to this problem. On Microsoft’s support site, I did find a similar-sounding problem for another Canon multifunction product, but I’m leery of trying a driver for a product that while a Canon, is not my model of Canon. I’ve done various Google searches just to see if there’s anything out there anywhere, and I cannot find anything specific to my problem. However, I did find a lot of people having problems printing from XP SP2 for various reasons, so I’m leaning towards an XP problem.

Does anybody have any suggestions or can offer any help?

Have you tried going to the Cannon website and looking for the latest drivers for that model printer?

I have, and I’ve tried them. There was also a patch to take care of DEP errors–those did appear at first, but once I installed the patch, they ended.

But in spite of the latest drivers and the patch, I still cannot print.

It seems that SP2 disables your USB drivers (that were installed in SP1 originally). Go to My Computer/Hardware/Device Manager/USB Controllers & choose the 1st USB Root Hub. Then right click, choose Properties & Update Driver…it will then find the correct drivers & reinstall them.

Try that.

Rico, I tried your suggestion, but I still cannot get this machine to send a document to the printer. Thanks for the suggestion though–much appreciated.

I’ve been on the phone to a support tech, and he’s stumped. I’ll take the computer in tomorrow (it’s not a holiday here) so they can have a look at it.

Thanks again, guys!

Is printing paused?

To determine whether printing is paused:

  1. Click Start, click Control Panel, click Printers and Other Hardware, and then click Printers and Faxes.

  2. Right-click your printer.

  3. If Resume Printing or Use Printer Online appears in the menu, click this command.

  4. Then try to print again.

Update: Problem fixed.

I cannot explain it, but the problem lay in the cable connecting the computer to the printer.

Basically, the computer didn’t like a USB-to-parallel cable connection. When I tried a USB-to-USB connection, the computer printed documents with no indication it had ever had trouble doing so.

So, while I cannot figure out what the problem was, the problem is now gone. Thanks again to everybody who offered suggestions and tried to help.