Can't delete file

I downloaded a handful of games off some freeware site the other day, virus scanned, all that, they’re clean. A couple of them wouldn’t install, so I go to delete them. I get an error that says they’re in use by another program, close anything that might be using them and try again. I closed everything and tried again, same error. I rebooted, because that was what let me delete the file last time I had this problem, but immediatly after the reboot, before I had done anything else, I was still getting that error message.

I’m running Windows XP Home, if more information on the system is relevant, I can add that in. How do I get these stupid things off?

I forget - does XP have “boot to DOS” or “safe” mode? You could try one of those. What kind of games are they? Virus scanners often don’t include spyware and the like in their scanning. Spybot or Adaware could work better for you.

I have that problem too. Make sure all programs are closed.

In task manager: End process “explorer.exe”
In task manager: New Task “cmd”
In command promt: Type “del path\filename”
In task manager: New Task “explorer.exe”

Hope that helps.

I can’t figure out why explorer.exe is “using” random files, but for some reason it does from time to time.

In case no one’s said it already: Welcome to the Boards, hobophobic! (Afraid of tramps?)

Make sure you open your process list and make sure everything really is dead. “Make sure everything’s closed”, to some folks simply means looking for things that are visible. Then as Nanoda suggested, try safe mode or command prompt only.

I get this from time to time as well; often times renaming the file first will allow you to subsequently delete it.

I don’t remember if WinXP actually processes autoexec.bat like earlier versions of Win32, but if so, just add the appropriate delete commands there.

As a last resort I can post instructions for adding a few entries to a legacy .ini file which are virtually guaranteed to get processed before anything starts up.


I did a spyware scan, nothing. Yes, I know to click that other tab and see what all is really going. I don’t see anything on it that isn’t normally there, that would be likely to be using these things. I closed everything that wasn’t vital, and still nothing.

I tried hobophobic’s suggestion, and it told me it couldn’t find those filenames. So unless there’s something missing from that that I didn’t do. Which is possible, the amount I know about doing things from a command prompt is, in entirity, I used to be able to do the little 3 character string to access the contents of the floppy on our Tandy 1000. That rules out just adding the delete commands to the autoexec.bat too.

If XP has a safe mode, I don’t have any idea how to get into it, it’s not an easy thing to find like it used to be. So if anyone can fill me in on that, that’ll be my next try.

Anything beyond that, and I know just enough to know that I don’t know a whole lot, I don’t dare stat messing around with system stuff. At that point, I guess they just have to stay there until I can find someone who can actually sit down at this thing and mess with it.


Having tried all of the above, I highlighted them and pressed “delete” as something to do while I waited for a response. Without fail, for the last day or so, no matter what else I did, that resulted in an error that they were in use, close it down and try again. This time, they deleted…

I have no idea why, but hey. The only thing I can identify as changing was closing down explorer.exe and restarting it. Maybe that was what was doing it and it didn’t kick in again when it restarted. Either way, they’re gone now. I feel kind of dumb now. :stuck_out_tongue:

Thanks for the help.