File wont delete?

I have a video file on my computer that, whenever I try to delete it, it gives me an error message saying

I’ve closed all the programs but I still get the message. Any ideas on what causes this and how to fix it? I’m using Windows XP Home.

Try rebooting and then deleting (without opening the file or playing it or anything).

I’ve found that sometimes the system seems to think a file is still in use, but rebooting will clear it out. Worth a try.

I tried that, didn’t work. Thanks though.

Try booting in safe mode and deleting the file.

Well you could search for the process that has it locked and kill the process, or start shutting down services one at a time until the file will delete but if you aren’t familiar with what you are doing it can be a kinda hairy ride.

However here’s a link to a free utility that claims to do just what you want:

Disclaimer: Link found after at least 7 strenuous seconds of Googling. I have never used this utility and don’t vouch for it. Use at your own risk :slight_smile:

How do I boot in safe mode?

You can also try this little trick:
[ol][li]Open a command prompt window (window-ed, not full screen)[/li][li]Press ctrl-alt-del[/li][li]Press Task Manager[/li][li]Click on Processes[/li][li]Click on explorer.exe and click End Process (this shuts down the Windows’ GUI)[/li][li]Now in the command prompt window type del C:\filepath\filename <–insert real file name & path[/li][li]Again at the command prompt type explorer and hit enter (this starts the GUI back up)[/li][li]Close the command prompt window (type exit)[/li][/ol]
This will work if explorer.exe (which is the windows GUI program) is the application that’s using the file you’re trying to delete. You’re just shutting down the GUI, deleting the file, then starting the GUI up again. That’s why you have to open the command prompt before shutting down the GUI, else you’ll have no way to restart it (w/o rebooting).

Press F8 when the computer is booting up, after BIOS but before Windows get to the splash screen. It should say “Windows is now loading…” or something similar. Then choose SAFE MODE.

Press F8 while booting then highlight “Safe Mode” and enter. Good luck.

Is the file in question an .avi file? If so, I’ve had the same problem in XP Home.

I found the solution here. See post by LwdSquashman on deleting the registry setting.

It sounds like you’re trying to delete it in Windows explorer with a preview pane on, yes?

If so, the file is opened by Windows Media Player when you select it.

Right-click the file and rename it to “1.dat” - it’ll give you some warning about changing the extension, don’t worry about it.

Select different .avi or .mpg, to release the currect file.

Then right-click 1.dat & select delete.

You should be all set.

Too bas you have XP, in 98, whenever I had a file I couldn’t deelte and knew to be basically useless, I just botted up in DOS and zapped that sucker into oblivion, it doesn’t even go to the damn recycle bin! Next best thing to a ‘file shredder’ or reformat.