Can't rename/delete file in C:\windows\system32

I need to rename or delete a file in C:\Windows\System32 and Windows is telling me I need permission to perform this action. However, I have Administrator priveleges, and for a “rename” there is no “run as Adminstrator” option. How can I do this?

I installed Outlook 2010 Beta and had a lot of trouble with it so I reinstalled Outlook 2003 (you can only have one version of Outlook installed at a time). When I reverted back to 2003 I get a message that there is a problem with MAPI32.DLL. Microsoft has a program called FIXMAPI.EXE that is supposed to fix this problem, but in my case it seems to do nothing at all. I ran Repair from the install disk and that didn’t work either. So my next strategy was to remove or rename MAPI32.DLL and repair or reinstall. At this point Outlook will not run at all.

Could be a couple of things:

[li]It’s in use. Use Process Explorer to find the culprit and “search for handle”.[/li][li]It’s owned by “Local System”. Many don’t realize that there is a level of greatness above even Administrator, and that level is “Local System”. But you can log on as this all-powerful user: start up a command prompt using your normal Administrator user, then type: [/li]
at 12:01 /interactive cmd.exe

Instead of 12:01, put a time one minute from now. This will launch a command prompt as “Local System” since the Scheduler service runs as that user. From that (new) command prompt, navigate to \Windows\System32 and see if you can move the file.

I had this exact problem yesterday! Couldn’t rename a .dll; access was denied. Found this tutorialand it worked like a charm.

I used the manual method (about halfway down the page) in the cmd line, using the takeown command and then icacls. note: I did have to boot into safe mode to execute these, as I guess TrustedInstaller is always running in the background and won’t relinquish control in normal operating mode.

Microsoft Windows [Version 6.0.6001]
Copyright © 2006 Microsoft Corporation. All rights reserved.
C:\Users\CookingWithGas>at 17:38 /interactive cmd.exe
Warning: Due to security enhancements, this task will run at the time
expected but not interactively.
Use schtasks.exe utility if interactive task is required (‘schtasks /?’
for details).
Added a new job with job ID = 1

This worked beautifully, but unfortunately it didn’t resolve the root problem I am having :mad: I deleted the file, tried running Repair, still failed. Tried a reinstall. Still failed. I may have to do a complete uninstall/reinstall but then I’ll lose all my settings.

Do you have System Restore turned on?

You said you tried running repair, but did you try renaming the MAPI DLL then just running Outlook, and letting it fix things? Microsoft recommends that method.

Great idea. I restored to the point just before I installed Office 2010 Beta and everything is back to normal :cool:

A couple of things to note. First, my error in trying to remove the file was that I was trying to remove it from the wrong place. I first found the file in c:\windows\system32. I finally found a Microsoft help page that pointed me to a different directory, C:\Program Files (x86)\Common Files\System\MSMAPI\1033, and said to delete the file, and on startup Outlook would automatically fix itself. That actually happened. But then, Outlook would not respond to any mouse clicks in the mail list window. I could navigate it using the up/down arrows but could not click on mail to select or open it. That is a very bizarre problem. That’s when I decided to go ahead with the restore, after seeing your post.

Office 2010 Beta installation asks you if you want to leave prior versions. It forgets to tell you that you can’t leave the prior version of Outlook, but doesn’t allow you to opt out of installing Outlook. So that’s a severe flaw in the installation process. I don’t think it’s possible to pick and choose which components to install, the way I can for Office 2003.

Unlocker is a simple app that allows you to delete a file that’s locked by your system. After installation, just right click and choose unlock from the context menu.