Can't see Windows 10 shares on Puppy Linux

I just upgraded from Win 7 to 10, and everything went surprisingly smooth, but there’s one problem: I have a laptop with Puppy Linux and used to access my Windows 7 shares with a tool named Pnethood from there. That doesn’t work anymore after the upgrade to Win 10, Pnethood finds the Windows 10 machine but says “no shares”. The Windows shares were set up via advanced shares with permissions set to “all”. On my Android phone, I can access those shares just fine, like before on Win 7. So the general set up is just like before. Google didn’t help. What could be the problem?

Ok, I still don’t know why it doesn’t work in Pnethood, but I searched for alternatives. I’m a Linux n00b, so I had to look up the mount command, but I was able to set up a short script that mounts all my needed Windows shares, and it works for my purposes.

The tool I’ve found that works the best for Samba (Windows) shares in Puppy is YASSM. Version 2.7 fixes some problems that it had with name resolution.

I do note that it lists my Windows 7 shares as “hidden,” requiring me to actually type in the names of the shares.

If you can’t find version 2.7 in your repo, here’s a link to the forum post that has the linked the lates .pet file.

I see that I got v. 2.6 installed, I just never gave it a try, but I’ll do now. Thanks for the tip.

Yes, YASSM works, and just like you said, it doesn’t resolve the server name so I have to type in the IP address, and my Win 10 shares are hidden as well, but that’s no big hassle. Thanks again.

Just for general interest:

“All” has probably changed meaning again. “All” can mean “all authenticated users”, or “everyone”, or “members of this workgroup”, or it can include “anonymous”, or it can include “guest”.

Solution to that is to either work out how to add “anonymous” and “guest” to your permissions, or work out how to browse and connect using proper login name.

Other possibility is that Win10 is not responding to SMB/Netbios browsing requests for some other reason. I’m only guessing that’s not the case because I would have expected to read more comment if that was true.

To clarify: I’m working on a machine with a German language Windows and set permissions to “Alle”. I thought that the English equivalent was “all”, but later saw that there is a setting “everybody” in the English version. So now I’m quite confused if both “all” and “everybody” are both possible, but separate options.

Pnethood allows proper login with credentials, and I logged in even with an admin account, but still no dice.

I thought so myself at the start, because I somehow dimly remembered to have read some time ago that Win 10 deprecated SMB support. But I googled the issue and that does not seem to be the case (and would have been a very strange decision). But it’s a moot point because I can access the Win 10 shares now with YASSM or via the Linux mount command, so SMB on the Windows machine responds.

See, I have dynamic IPs, so I needed name resolution, so I installed 2.7. If you don’t, fine.

To tell the truth, I actually just use the YASSM automounter, which basically just does the same thing as your scripts. You set up all your shares using YASSM Share Select, and then run “samba-automount” or “yassm-automount” (I can’t remember which one it was back on 2.6.)

I too installed v. 2.7 from your link, but it still doesn’t find the machine with the host name. But that’s no problem, I don’t need dynamic IPs on that computer.