Computer Issue...Please Assist

My PC is having a problem. When I got up this morning the desktop was acting weird, freezing and trying to open applications and it was slow and wonky. So I attempted to restart the computer from the Start menu (Windows 7) and it hung up there. So then I tried to hard reboot it from the power button and it didn’t do anything.

So then I had no option but to hard reboot it by cutting power and pulling the plug. So I do this, and then it looks like its starting to reboot, then I get this message on a black screen: “Drive read error. Press Ctrl-Alt-Del to restart”. So I do that, and I keep getting the same message. I’ve tried several times now over the course of several hours and I am getting the same thing. I’m guessing my hard drive is cheesed, but is there anything else I can try before I jump to that conclusion?

I don’t even get the option to tap F8 or whatever to open the Bios or anything as the boot cycle doesn’t even get that far. In fact now it doesn’t even look or sound like it’s rebooting, it just goes straight to that error message.

If you are not getting even the initial manufacturer splash screen you have a hardware problem, but not necessarily a hard drive problem. Power supply, or motherboard most likely culprits.

sounds like the hard drive or controller is toast. if you’re lucky it might be a bad cable.

It does sound like drive failure of some kind - that can cause erratic behaviour on its way down. If it’s actually failed, it could be either the drive itself, or the drive controller on the motherboard (no option at power-on sounds like the latter)

Couple of things you could try:

Open it up and reseat a few things (that is, unplug them and plug them back in again, as the connectors can get corroded and unreliable over time - reseating scrapes them clean).
Reseat the cable connecting the hard drive to the motherboard at both ends
Locate and reseat the RAM module(s)
If the machine has a separate graphics board, reseat that too
(do this all with the machine powered down, but still plugged in, and touch your hand frequently on the metal case so you don’t zap anything with static)

If none of that works, try disconnecting the hard drive inside the case and power the machine on - if it’s just the drive causing the problem, it should boot as far as saying ‘no disk’ (or maybe it will try to boot from the optical drive)

Finally (for me at least), look up the correct function key to get into the BIOS settings - this varies from machine to machine - it’s often F1, F2 or F10 (not usually F8, as Windows uses that for a boot options menu) - turn the machine on and press the appropriate function key repeatedly until you’re sure it’s definitely not working. If you do get into the BIOS, you should be able to see whether it can see your hard drive.

I’m able to get into the CMOS menu by tapping delete upon startup. I’m wondering if I can use my motherboard disc (this is an aftermarket PC) to access the partitions then try a system restore?

Sigh. I should have followed your advice sooner. Turns out it was a very slightly unseated connection between the hard drive and the SATA cable. And I mean barely. I pushed it ever so slightly inward towards the drive and bam: problem solved.

Thanks for the help guys. Mods please close thread if necessary.

Glad it was nothing serious.

Even though there’s nothing apparently wrong with your computer, ‘near miss’ events like this are a good time to check that your important data is all backed up.


Many backup programs let you burn a boot CD, and then you can use that (often a Linus OS) to restore the entire computer.

An excellent program that creates a mirror image of your entire computer is Acronis True Image. It has lots of other nifty tools too, even cloning your system to another HDD.

Also, on boot up, where the screens offers to let you boot from the a CD, it shows a message to hit F11 to boot from the external HDD to which you backed up. This saves even booting from the CD, but you should burn one just in case.

That’s great! While a loose cable is certainly a possibility and should be one of those simple things you check first, in my 20+ years of working on PCs I don’t think I’ve ever encountered it in a PC that had been working properly and just sitting there.

I attributed it to the fact that I have an older gaming rig in which the processor tends to overheat when I tax it with games like the latest Bioshock, so I’ve taken the side off the case and put a fan next to it to help keep it cool. So it’s open all the time, I move the tower back and forth quite a bit to keep it close to the air conditioning vent or to make room next to me for my girlfriend when we watch videos or something on it, etc. I also have a cat. Something or all of these conspired to loosen that cable ever so slightly so the connection was lost.

I am however relieved that was all it was. Putting in a new hard dive is easy enough but re-loading an entire OS all over again is time consuming.

You took the words right out of my mouth. Literally. Glad it was just loose wiring though!