Computer problem! Mouse gradually gets slower and slower…

I’ve had a plethora of problems with this computer over the years, but this one really stumps me. I’ve put up with a bunch of stuff over the years in the effort to avoid totally wiping out the hard drive and starting from scratch, as I’m not sure I can find copies of all my current software, which I would need to to be able to reinstall them if I started from scratch. I actually bought a copy of some software over eBay today so I think I will do this if I need to, but I figured it was worth a last attempt to ask the experts first.

In simple terms, the mouse curser gets less and less responsive over time, until I reboot. Then it is fine. After restarting, it moves fine… then as hours go by, it gets slower and slower. At first it is tolerable, just a bit slower. Then it gets to the point when I can barely maneuver the mouse to close programs that give me problems if I don’t exit properly so I can reboot. If I leave it long enough, I get “the blue screen of death” which will go away if I try to move the mouse, but not enough to actually do anything.

The interesting thing is if I hit Ctrl-Alt-Delete to bring up task manager, the mouse operates perfectly as long as task manager is open, and reverts to the way it was as soon as task manager is closed.

Now the longer more detailed background. I don’t know how much of this is related or needs to be known, but I have learned that stuff that seems unrelated to me can in fact be crucial, so I’ll include all I can remember in case it matters.

A second problem occurs at startup, although in itself does not seem to affect me. Before the desktop is completely loaded at startup, sometimes (not every time) an error message pops up:

I hit the OK button, and a second error box pops up:

I hit the OK or close button, and it doesn’t seem to affect anything after that. All my programs seem to work just fine, AFAIK.

I am running Windows 98. I would have upgraded to Win 2000 a long time ago, except I wasn’t sure I could find copies of all my software, and I have heard that an upgrade installation of Windows 2000 is problematic (as opposed to a fresh installation). System Display from the Control Panel says Microsoft Windows 98, Second Edition, 4.10.222A. Computer: AuthenticAMD™XP 2000+ with 512 MB of RAM.

When I open task manager to see what’s running, I get the following list:


I think Explorer always starts with windows (not really sure about that), systray is the system tray in the taskbar, and Rsrcmtr is the windows Resource Meter I like to keep in the task bar to see if my resources are getting low. I do not know what everything else is.
If I try to delete things one at a time, it gets no noticeable improvement from the mouse (although if it is just too late by the time the mouse is getting real slow and one of these needed to be removed right after boot up to make a difference I wouldn’t know it). If I delete the Qttask program, however, the computer immediately freezes. Cannot move the mouse, keyboard has no effect, cannot even Ctrl-Alt-Del. Have to hit the reset button.

Now that I think about, actually, most of the time (maybe now it’s every time) I hit restart from the Shutdown window, the computer doesn’t completely shut off. It leaves a blank desktop (no icons at all, just the wallpaper) and freezes at that point, so I must hit the reset button again.

The computer has two hard rives, a 20 Gb (which it boots from) and a 40 Gb. It has a CD and a DVD drive, and an external 250 MB Zip drive using a USB port. I also have a scanner, connected with a SCSI card. Daisy-chained to the Scanner via the SCSI connection is a Zip drive and a Jaz Drive, which I really haven’t used in years. There’s also a printer. Printer is connected to the router, which is connected to the cable modem and to my wife’s Macintosh, so she also gets the cable internet connection and can print to my printer. Router is hooked up to my computer via an Ethernet port.

Because we want to get a digital video camera, and the one I am going to get needs a Firewire card, I just had a Firewire card installed. Haven’t used it yet, I am planning to get a 250 Gb hard drive for future video use. At first I thought that since all the space used on both my current hard drives will fit on the 40 Gb drive I currently have, I would first copy the data on the 40 Gb drive, then erase the 40 Gb drive, then mirror the 20 Gb onto the 40 Gb and use that as the boot drive, then move the stuff I copied from the 40 Gb back onto the 40 Gb which is now bootable, and install the new 250 Gb for video use. Now I am thinking I’d rather have too much space than run out, so I am thinking of also getting a new 80 Gb drive instead of the 40 Gb. Hope that wasn’t too confusing. None of this has been done yet, except for the installation of the Firewire card. The problems all occurred before the card was installed, and continued after it was installed.

For a while I was crashing all the time. If it wasn’t for the software copies issue I would have reinstalled the OS a long time ago. Just before I had reached my breaking point as it crashed several times a day, a friend suggested that spyware might be the problem. I downloaded Adaware and Spybot Search and Destroy, and after using these the crashes just about stopped. That problem has been solved, but the Mdrv32 issue was there before and continues now, and this mouse slowing thing is brand new (just in the past week or two).

I tried to “solve" the Mdrv32 deal by just stopping it from attempting to load: running MSConfig and unchecking that from the startup programs list, but that doesn’t help. I think it gets added back in somehow, because now in the Sartup Tab of MSConfig there are literally four different identical lines reading run=Msdrv32.exe, with only one checked.

Here’s the full list startup items checked in MSConfig:

Trayman                   C:\WINDOWS\SYSTEM\RA32.EXE
System drivers            C:\WINDOWS\MDRV32.exe
ScanRegistry              C:\WINDOWS\scanregw.exe /autorun
TaskMonitor               C:\WINDOWS	askmon.exe
SystemTray                SysTray.Exe
LoadPowerProfile          Rundll32.exe powrprof.dll.LoadCurrentPwrScheme
Iomega Drive Icons        C:\program files\Iomega\DriveIcon\ImgIcon.exe
TkBellExe                 C:\Program Files\Common Files\Real\Update_OB\realsched.exe –osboot
ATIPTA                    atiptaxx.exe
Quick Time Task           “C:\WINDOWS\SYSTEM\QTTASK.EXE” =atboottime
System Drivers            C:\WINDOWS\MDRV32.exe
Resourse Meter            C:\WINDOWS\RSRCMTR.EXE
msapi32                   msapi32.exe
taskmon                   taskmon.exe
run=                      MDRV32.exe

Items also in the Startup tab of MSConfig but are NOT checked (I know I’ve gone here once or twice and unchecked things I knew for sure I didn’t need or want):

System drivers                 C:\WINDOWS\MDRV32.exe
Iomega Startup Options         C:\Program Files\Iomega\Common\ImgStart.exe
AtiPTA                         Atiptaxx.exe
Internet Optimizer             “C:\Program Files\Internet Optimizer\optimize.exe
System drivers                 C:\WINDOWS\MDRV32.exe
Machine Debug Manager          C:\WINDOWS\SYSTEM\MDM.EXE
LoadPowerProfile               Rundll32.exe powrprof.dll.LoadCurrentPwrScheme
ATIPOLAB                       ati2evxx.exe
Run=                           MDRV32.exe
Run=                           MDRV32.exe
Run=                           MDRV32.exe

Like I said, there are several copies of some things that are not checked. For the MDRV32 thing, there are three versions of the “System Drivers,” one checked and two not checked. There is one run=MDRV32.exe line checked, and three not checked. I see ther is a pair of ATIPTA (although one is AtiPTA), one checked and one not checked.

As an experament, I am going to uncheck both MDRV32 lines that are currently checked and restart. OK done: at first I thought it worked because the error messages didn’t pop up when I restarted. But no such luck: now in the startup tab of MSConfig, the system line appears four times (two checked and two not checked) and the run=MDRV32.exe line is there five times, one checked and four not checked. So clearly it adds in both lines if they are turned off.

Just in case, I just ran Adaware and Spybot S&D again. Adaware had an update which I downloaded, Spybot S&D did not. Adaware found no problems – zero. Spybot showed one listing, a registry change for Windows Media Player. Guess I did install the newest version of Windows Media Player recently… why would that show up in Spybot? Does Spybot list every registry change, even if it is not Spyware, or does this mean I do have a problem?

Well, that’s all I can think of. What could be causing this mouse slowing (and probably computer slowing as well, but I’m not sure) and how can I fix it?

Just as a first-off, which version of Spybot are you running?
I have just installed 1.3, including the tea-timer, that advises of any change to the registry. The previous version had in the tools section a startup list that included far more things than the MSConfig listed, also the process list shoewd far more running processes than the task manager did, and was better at killing stubborn processes.

I suspect something non-kosher running in the background and stealing system resources and would investigate this rather than beating the thing with a big stick.

If this draws a blank, grab as many free virus scanners/cleaners as you can and try and locate/eradicate any malware this way.

It’s Spybot S&D ver. 1.2.
Figuring this must be “the previous version” you refferred to, I opened the Advanced Mode as opposed to the Easy Mode I usually use. Clicking around, I found what you are taliking about under Tools. There is among other things a Process List and a System Startup. Looking in the system startup, it looks remarkably similar to the MSConfig Startup Tab, except it doesn’t also list the unchecked items. I count 17… the same as MSConfig showed. Doesn’t seem to be a difference.
The Process List does show more things, but nothing I see as out of place, really, although I might not know what I am looking at, either.

I actually tried this a few weeks ago, without much success. I don’t remember exactly what I googled under, but I was looking for a free system scan. I think I found one I had heard of, but for some reason it never worked on my machine. From their website I clicked on the Scan Now link (or whatever it is called) and it never showed any results of any kind. The only other one I found (and I searched twice using different search terms and looked through four or five pages of results) was a bait-and-switch kind of deal. They said it was a free scan, and it was, but to fix any of the problems it found you had to pay for a key to unlock the rest of the program. I didn’t pay for the key, but even though I don’t remember exactly what the six or so “problems” it found were, I do remember thinking at the time that these “problems” were minor in nature and not what could be causing my problems. I didn’t write it down, so sorry I can’t be more specific.

Anyone have any links to good free system scan sites?

There are a gazillion in the sticky at the top of the page.

Try McAfee Avert/Stinger, F-Secure have a free Mydoom cleaner. Merijn CWS Shredder, anything free on there is worth a shot.

That online scan thing wouldn’t work for me either, doesn’t like Firefox.

What’s this ‘Internet Optimiser’?

It’s Spyware. Whether it’s the source of the problem, I don’t know, but it’s Spyware.

You said the file that has multiple lines is “MSDRV32.EXE” but you also list it as “MDRV32.EXE” so I’m not sure which is accurate but if it is the former:

You might want to check out that link. Typing that into Google only brings up references to that particular virus. Typing “MDRV32.EXE” (Ie, without the S) brings up zilch. And according to the Symantec link above, it copies itself to the Windows directory, and tags itself as a system file.

Here’s a few online scans which I’ve used in the past. I had a bad virus infestation a while ago. I’d clean my system, then the problem would come back again. Running these one after the other got rid of it. each picked up viruses the others mised.