(computer question) Help, my HDD won't boot.

Some portions of my post may be better suited to IMHO, mods, move as you desire.

I have 2 Hard Drives, lets call the bootable master HDA and my slave drive is HDB.
HDA is 80 Gb and has 3 partitions, HDA1 is NTFS windows XP, HDA2 is FAT and is my linux patition and HDB3 is the linux swap.

I used grub bootloader and the boot sector is written at the start of HDA.
HDB is 120 GB and is mostly data.

The problem: is I turned on this afternoon and where grub usually gives my options I get “No Boot device detected, please insert a book disk and press f1”.

I cant boot to this disk, when I look in the BIOS the HDA cannot be seen, although HDB can. but this is no help as HDB has no operating system neither is it bootable.

So I tried taking out HDA and putting it in another system as slave, this was fine, I could mount it no problem, the partition table is good, I can see all the files etc, and all checks pass.

What should I do to get going again ? I feel like the boot sector is scrambled, however using the xp installation disk and trying fixmbr and fixboot didnt help. My disk can still not be seen.

I look forward to your suggestions, Chew.

Hi Chew,

If the boot sector was scrambled (or even if the entire disk was blank), you would still be able to see the disk in the BIOS. The fact that it works in the other machine suggests a hardware fault.

It would be useful to see if hdb is visible when plugged into the slot hda used - I expect not. If so, try hda in the hdb slot and see if it appears - I think it will.

Let us know the result - it’s looking as though one of your IDE channels is fried. This is a relatively cheap and simple fix (an IDE plug-in card).


thanks for the quick reply,
when HDA was in the new system, I also tried removing that systems HD and trying to boot to HDA but I got the same message as on my system.

I have tried HDA in HDBs slot and I got the same result, I have not tried yet putting HDB in HDAs slot but I imagine this wont help me much knowing HDB is visible in its own slot but HDA isnt when it is there.

What else would cause my disk to be invisible ?