Odd HDD failure scenario

I have a machine in front of me.

Will not boot, BIOS does not detect a HD

mounted in a External USB unit the drive does not detect


If you load up an XP disk, the installer finds the drive and merrily formats it (albeit slowly) and proceeds to install windows. Once its done, tries to reboot, no drive detected.

Bios seems to hold other settings so probably not bios battery

tried fixboot under recovery console no joy.
Any wisdom from the masses before I go invest in a new drive

Have you tried clearing the bios, either by shorting some jumpers or pulling the battery and waiting 10 minutes or so?

Will try, I have tried retetting bios settings to default and letting the auto detect run, doesn’t seem to be a manual HD setting.

I am not clear on the procedure you used. Trying to boot the unit alone will go nowhere correct? Are you adding an external USB hard drive then? What drive are you putting the boot cd into? internal or external? What is the boot order designated in Bios? With a little more info we can sort this out fairly easily, I hope…

I assume you know what you are doing but have you checked the jumpers at the back of the hard drive are correctly positioned? (the ones that differentiate between primary / secondary drive etc?)

I removed the drive and plugged it into an external USB HDD housing. Then tried to plug it into another working computer. Boot cd (xp home) in the internal CD rom drive for the machine.

I went out and picked up a new drive…worked like a charm first time.

I was about 90% sure the drive was bad, just was curious more about what type of failure causes this type of behavior.

If you did that to me, I would not work either… :wink:

I see a few things here that do not adhere to proper trouble shooting procedures. No slam on you, but using the suspected bad drive in another channel really proves nothing. As long as the drive is physically away from the case, unplug it and work the system without it. See if everything else seems to work. I would be more specific, but it is late and I have to be on time in the morning at the IT department. It is hard to tell right now, but I am guessing your HD is hosed. Ascii to Ascii, Dos to Dos. If you were to on the odd chance to be looking for a college to go to and contacted Southwest Wisconsin Technical College, you might find some more help. Wink wink.

So you mean winxp detected the drive and formatted it, but on another system?? Just because it can’t boot off of USB, doesn’t really mean anything. Can another system write and read data to it?

You really have to give much more detail.

If the BIOS does not detect it but windows does… your computer is crazy. If your drive is not detected by one computer but is usable in another (and a second drive works in both)… I once had a problem with a Western Digital drive not being detected if you enable RAID capability on the motherboard. However, that shouldn’t apply to a USB unit. Other than that… update your BIOS, of course, but I’ve got no clue.

also you have to say whether it is SATA or parallel ata. pata needs correct jumper settings, and if you choose “cable-select”, it needs a correct cable and (i think) be put in the right position. also make sure that if your cable doesn’t have a notch to orient it, you try it both ways.

OK more detail. IDE drive

I inserted the drive into an external usb device to see if it could read and or write at all. I then plugged that device into a different working machine.

This other machine would not even detect that a USB device had been plugged in let alone drive it. Using a different drive the same external usb device worked fine.

At no point am I actually trying to boot from USB.

The weird part is, bios says no HDD exists at all.

If you boot from the xp disk it sees the drive for partitioning, creates a partition, and installs windows on it.

Reboot…says no boot disk present

checked bios settings for boot order, HDD’s selected first.

Fire up recovery console and the drive is there, the XP files are there.

Reboot, nothing.

Yup checked, CS is not the issue.

This was my customers take, thats why I was called in. He couldn’t understand why windows would patition, format, and install to a drive that bios could not detect.

Well as you may have surmised I have no formal education at this, just 25 years of being everyones geek kid down the street. I’m just about to break even after 9 months so I can’t be that bad :D.

crazy, crazy, apeshit crazy

if the bios does not detect the drive at all, it usually means the HDD controller is broken. (as opposed to when it can detect it, but the platters have errors.) Maybe the controller is broken in such a way that if it’s reinitialized, it works. Maybe upgrading the BIOS, or changing a settings that controls IRQ assignment (in my bios it’s called “Plug and Play OS”), or maybe enabling/disabling ACPI (doubt it) or some other weird setting will hack it to work.

Is it under warranty? If so, and since you obviously don’t have data on it, it’s a no-brainer. If not, you might be able to find a broken drive of the same model whose controller you can use (though such things are tricky). Maybe on ebay.

The most obvious cause is that it can write OK somehow but it cant read.

So format works, but when it boots and then tries to read it, nada.


  1. A drive formated on one IDE controler won’t work on another controler if the Bios for the controlers differ in how they handle interfacing with the hard drive. It was more of a problem when the Bios kept reaching new size limits on the drives. This is just to tell you why you shouldn’t just switch to a new computer without reformating on the new computer.

  2. It could be a jumper issue.

  3. You may have a cable wired to use C/S or cable select on the hard drive. The drive may be set to primary, but your plugging it into the secondary cable end. It would work correctly if the hard drive was set to primary and connected to the primary.

  4. I suspect it has a bad boot sector. The Windows CD boot uses the cd to boot, and the drive was detected. The format was done and the hard drive sectors rewritten. You try to reboot and the boot sector is bad, leaving you with a non-booting drive. The drive heads would be moving around alot trying to read the boot sector, and finding nothing trying again.

  5. The drive could have a bad power connector. It wouldn’t make a noise when you try to start. A bit of wiggling and it might work.

  6. Much like the #3 an IDE cable could be bad. You would hear the drive running in this case.

  7. The hd circuit board could have a crack, but I would expect that once it died to stay dead.

Unfortunately Windows broke the BIOS rule

  • originally things looked like hardware to the sub-DOS BIOS
  • other things needed device drivers to emulate block and character devices

You can have /anything/ and it will look like a device to Windows

but if I use recovery console in xp it can see files. I can run a dir, chkdsk, and nothing seems amiss. The only indication I can find of failure is the failure to boot the machine. It would seem to me that if it can find and display the contents of the C: drive then it can read at least to some degree.

The interface still uses the IDE hardware bios on the mother board to do reads and writes. The Bios translates requests to read or write to a specific sector into a physical location on the hard drive. The computer powers up, and the Bios gets all up and running so an operating system can be loaded. The Bios looks at Sector Zero on the first data storage device, and executes the OS start up code. The Bios goes to the next and the next storage device, until a boot sector has the boot data to start the OS. The drivers in the OS add a layer that can be always accessed the same by programers to do I/O between the IDE Bios and the OS. This eleminates the need for each program to know the way to access each device. The hard drive has it’s own interface to tell it this is where the sector is on this device. So there are multiple layers to access all hard drives.

  1. The hard drive circuits telling the heads where to go.
  2. The Bios for the IDE controller.
  3. The OS drivers to make all access points needed by programs the same for all devices.

A program requests data. The OS uses the driver to ask the Bios, to ask the hard drive for the data.

Bios almost always are set for LBA access for all drives now a days. Most of the Bios are the same today, and the Logical Block Addressing tables they use are identical. LBA came along to allow a greater number of sectors to used. On older computers ,when the hard drive was to large for the Bios to access all of it, you had to add in a bootup program on sector zero that handled the LBA interfacing. That was one more layer at the time to go through. Most of those motherboards were year 2000 non compliant.
CD and DVD drives interface the same way.