Copy image address in MS Edge

I’m using Microsoft EdgeHTML 17.17134 on my work computer. In previous versions of Explorer, I was able to right-click on an image and choose ‘Copy image address’. Edge doesn’t seem to support this. If I want to copy an image address, I need to open Chrome and use the ‘Copy image address’ option.

How do I copy an image address in MS Edge?

When I right-click on an image I get a menu that includes “Copy Link”, which copies the URL for the image to the clipboard.

When I choose ‘Copy link’, it copies the link to the webpage where the picture is; not the URL of the image itself.

google image search results
Image I want to link to (‘Copy image address’ in Chrome, formerly available in Explorer)
‘Copy link’ in MS Edge

I want to link to actual images, not to the pages they’re on.

It doesn’t appear that this is a feature whatsoever in Edge. I have the same experience with Edge on my machine.

I hate to be “that guy” but Edge and Explorer are really trash browsers. You’re much better off with Firefox or Chrome.

If you need this feature, just know that you’ll need to do your task in Firefox or Chrome.

The OP is using a work computer. They might not be allowed to download another browser :frowning:

You cant do that from a google image search anymore due to a deal that they did with Getty Images. They removed that menu option. Do the same search from Bing and you can do what you want.

Is there an option similar to “view image”?

If so, click on it and then copy the contents of the address bar while you are viewing the image.

Not that I could find.

There is a “share picture” command, maybe that inserts the image URL to the e-mail client? May be worth a try if that function works on your computer. (It doesn’t work on my work computer, it wants to open up the Mail client which my workplace policy doesn’t allow.)

[QUOTE=scr4;21609709It doesn’t work on my work computer, it wants to open up the Mail client which my workplace policy doesn’t allow.[/QUOTE]

That was my experience.

Fortunately, I’m only physically at this computer two days a week.

FYI, the next version of Edge being developed by Microsoft is based on Chromium, the open-source version of Chrome.

When I do it, it works. When I click Copy Link I can open a new tab, Paste, and then just the image is shown. I don’t know why it works differently than yours.

Video of me doing this: edge - YouTube First by “open in new tab” then by “copy link” and pasting into address bar of new tab.

Microsoft Edge 42.17134.1.0
Microsoft EdgeHTML 17.17134

while the following method is not as easy as, say, chrome/firefox/opera/brave … it can be done effectively.

[li]right-click image … choosing the “inspect” option … frame/window slides into view (left-frame) … with specific code already highlit.[/li][li]copy/paste that highlit code into notepad (starts with ‘img’ tag … inside < > chars) … do not use wordpad.[/li][li]copy/paste only the pertinent url (address starts immediately after “src=” code … inside " " chars) into your browser (edge, explorer, etc.).[/li][/ol]
i have illustrated several examples … pay attention to how the code differs within each string … only the “blue” text is relevant.

example #1:
Basic Computer Skills: Installing Software on Your Windows PC … (first picture):

**<**img width="655" height="275" class="imageBorder" style="width: 655px; height: 275px;" alt="downloading an .exe file" src=**"****"** longdesc=""**>**

example #2: … (second picture … avoid clicking ‘play’ button):

**<**img style="width:220px;height:165px" alt="File:Friedlaender.webmsd.webm" src=**"**//**"****>**

example #3:

**<**img width="600" height="400" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" src=**"**" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 60vw, (max-width: 1362px) 62vw, 840px**"** data-large-file="" data-medium-file="" data-image-description="" data-image-title="puting balas pagadian zamboanga del sur sandbar" data-image-meta='{"aperture":"1.9","credit":"","camera":"SM-G920F","caption":"","created_timestamp":"1485255382","copyright":"","focal_length":"4.3","iso":"40","shutter_speed":"0.00038699690402477","title":"","orientation":"1"}' data-comments-opened="1" data-orig-size="600,400" data-orig-file="" data-permalink="" data-attachment-id="13284" src-orig="" scale="1.5625"**>**

in the third example … much of the data is irrelevant (does not pertain to the actual image-url) … the only data you need is “

What you show in your video is not a direct link to the image, but merely a page on Google Images which contains the image.

That’s not what the OP wants.

My only suggestion (besides using the Inspector as albino_manatee says) is to try just using the copy command, and then try pasting somewhere where you can only paste text.

Using the Inspector is always rather annoying. I hate it when that’s the only way to get an image URL (which is the case even in Chrome for images added as background images).