Dell Studio 15 laptop not charging

My laptop has just decided that it won’t charge. It doesn’t seem to be loosing charge while it’s plugged in, but it isn’t charging either.:smack:

When I plug the cord into the laptop the “charging” light comes on briefly and then goes back off. It doesn’t come back on when I wiggle the cord, and it isn’t the cord because I tried my wife’s and it does the exact same thing (and it has worked in the past).

I just put in a couple of big new updates from Microsoft for Win7. Could that have hosed some power management drivers or something? What else should I try?

If you are saying that you put your wife’s charger on it and the same thing happened, then the problem is internal to the laptop itself. There is the chance that your battery is defective and won’t accept a charge. Lithium cells have to be charged carefully and safeguards are built into the system to prevent damage. So a cell pack that is determined to be defective will not charge. If you could try another pack in their, that would tell the story on that one.

The fact that the charging light goes on temporarily suggests that the charger has output. The brief time factor could be the computer checking the battery pack and declining to charge the bad cells.

There is no possible way that a Win7 update is going to do anything to your charging situation.

I was afraid of that. It would be weird for my battery to suddenly die like that, though, right? It isn’t losing its charge, and until now it has been strong as an ox. I could run on a battery for 4-6 hours depending on what I’m doing.

Could it be some sort of electrical short at the battery cord port?

The reason that I was thinking that it might be a software issue is that some quick Goggling led me to places that said it might be a corrupted driver in the power management software, and that I ought to try replacing that.

Also, earlier that day, I had shut the lid (which makes it hibernate or standby) and picked the laptop up quickly. I heard a beep (the system-tone kind) and opened the lid. Nothing was there, and the lights were off, so I closed it and packed it in my backpack. When I got home I found the dang thing was on, hot and displaying the “OS cannot be found” message. I hit the power button and it cycled back on without incident. Seems like too much of a coincidence to me…

I’m not familiar with that model, but I know this issue on other models can sometimes be fixed by deleting the battery from the hardware list, and letting Windows find it again.

I didn’t even know you could do that, Ponderoid. I’ll give it a try.

I think there’s a screen in the BIOS that lists the current power status of the battery (100% charged, 90% charged, 80% charged, etc.). Try to boot into the BIOS, switch to that screen and and then plug in the AC adapter. Does the indicator show that the battery is getting charged? That would eliminate any problem with software.

I’ve also seen this problem with DELL laptops. In my case it was fixed by just pressing a combination of keys.

I do not recall exactly what they were, but it was a combination of Fn/Alt and an F key.

This turns on/off the charging circuit.

So, I just looked at the device manager, and there are three items under the “batteries” heading. There’s one for the battery itself, but there is no option to uninstall that one. There’s one for the A/C adapter, and there’s one for the “Microsoft ACPI-Compliant Control Method Battery.”

Which one should I uninstall (if any), and what are the dangers of doing so?

Sometimes, removing the battery and reinstalling it will fix the problem. My niece had a problem like that once and we did the removal and reinstall. Worked fine after that.

Well, I’ve tried a new A/C cable and it didn’t fix the problem. My only options now are finding a new motherboard or doing the “reset the A/C charging circuit thing.”

I really don’t want to replace the motherboard in the dang thing. That just doesn’t sound like fun at all, but I don’t see why I couldn’t handle it if I had to.

Does anyone know if the thing **Deflagration **was talking about is still a thing that can be done with button presses on a Dell 1537?

Alternatively, I could just use the laptop as a plugged-in thing (but I don’t really want to.) The real problem with that is that CPU-Z confirms my suspicion that the damn thing has been slowed to less than half speed by this “AC adapter not recognized garbage.” Is there any way that I can bump it back up to full speed?

Replacing a motherboard on a laptop is not something fun. Beyond that, unless the laptop is a very high performance one that cost a lot of money, the cost of a new, warranteed motherboard is going to make up a serious percentage of simple replacement cost for the thing.

If you power down the laptop completely, does the little charging light come on? It’s an orange light with a lighting bolt near it on my laptop, it may be slightly different with yours.

As for the slowing of your computer, that’s probably your power management profile cutting the processor speed back to preserve battery power. You should be able to adjust it in your power management settings, just look at the differnt profiles and adjust as necessary.

Have you tried removing the battery and reinstalling it? Sometmes that helps some situations in laptops.

I think I can get a motherboard for about $100 bucks. It’s a fairly decent laptop, and I doubt that I could get something comperable for less than $600, even at the Dell refurb shop.

The power light behaves in the exact same way whether it is powered down, sleeping, battery in or battery out. When I plug in the AC cord the light will stay on for perhaps 3 seconds and then turn off.

The power management options in the control panel don’t seem to do anything for me. It’s set to “High Performance” and the settings are jacked all the way up on the “battery” and “plugged in” settings. There’s got to be something in the BIOS that looks at the AC adapter and applies some kind of limiter to the core speed and the multiplier.

To make matters worse, I don’t think that I can access those things directly in my BIOS.

Robcaro: Yep. Doesn’t do anything at all. I don’t think that the battery has anything to do with it. If it did, then I wouldn’t have the problem when there isn’t a battery installed.

Did you ever find a solution? I am having the same problem. I have 2 adapters and 2 batteries and all of them experience the exact same symptoms you described, even the light flash and the 10 or so seconds of “charging” before it decides it wont charge anymore.

Does it work without the battery out, just plugged into AC power?

I think that both of the things in my laptop were cashed. I ended up getting a new battery and an external charger that I plugged into the wall. That worked fine. I got it on eBay for a few bucks.

Then, a couple of months later the screen’s backlight went out and I replaced the Dell with an ASUS.

It works with the battery out just plugged in to the wall on both chargers, but just wont charge. My original battery finally got depleted to 0% so I ordered a new battery. It came with a 65% charge, but it wont charge either.

It has to be a hardware issue. I don’t think both my adapters would stop at the same time. Both the batteries are reported as healthy when they are in, they just wont charge.

An external charger might be a good idea for a little while, but that just sucks.

I’m about 8 months out of warranty on the laptop, figures. I dont think I’ll be buying a Dell again. This is my 3rd. I was just thinking the other day that I have been lucky to get 3 years out of this one. Had the hard drive replaced under warranty in January, then the warranty expired in February.

I have read that the board that could be bad is separate from the motherboard on the 1555 and easier to replace, but I dont know the cost. I’ll attempt fixing anything myself though, so I might as well try. Some of it is just not worth it on a laptop though.