Desktop question on Windows XP

How do I get the icons on my notebook desktop to sit on top of my wallpaper without having a rectangle of desktop background colour behind the icon text?

My home PC has done it automatically, and I can’t figure out how to do it on my notebook.

Disregard. Problem solved.

I found a site that suggested I enable “Use drop shadows for icon labels on the desktop” under Control Panel/System/Performance settings. That didn’t work.

The same site also suggested using a program called “Microangelo.”

I downloaded that, enabled “desktop support,” deselected “Use Windows Default” and ticked “Transparent” for the desktop background.

A popup window told me that the new settings wouldn’t work because I had web content enabled on the desktop. So I disabled that (I wasn’t actually using it, but one of the check boxes was ticked.)

Now the new settings worked!

I had a brainwave and disabled Microangelo’s desktop support and rechecked “Use drop shadows for icon labels on the desktop,” It still worked!

The problem appears to have been caused by unintentionally having web content enabled on the desktop.

Damn you Microsoft and your unintuitive settings!