Digital Camera Help

Ok, so I borrowed the neighbor’s camera to take some pictures of a room for rent to mail to some prospective renters. They gave me their camera (a very nice Canon) and I snapped a few shots. So far, so good.

Now I tried to download the pictures and, thinking I was being clever, I just copied them from the flash drive to my hard drive. Silly me. I did this mostly because they had a bunch of other pictures on the drive and I didn’t want to copy 100 pictures to my hard drive when I had only taken 10, and iPhoto doesn’t (as far as I know) let you pick and choose what to download.

Anyhow, now they’re not home any more and, when I tried to open the pictures, they are unreadable. I tried opening them with ACDSee (a free image browsing program), Preview and Safari. In all cases they came out really weird. Does the importing process normally manipulate the data or something?

The thumbnails that the finder window shows look fine, but no programs seem to open them. The computer I’m trying to do this on is an old Apple G4 powerbook running OS 10.3.9. The camera was a pretty fancy looking Canon. Is there anything I can do to recover these pictures, or do I need to take new pictures?


How are the files labeled? Are they jpg, tiff, raw, etc? Some camera’s raw files need their own software to read the files. Altho, a program like Photoshop Elements might be able to open them…

For a specific answer from someone who might know for sure (obviously not me), post exactly what camera it was and what shooting/recording mode you were in.

I was afraid that I might need to know modes and stuff. I don’t actually know any of that. The files are called IMG_8101.JPG though 8110.JPG. That’s kind of why I thought I could just copy them…

Hmmm. A jpg is just about the most common file type for pics I know of. I use my Photoshop Elements and my old 6.0+ to open and play with the files I’ve taken with my friend’s Canon EOS-1D that I took in large jpg format. And I’m on a PC, not a Mac.
Sorry, I can’t help. I’ve been a photographer for decades but just now getting into digital myself. Maybe at the very least my bumping this thread will help get an answer from someone more digitally minded.

You have a reader for a flash card or whatever storage type the camera uses on your old Mac?

You opened the camera storage, selected the 10 pictures and dragged and dropped them onto you hard drive? They show up as IMG_8010.JPG?

What mega pixel rate did you shoot the pictures at? If up around 6 million, maybe the old puter can’t display that large?

If they are really a JPG, then they should open and if it will see them in thumb nail size and not full, you might need to take them to a better computer.

Which Cannon, they are all nice…?? Do they have flash drives? Or memory sticks, or SD or XD memory storage?

Thanks guys. The files are about 2.1 MB each. The thumbnail image is fine, but all the programs freak out when they try to open them. Here’s what the pictures look like when I try to open them: Image Shack photo

Oh, and GunsNSpot, that’s pretty much exactly what I did. :slight_smile:

Try uploading one of the files that’s giving you trouble to Image Shack and let us know where it is. That way we can see whether it looks OK on a different computer.

It’s on imageshare (see above) but I had to compress it. Jere’s yje file for download from rapidshare:

(I changed the file name to street.jpg)

Copying a camera file works fine.

It sounds like a decoder or file size problem that the default program can’t handle. Try opening the file with a different program like Firefox. I can’t help you beyond this, because I don’t use Apples.

I have several Canon digital cameras and I always do exactly what you did, take the flash card out and copy the files directly to my hard drive. Looking at your file, it looks like you didn’t get all the data when you copied. Either the flash card was defective or your reader glitched when you copied them. I think there is little hope for you unless you can retrieve that flash card and try to copy the files again.

The reason the thumbnail is viewable is because it is stored separately new the beginning of the file and you apparently got that far before the glitch.

Yep, you don’t have the complete file. File copy error.

I agree.

That looks to me like a corrupted file. I don’t know what happened to you, but my normal course is to copy JPEGs directly from the card to the computer. I never use the camera cable, so that’s not your problem. Somehow, in you transfer, it looks like your file got screwed up. I’ve seen this happen before, but I don’t know what causes it.

From what I hear, most (if not all) Canon digital cameras tend to be rather nice. If it’s one of the SLR cameras (interchangeable lenses and flashes, along with various other accessories), they use Compact Flash. If it’s one of the point-and-shoot cameras, it probably uses Secure Digital (Compact Flash’s little brother).

I think only Sony cameras use Memory sticks, and only Olympus cameras used XD (some of the newer Olympus cameras I’ve seen have had slots for both XD and SD cards too).

I am with AHunter3 and Rick on this from seeing your result. Need to get the card back and redownload the pictures. I have had this problem before on an old Sony Mavicia™. Actually a good camera in a lot of ways.

I have an Fuji F-10 also and it uses the XD memory.

Agree on not using the camera for download but to remove the card and use a reader. Seems faster on my set up.


This happens to me when I’m driving too. Some days I’m just invisible. :smiley:

Thanks guys, I cajoled a different neighbor into coming over and snapping the pictures. They are now traveling over the internets to points East at billions and billions of miles per hour, hopefully eventually fooling some poor souls into thinking I live in a nice house. :slight_smile: On the plus side, I know there’s nothing I can do to fix these files and can just delete them. Three cheers for deleting stuff!


Oops !! scrolled through too fast and missed ya. My bad. I know the feeling. Better late than not a all.

Be well …