Drive partitions not detected

I am running XP SP2 with all updates. I have 2 drives. Drive 0 is 40Gb with two partitions C and E. Drive 1 is 60Gb with 4 partitions D F G and H. Sometimes when I boot, partitions F G and H are not detected. Sometimes partitions D F G and H are not detected. If I reboot, all will be detected. Any ideas what is happening?

I am just going to bump this one time in case there is one intelligent Doper who know something about this. :rolleyes:

When you say undetected, do you mean “Drives don’t show up in My Computer” or “Partitions don’t show up under Disk Administrator”. What does Disk Admin report is in the space?

The partitions do not show up in My Computer. I have not looked in Disk Administrator. Right now, all partitions are showing, so when I get no partitions showing, I will check out Disk Administrator.

If you get bored, try running the drive diag tool made by the company that made each of your drives.

Well, I would say that when one of your partitions don’t get dected there’s no chance you can’t see it in Disk Manager, and if your boot partition isn’t detected there’s no way you can see anything anywhere. A partition is not a volume (like C: or d:), though you may have four partitions with a single volume on each on your second disk.

It sounds that your disks are old (around 2000?). My estimate: a) you should check your cables, b) your second disk (with D F G and H) is about to die.

I now have the problem again, but D is detected. F, G and H are not. They do not appear in Disk Manager either. But if I reboot, they usually appear the first time. The drive isn’t very old. I bought it early in 2003 before I came to Colombia. Drive 0 is new. I have run the Western Digital Diagnostic disk and it reports no problems. I have also run SpinRite at the lowest level to reclaim anything bad, but it reported that all was well. I have Trend Micro Internet Security and it is up to date. I have a Netgear Router for protection too. What about the Master Boot Record. I am running XP SP2 so that is a little different to restore.

So does Disk Manager just report the missing partions as empty space? Does it report the size of the drive correctly?

Go into your BIOS, and see if there’s something labeled some variant of “Disk Detection Delay” or “Wait time for drive” or something like that.

Hard drives take a variable amount of time to spin up. On modern drives, that time is very short, and “waiting” for the drive is time you’re not spending booting, so most BIOSes set the wait time very short as well. Since many people treat “boot time” as an indicator of system speed, manufacturers want it short.

One possible explanation for what you’re seeing, then, is that the spin-up time for the drive, and the wait time for the BIOS, are very close to each other. You get the sort of random behaviour based on which drives and even which partitions have managed to report themselves to the BIOS by the time it stops looking.

If you find the setting, bump it up by a little bit (five seconds ought to be WAY more than enough) and see if the problem goes away.

Note: I’ve dealt with a LOT of computers over the years (hundreds), and I’ve seen this problem exactly once. But the symptoms were a lot like yours (the particular system didn’t have partitioned drives, but otherwise the same). Bumping the delay fixed it.

Another argument in favor of my explanation would be:

If by “boot” in the OP, you meant “cold boot” - i.e. booting from a power off state. A reboot would leave the drives spun up, and should always work. If that’s the case, I’ll wager two putz smilies that it’s just the drive detection time (whether your BIOS lets you set this is another matter, of course).

Yes, Disk Manager reports all the space of partitions F G and H as one big space. That space is correct for the total of the 3 partitions.

I don’t find anything in my BIOS that indicates “drive detection time.” The information for Drive 1 is as follows:

Phoenix BIOS V1.11 24 Aug 99
Primary Slave
Type: Auto (changeable)
CHS Format
Cylinders 17475
Heads 15
Sectors 63
Max Capacity 8544MB
LBA Format
Total Sectors 117231408
Max Capacity 60022MB
Multi-Sector Trf 16 Sectors
LBA Mode Control Enabled
32 Bit I/O Enabled (Changeable)
Trf Mode FPIO 4 / DMA 2
Ultra DMA Mode Mode 2
Smart Monitoring Enabled

Timewinder’s solutions sounds interesting. It’s worth a shot.

Disk 0 (with C: and E: ) seems ok. Moving on to disk 1, I think you’re mixing up partitions and drives/volumes. In Control Panel/Administrative Tools/Computer Management/Disk Management, in the window down to the left, you’ll see your partitions. You can have primary partitions (dark blue) and extended partitions (green) with logical drives (light blue). Is your disk 1 a single primary partition or something else? When some of the drives fail to load, how does the layout of your disk look like in that lower left window?

I don’t think I am mixing up partitions and drives/volumes.

Drive 1 contains 4 partitions.
Partition D: Active Primary
Rest of Drive 1 is Extended
Partition F: Logical
Partition G: Logical
Partition H: Logical
All are FAT 32

Good. In my experience disks either work or they don’t, so your problem with disappearing drives is kind of special (at least to me). So, try out Timewinder’s advice first. If that doesn’t work it’s quite possible your looking at a failing disk. Obviously your disk doesn’t detect what it should detect, and that’s never a good sign.

I had to look up the details on how drives are loaded. The following might be useful:

The information about primary partitions and an extended partition is contained in the Partition Table, a 64-byte data structure located in the same sector as the Master Boot Record.

When you have an extended partition on the hard disk, the entry for that partition in the Partition Table (at the end of the Master Boot Record) points to the first disk sector in the extended partition. The first sector of each logical drive in an extended partition also has a Partition Table … These are the entries in an extended Partition Table:

Forgot to mention: I see your using FAT32, but Partition Tables are handled the same on all the recent windows operating systems, AFAIK.

Is there any way that I can view the Partition Table in the MBR.

Oh yeah, a bunch of programs will let you do this, though many are the give-me-some-money-first kind of programs (and usually of dubious quality I might add). You could check out the very powerful TestDisk (freeware) from:
TestDisk - CGSecurity.

From the top of my head, a program called Disk Image (free demo) should also do the trick.

Note: Both run in DOS/Command mode. Don’t know of any such Windows based programs since I’ve only touched this issue when working with disk recovery software, which always run in DOS mode.

I may have solved the problem. My BIOS battery is 6½ years old and I think it is starting to run low on startup. So, the first time I boot, I get these errors. After a reboot, battery is charged a little and all is well until the nextime I boot from scratch. I have ordered a new battery from the US and will need to wait until it arrives in a week or two. I will post back about results.

I feel real stupid in that none of us guessed that. It would make sense, I think.