Easy Win98SE Q

I’ve had lots of problems with my PC lately, turned out to be a duff motherboard, one stick of duff RAM and soundcard drivers causing a windows protection fault (my very first one!)

As a result of a long process involving much cursing, scratching of head, fruitless online searches, I eneded up reinstallinh the whole thing with the absolute minimum components, adding one at a time, until everything was running properly, well almost.

So now to my Q,

I have 2 hard drives(one is SCSI), both partitioned, one CD-RW and a plain old vanilla CD ROM.

However, windows cannot see every drive when they are all connected, I suspect its because of a default setting within windows and something to do with the Lastdrive letter allocation.

I remember a good while ago that all one had to do was go into one of the Windows system files, and change the last drive allocation from H: to a letter further along, say K: and this allows Windows to see all drive up to that letter.

I also remember that this did work last time.

I’ve done the obvious things like check on ‘Device Manager’ and tried the ‘Add new hardware’ wizard to no avail, and yes all the drives are visible in the bootup process and all are correctly set to the required Master, Slave settings.

So now is your cance to shine and beat everyone else to the glory :slight_smile:

In your CONFIG.SYS file, edit (or if missing, add) the line that says LASTDRIVE= to whatever last drive letter you wish to use. Example: LASTDRIVE=K.

Thanks for the reply.

I tried it and unfortunately no joy.

When I boot up on the second hard drive everything is fine so I may reinstall the SCSI drive again since I now know everything is working properly.

You can also reserve drive letters for devices: Control panel, System, expand CD-ROM branch, select CD drive, properties, settings. It might be worth fiddling around here.

You only have 4 devices and no network drives so I suspect it’s nothing to do with the “lastdrive” letter allocation.

I suspect the SCSI drive’s settings are causing it (the SCSI drive) to insist on occupying the same drive letter that one of the CDROMs is currently taking. Per Schnauzer’s suggestion reallocate the CD/CDRW drives to F: and G: (or whatever) The SCSI should pop up as “D”.