Firefox, user-defined stylesheets, and links

I got a quick question about this. I use my user-defined stylesheets to remove link underlines but make the text underline when hovered over. My user stylesheet has stuff like

a:link {text-decoration:none}
a:hover {text-decoration:underline}
a:active {text-decoration:underline}

Etc. It’s nice. Except with internal links. See, the “name” part of an internal link on a web page - the bit that’s not actually a link, but is linked to by an internal link will underline when the mouse moves over it. Sometimes (with badly designed sites) that’s whole paragraphs.

So can anyone help me here? How can I change my stylesheet to fix that stuff? I’d like it to make a distinction. As a bonus, I might add some special property to internal links - it’s always nice to know before I click. But I don’t want any formatting at all on the “name” link.

Bonus question: I need to change some extension properties. However, recently, when I try to view my extension list, it’s empty. Is there a fix? Or even just another way to access the properties to turn off some extensions?

Ooh! Another question. Can I use my stylesheet to make the little dotted border around active links (put in by the browser by default, I think) disappear, to be replaced with what I want?

[li]Add the following to your style sheet:[/li]a[name] {text-decoration:none}
[li]The extensions list shouldn’t be empty. Did you try reinstalling Firefox?[/li][li]I don’t know if you can make it disappear completely, but you can give it another border and the normal dotted lines will become harder to see. Try something like:[/li]a:active {border: 1px solid red}

Actually, for your last question, this page explains several possible workarounds.

There’s another way to access the properties, but on a much lower level… type “about:config” in your address bar.

I know certain extensions store properties in there, but do all of them?

I’ll probably have to try a reinstall.

One more question has come up: the way my stylesheets are set up now, the underlines only appear on unvisited links. How do I set a property for visited hover links and visited active links?

Slightly off topic, but this is generally considered a bad thing to do.

See the famous “Top Ten Mistakes of Web Design” at This is mistake #3.

To quote from the details about links: “Users shouldn’t have to guess or scrub the page to find out where they can click.”

I’d really suggest reconsidering doing such a thing.

a:visited:hover {text-decoration: underline}

Note that I said on my user-defined style page. I prefer not to have underlines on links because they interfere with reading. I’m sure I’ll be able to manage my confusion.