Fix for Vista large file copy hang?

I’m really good with PC stuff, but I’ve looked & tried everywhere & everything and cannot fix it.

Basically when I try to copy a large file to a USB drive the progress bar goes almost to the end and then hangs. The Details button always reveals a small amount (a few MB) still waiting to copy. Only way to clear it is too pull the USB drive. Hard drive to hard drive works fine. I’ve tried:
[li]Turning DEP & UAC off[/li][li]Turning Net Tuning off[/li][li]Installed ALL updates & SP2[/li][li]MS Hotfix[/li][li]Turning off AVG & Zone Alarm[/li][li]Using different USB ports & drives[/li][li]Of course rebooting after all of these…[/li][/ul]
I’m using Vista Home Premium 64-bit. The weird thing is this just started happening out of the blue today. I never had this problem (or the Vista slow file copy problem) before, but now it happens every time. Only thing left I can think of to do is upgrade to Win7…

How large is large? If the USB drive is FAT32 it won’t like files > 4 GB.

No, I learned about the FAT32 thumb drive thing with XP. The file is about 650 MB. I know its actually copying almost all of the file because when I unplug it & plug it back in most of the file is there but of course its corrupted.

Can you do an end run, zip the file up while splitting it into a couple files? Or do you need the file as-is on the USB drive?

Try Robocopy.

Put your big file in a folder by itself

Open the Command Prompt and type:

robocopy C:\location\of\bigfilefolder F:	argetfolder /COPYALL /E

This assumes that your big file is on C:, and that F is the drive letter of your USB key. Chage letters as necessary.

I could figure ways around it. And I’ve tried a few freeware file copy apps (Teracopy). Problem with them is they are ridiculously slow. They all give estimates of over two minutes to copy my 650MB file. Is that normal for these aftermarket copying apps? Or is that a sign of a bigger problem? Either way I cannot put up with copying always being that slow.

And its not so much that I urgently need this file copied, as it is I want something as fundamentally basic to an OS like file copying to friggin’ work!! (Mac users insert witty rejoinder here)

I also really want to solve the problem as I’m always the guy who solves everyone else’s computer problems! :smiley:

The robocopy utility i recommended is not a third party app. It’s a command-line tool that is part of Vista and Windows 7.

Have you tried multiple USB drives of different brands? Sounds like you might have a bad sector. Have you tried updating your USB drivers? Are they USB 2.0?

It might be worth formatting the USB as NTFS and seeing if it changes things at all and running ckdsk on the USB drive. That or buy a new USB drive and see what happens. Does the USB drive have some crappy software on it? If so you should dump that and let Vista handle everything. Sometimes these softwares are a pain to uninstall, you might need to refer to your USB manufactures notes on how to do it.

Thanks to all who have replied so far.

I tried Robocopy after reading about what it was, same deal. I’ve discovered that the copy process isn’t really hanging, it is the dreaded slow-down others have reported (I just never waited long enough to let it finish). I don’t understand why it cropped up on me all of a sudden as most of the info I’ve read stated that it was fixed with Vista SP1.

Its definitely not the USB drive. I tried different ones, same thing. And I always ditch any ‘mini-OS’ Cruzer software and format them NTFS. And I never use ReadyBoost. Like I said, I can get along with it like this, I just don’t like not being able to find the cause of such a fundamental problem.

If and when I do up to Win7 and it still does it, then I’ll be pissed! :smiley:

One more thing you might try is a synchronization utility, like Microsoft’s SyncToy. If you make the left folder the one containing the file, and the right folder your USB key, and then run an Echo synchronization, it might do the trick.

Have you applied Vista Service Pack 2?

Whats the file like? Can it be copied to a network share? Is it corrupt? Can you zip it and try copying it again?

Is anything locking or using this file (torrent?).


I would totally recommend Win7 if you get the chance. I am running Win 7 64bit at home and it definately kicks ass, so much better than Vista.


Also, what other USB devices do you have plugged in? They could be interfering (busy on the bus, sucking power, being noisy, etc.) Try removing them all.

Do you have the latest drivers for your motherboard? Might be a chipset update that addresses USB issues.

Oh, check your update log. Did you just do a bunch of Windows updates last night or the night before? If so, list them. Perhaps one is messing up you machine.

This is atypical. This is starting to look like a hardware issue. Two minutes? Thats USB1.1 speeds. Hmm.

650 MB… are you trying to do the Linux installer or something? It might be the file, especially if you have been trying it on different ports/drives.

If you aren’t doing the Ubuntu Installer, maybe you should download it and try it. Its about 650 MB too, and if it copies okay, you would know its just the file. If it doesn’t copy, its probably a personal issue with you and Bill Gates.

I was thinking the same too. I’ve seen a case where a large file was partially corrupt; most of the file could be read, but not all. And it couldn’t be copied or moved.

Concur. Windows 7 is Vista done right.

The file itself doesn’t seem to matter. Its just a big zip file. I’ve tried other files and although I haven’t pinpointed the size limit it seems that it always happens with big (over 200MB) files.

I think there were several Windows updates right before it happened so that’s most likely what caused it, because I think that both ZoneAlarm and AVG got flaky then too. Rather than try and remove updates one by one, or try and update my motherboard BIOS (that’s always risky and I doubt there’s a newer version anyway) I think I’ll just use this as an excuse to up to Win7. I got 7 upgrade discs for free because I bought my PC after it was released but it came with Vista on it. I’ve used a PC that had the 7 release candidate on it and it is basically a ‘fixed’ Vista!

Again thanks to everyone for the help…