Google settings stuck on another country...

My friend in Idaho can’t access her Google Voice as whenever she goes to Google, it is stuck on Google Netherlands. She tried to fix her settings & it says she is in the USA & her language is English, but when she tried to actually do something, it defaults back to the Netherlands. What is going on here & how can she fix it?

Was she in the Netherlands? I was in the Philippines earlier this year, and for some reason it took a few days back in the US before Google realized it and stopped trying to return me results in Filipino.

Google is an odd duck like that sometimes. It still gives me the option of writing my emails in various Indian scripts - and I left India over a year ago.

And why do they think that they know what I’m searching for better than I do myself? This frigging attitude makes me mad.

This actually makes a lot of sense. If an American and an Englishman would google ‘football results’, I’m sure they would be looking for very different things. Also with names and places (for travel for instance) it might be preferential to get results in your language.

Did you mean “figging” instead of “frigging”? I’m going to reply to this post like you meant to say "figging; just because I know better. “figging” does tend to make unsuspecting people mad, you might want to talk to your partner about it. :smiley:

Since Google often misguesses what my language is,I have to take Floater’s side here. When I Google in Internet shops, I’m never sure which language I’ll get. Sometimes gives English, while gives Thai! On occasion, both give English but aren’t working right so I switch to Then the language switches to … (did you guess right?) Thai.

Google sure is clever trying to guess what language I want. Did it ever occur to them that I might be able to tell them? (Google is improving in some ways. Several years ago I occasionally got in a mode where no obvious click produced English!)

But the last gets determined by language settings, and if I’m looking for information on Argentina I’d rather get it from Argentinian sources than from a Spanish travel blog.

And whose choice should that be, yours or some anonymous systems designer’s, who’s working on the premises that the users are too stupid to decide for themselves?

I always have Google as my homepage, but for some reason on my home computer, it always, always, always comes up in Thai, no matter how many times I switch it to English, on screen and in the controls. It’s not that big a deal, as 1) I read Thai, and 2) I’m familiar enough with the Google commands that I know the positions of the links I want anyway regardless of the language it’s in. But odd it always reverts to Thai like that.

Has anyone checked to see if the search settings are locked?

Perhaps someone at some time changed, then locked the settings.
I realize it’s too simple a solution, but it’s all I have!