Google tracking code. What am I doing wrong?

I know I can ask this via google’s help system but I figured it’s hopefully an easy enough question to answer for Dopers who own/manage websites that I can ask it here, and it’s easy for me to ask here than somewhere I’m not used to.

I have a website that can be accessed both with and without the ‘www’ bit. (http://notails.com) I know it’s not just my browser adding the www for me when I type notails.com because it stays as notails.com. My domain according to my host is notails.com not www.notails.com. (but www.notails.com does also work)

That might be irrelivant, it might not. I don’t know…

On the google analtics website I have both versions of the domain registered (I seem to remember seeing advice somewhere suggesting register both)

My google tracking code page says ‘tracking not installed. last checked 31 dec 1969’. 1969??? WTF???

My tracking code IS installed.

Also, there’s different tracking code for each version of the domain. I’ve got the notail.com tracking code installed.

How do I make google re-check my tracking code?

I do seem to be getting some stats, so it seems like google IS tracking my website. But it says the tracking code isn’t installed. What gives?

I have it installed in the suggested place (just before the closing head tag)
So, any idea what I might be doing wrong? And should I remove the www.notails.com tracking account?

And in the tracking code options there is the option of picking ‘one domain with multiple subdomains’ currently I have ‘single domain’ selected. If my site technically has two domains (notails.com and www.notails.com) should I choose ‘one domain with multiple subdomains’?
Or to cut a long waffling story short: I’m an analytics noob. help!.

[too late for] Edit: I have since discovered that it’s a bug with google’s new version analytics page.

But I also spotted that the www.notails.com version gets a LOT more traffic than the notails.com version. I never give out or provide links to my website using the www.notails.com version.

I work in SEO, and all the advice is don’t split your traffic in the way you’re currently doing. The best solution is to have a single domain to which the other resolves (via server-side deep links if possible using a 301 permanent redirect).

ETA: because Google gets confused in the way you’re observing.

I’ve tried creating a htaccess redirect (seems rather tempremental - worked in FF, doesn’t work in safari or chrome. redirects sub-pages to homepage). How do I create a 301 permanent redirect?

edit. here is my htaccess…


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

</IfModule>

# END WordPress

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^www.notails.com [nc]
rewriterule ^(.*)$ http://notails.com/$1 [r=301,nc] 

The redirect does seem to work, but not on sub-pages. The place I got the rewrite code from said it works on all sub-pages/folders

perhaps I should create a “rewriterule. what am I doing wrong?” thread.

I think I fixed it…

http://www.notails.com/photography was redirecting to http://notails.com

/photography has its own htaccess file to re-write the way subsections are shown.

I moved that rule to the root’s htaccess file and deleted the htaccess file in /photography. It seems to work now (http://www.notails.com/photography redicrects to http://notails.com/photography)

No idea. I get a little man in to do that sort of thing for me. :wink: But I believe the most successful approach would be at the webserver layer rather than a catchall file in the directories. garius knows way more about this shit than me.

you’re using WordPress, which means you don’t have to add a redirect to your htaccess file to control this particular redirect, just change the domain name under Settings General.

I have a self hosted wordpress, but I also have non-wordpress stuff. I want to redirect everything (wordpress or not) from www.notails.com to notails.com

I have tried to add one via cpanel but it won’t redirect anything deeper than the root.

(This is like trying to clean a room while wearing muddy shoes, as soon as I get one bit clean the bit I just cleaned is dirty again.)

I’ve posted a question on stackoverflow.com about this.