Having a weird problem with optical drives

I have a homebuilt PC running Windows 7. I need to reinstall my OS, but I am hindered by an unusual problem.

I set the BIOS to boot from CD first. I’ve got my Hiren’s boot CD (which has worked fine on this PC before) in the drive, because I want to format the hard drive first. I boot, and when the BIOS says “press any key to boot from CD,” I press a key and nothing happens. It goes on to boot normally.

When I’m in the normal GUI, the drive shows up as a drive, but will not read any disk. It just shows up as (empty) no matter what kind of disk I put in there. If I double click on the drive, it says “please insert disk.”

I have swapped out the CD/DVD drive with four alternate CD/DVD drives, and they all behave exactly the same.

If I boot to a command prompt, and try to access the optical drive, it says, “drive not ready.”

If I set the BIOS to boot ONLY from CD, (all other boot options disabled) it says “disk boot failure. please insert system disk and press enter.”

Seems to me this must be a problem with the motherboard.

I must leave for work soon and will be gone until evening, California time, but if someone has any ideas for me, I’d be grateful.

P.S. I know that the Windows disk will format before installing. I tried using it too, but the same thing happens.

Is that the only optical drive in the PC? Are you sure it’s set first in the boot order, and not some other drive? Also, when the “press any key to boot from CD” comes up, are you sure you’re hitting the <space> key or whatever fast enough? If you don’t hit it fast enough it will often just go on to boot to HD.

Yes, it’s the only optical drive in the PC; in fact it’s the only thing on the IDE cable.

I have taken the original drive out, and tried using several different drives, and they all do the same things.

I boot the PC with one finger on the enter key, ready to press it in a microsecond. :slight_smile:

About the drives, you sure you’re not trying to read a DVD disk with a CD drive? Are they old drives that might only read either -R or +R and not both, and the disk isn’t the right one? Is the jumper on the drive set to Master, not Slave? Do you have another cable to try?

It’s always good to review the most likely simple mistakes, just to be sure.

IDE? Have you got your master/slave settings right?

While the machine POSTs, try hitting F8, F11 or Esc.
You should get a list of boot device options, choose the one you want from the list.

Since the optical drive is the only IDE device present, maybe it’s the IDE controller. You could try the other socket on the motherboard first, though I doubt that it makes a difference if the problem is with the controller. If you have a working IDE hard drive somewhere, you can try if that works in your system. If not, I’d say the controller is toast.

I just saw that I misread your second post, and that it’s not the only IDE drive in the system, but on the cable. In that light, my guess that it’s a problem with the controller is less probable, but you should try the optical drive in another socket anyway. And yes, as voltaire suggested, check the cable.

I mean, the cable has a master and slave connector. The drive has a master/slave jumper.