Help! Can't get rid of closed-captioning

I am using an HD antenna and having trouble getting rid of the closed captioning. I hit ‘menu’, then ‘Digital Audio Selector’ under Audio Settings, then ‘off’ under CC. Sometimes it works, sometimes it doesn’t. And, every time I change channels, the captioning re-appears.

Any help would be greatly appreiated. Thanks Dopers!

Have you tried unplugging it for a bit to “reboot?” Modern TVs are essentially computers focused on playing video and audio.

I occasionally have the inverse problem – lose CC and can’t turn it back on, given there are 4 “styles” I try them all to no avail. The answer was already given … when the thing acts wonky, reboot.

Tried rebooting but no dice.

Not sure I’m understanding, but does your TV have its own CC settings separate from the HD antenna settings?


Since this is about the mechanics of TV, and not the content, I’m moving it to GQ.

I think so. How would I access antenna settings?

I might be missing something, but do you have Netflix/Hulu/some other similar channel? Some of them have their own CC which may kick in when you turn off your TV Settings CC; and vice versa(?).

No, just local broadcast channels.