Help me with my home network (XP Home, Linksys router)

We have two computers in our family, a desktop and a laptop. Both connect to our DSL internet service through a Linksys wireless router; the laptop is wireless, and the desktop is connected to the router by an ethernet cable. Both computers run XP Home.

I’ve finally decided to get off my ass and try to network them, so that the person with the laptop can get access to certain files on the desktop, and so that, when our new printer arrives next week, both computers can see and use it.

The first thing i did was to follow the instructions on this page, but when i opened up the “My Network Places” folder on the laptop it didn’t see the desktop. I tried running the set-up wizard, and tried to get the laptop to connect to “Home” (the name i assigned to the workgroup), but it told me that it didn’t have permission to access Home.

I did a bunch of other Googling, and ran the Windows network troubleshooting thingy, but all to no avail.

My suspicion is that there’s some setting in the router that i need to change, because when i select Start > Run on the desktop and try to ping the laptop (ping it times out without a response. I read the router manual, but nothing seemed to help.

Also, both computers have firewalls installed (Zone Alarm on one, Sygate on the other), and i’m guessing there might also need to be some settings changed there, but again i’m not sure what it might be. When i tried to netwrok the two computers, neither firewall gave any pop-up warnings.

If anyone has any advice, i’d certainly welcome it.

You probably need to add the IP address of each computer to the other’s trusted zone inthe firewall settings.

If you can’t figure it out, let us know and someone will walk you through it.

For a simple test, disable both firewalls and ping from one computer to the other and see if you get a response.

Also, make sure they are both configured to use the same subnet.

OK, that solved one problem. Thanks for the help, xash.

I went into each firewall and added the other computer to the trusted zone. Now i can ping each computer from the other, and the folders that i’ve set to be shared show up on the latop.

But now i have another issue.

The desktop has three accounts: Main Admin, mhendo, and mrs_mhendo. Main admin is an administrator account that i use for adding software and other global stuff. The other two accounts are restricted accounts (no program installing, etc.) that we use for day to day computing.

As with all XP boxes, there is also a Shared Files section.

Now, the laptop is my wife’s, and i want it to be able to see the Shared Files section, as well mrs_mhendo’s documents. So i went to each of these folders and set them to share.

On the laptop, i then went to My Network Places and, sure enough, both folders appeared in the frame. So far, so good.

But then, when i actually went to open these folders from the laptop, it allowed me to open the Shared Files folder, but it wouldn’t open the mrs_mhendo’s documents folder, telling me that i didn’t have permission to access that folder on the network.

Anyone know what i’m missing here?

Try this:

Right click on the My Documents folder after logging in as mrs_mhendo on the Desktop. Select “Sharing and Security”. Make sure “Share this folder” is enabled. Click on “Permissions”. Make sure “Everyone” is selected, and at least “Allow/Read” is selected for “Everyone”.

The other reason why this might not work is that your desktop is using NTFS as a file system, and the folder is encrypted for use by mrs_mhendo’s login only. I don’t have the environment to try out different options, but see if you can figure something out along these lines.

This is only half the story. Windows uses two sets of permissions: share level and file level. When accessing something, the more restrictive applies. xash has told you how to set the share level permissions, but you’ll also need to set the file level permissions similarly. And don’t use the Everyone account: this is a security risk. Either specify the accounts explicitly, or (better) create a group (e.g. ‘The Hendo family’) with both accounts as members and apply permissions with that.

This is really good input and I wish XP made it more obvious. If you have NTFS, you have two sets of permissions (share and file); if you have FAT32 you only have one (share). From memory, I believe XP Home hides the option for file permissions, but you can get to them if you boot in to Safe mode.

Thanks for the further replies, folks. I think that we might just stick with having the Shared Files section available to the laptop. I’m not quite sure exactly how to go about changing the file-level permissions, and it’s not like we do a whole lot of moving files about anyway. The main thing is that, when our new printer arrives this week, i want her to be able to print directly from the laptop, so i’ll set up printer sharing.

That will work. If you want her to be able to print even if the desktop system is off, then you might look at print servers. This will interface your printer directly to the network without needing a full blown computer in the middle. (the print server IS a minimalist, single furnction, computer)

It’s probably moot if you leave the DT on all the time, though it would let you put the printer in a hallway or such where it might be more convienient, or less distracting, on average, for all the users.

OK, now i’m getting annoyed.

The new printer arrived today, and i set it up on my computer. Unfortunately, it won’t connect directly to my router, so i have to connect it to my computer and have the laptop access it via the network that way.

After installing the printer, i went into the Printers section of Control Panel and set the printer to Share.

Then i went to the laptop, and not only could i not set up the printer, but i could no longer even see the desktop’s shared files in the laptop’s My Network Places. I haven’t changed the file sharing settings or the firewall settings since the other night, when it seemed to be working.

I don’t know what the hell’s going on here, and i’m rather frustrated that i can’t figure it out. I’m a pretty smart guy, and even though i’m no IT expert i reckon i probably have more computer understanding than the average home user (not hard, i know). This just shouldn’t be so fucking difficult!

If anyone has any more advice, i’d love to hear it.

Sorry for replying late…check if your IP addresses have changed since you last made a change in the firewall trusted zone settings. If the IP addresses have changed, add the new ones to the trusted zone.

Also, from the machine to which the printer is connected, go to Start/Run and type “\” and see what comes up. If nothing comes up, you probably haven’t shared any folders correctly. Re-configure shares from the “Sharing and Security” options as mentioned above.

Thanks for the reply, xash.

Actually, everything seems to have fixed itself since my last post. The sharing is working (at least for the "Shared Files " folder, which is good enough), and we can now print from both computers.

Not sure exactly what the problem was last time around, but the next day everything was working fine, so it might have just needed a reboot or something.

Thanks for your help.

To do this you will need a print server like Kevbo mentioned.

This will make it so you do not need the main PC on all the time to access the printer.