Help!! Need UNIX Make help...

Any one out there familiar with UNIX Make? I’m trying
to set up a development environment, including a “”
file, but when I try to compile I get an error message
saying “Must be a separator on line 48. Stop.”.

What separator?!?! this is what lines 48 and 49 look like:

#echo "Step 3
.c.o: <==This is line 48
gcc (CFLAGS) -c -ggdb *.c

I’ve often seem similar errors (i.e make complaining about missing seperators) when the Makefile you are trying to compile from expects that you are using the GNUmake program, when in fact you are using whatever version on make came with your OS. You should be able to get GNUmake from (I’m assuming you are trying to compile someone else’s source code that you downloaded from somewhere right?)


It’s DEC unix, and you are right, I am trying to use a GNU compiler. What’s frustrating about this is that I can use the same evironment, basically, on our production server.
I’ve been doing it there for weeks to make small tweaks
in some of our production code. But now I have a major development project coming up, and I don’t want to use the
production box for that. So I simply ported everything over
to the development box and encountered this error. Others
in my office have encountered it too, but its been such a long time they’ve forgotten how they got around it.

First guess - indent the gcc line with a tab, so it looks like an action rather than a new rule.

TABs, read up on TABs, the bane of Make.

The error is occurring earlier in the file than the lines that you posted. The line number mentioned is where make’s parser realized that there is an error.

Starting with the line you pointed out, look upward toward the beginning of the file. Lines that start with a # are comments…those are ok. Lines like “x=y” are ok too. Every other line must start with a tab character or it must have a separator. Somewhere earlier in the file is a line that does not start with a tab nor does it have a separator. The separators are colon and double-colon (: ::).

I got some very helpful information which enabled me to solve the problem.

Not worthy of a thread of it’s own, I’m hoping some UNIX savvy doper can clue me in about this.

At work all of the WAN monitoring applications are run via GUI interfaces on a UNIX platform. They look like Windows, and the workstation is Windows (NT4.X) all right, complete with File, Edit, Map, Telnet, etc. right up near the title bar. But here’s the puzzle: Using the ALT+F key combination does not bring down the file menu for some reason. I have tried CTRL+F, CTRL+ALT+F, CTRL+SHIFT+F, and a number of other key combinations in the hopes of stumbling on the magic combination that works for UNIX applications. Clicking on them with my mouse brings them down, but the shortcut keys don’t work.