Help with cable modem/wireless router setup

Okay. I didn’t realize there was a specific order you had to power things up in, and I did it the wrong way.

Here’s my setup. Dell PC running Me, Linksys router, SURFboard cable modem (not sure if that’s the manufacturer or the model). I connected them in the right order, but didn’t power them up in the right order. So now, I have one of the router’s internal IP addresses in my PC. I have removed the router from the equation for the time being. My modem has 5 lights, which light up in order during the initialization sequence. The first light, Power, lights and stays solid after about 20 seconds. The second light, Receive, flashes continuously after the Power light stays solid. The other 3 lights never light.

My IP help desk was content to tell me it’s not an issue of theirs, judging from the 192 IP address.

So I’m stuck. When I run winipcfg and release all/renew all, I get the same IP address back, even though the router’s not in the path anymore. I’m set to autograb an address. Do I need to delete the IP service from the network properties and reinstall it, or is there another way to skin this cat?

I’m not sure I understand what your problem is. Are you saying you release and renew the IP address with the router not hooked up at all and still get a 192 address? That doesn’t seem possible without another DHCP server on the network. Linksys routers are configured to act as DHCP servers by default. You can turn this functionality off, though.

Your modem should be handing out a real Internet IP to the router, which uses NAT to translate that into a private address for your internal network.

Do you really need DHCP? Have you tried setting the address on the computer statically to something in the 192.168.1.x subnet?

Yep, that’s it exactly, ns. I have taken the router out of the equation, and hooked the PC directly to the modem. Release/renew simply gives me back the exact same IP address every time. I’ve left the PC as DHCP because I’m fairly certain that’s the way the cable company set up my original connection a few years back.

I’m trying to get my original PC to modem connection back up so that I can verify I have a good internet connection before I put the router in. Under the advice of a friend who’s gone through the installation before, I think I’m going to call my cable company and ask them to ping the modem when I get home tonight. I’m still not sure if all the indicators on the modem are supposed to be lit, or if it has to communicate with the PC for all of those to come on.

The cable modem I have generally gives me the same IP address every time. I understand this is generally true for cable modem systems. When you hook your PC up without the linksys box can you see the internet?

Sorry if I was unclear. What I meant was have you tried setting the private IP address statically with the router hooked up? Generally, the way it works is that the router acts as a DHCP client for the modem. The router says “give me an IP address, any IP address” to the modem and (hopefully) the modem complies. The router then converts it to an internal IP. Whether you enable DHCP on your computer for this or not is up to you. You can just set a static address in the 192.168.1.x subnet (where x could be any number from 2 to 254).

Still, all of that aside, it’s quite strange that you renew to that address when there’s no DHCP server handing out internal addresses on your network. Maybe it’s yet another in a long line of stupid Windows Me quirks. Perhaps you could try uninstalling and reinstalling your network card.

Your computer will also sometimes pull up a 192 yadda yadda IP address if your modem needs to be provisioned. Your cable compnay should help you with that, if they aren’t a bunch of meanies.

Your SB modem should have solid power, send, receive, online and a flashing activity. If any of those aren’t on, it is a problem on your cable companies end. There should be a flashing light on the back of the modem which indicates the connection with the computer.

The cable modem I have generally gives me the same IP address every time. I understand this is generally true for cable modem systems. When you hook your PC up without the linksys box can you see the internet?

Sorry, I can’t read. This is on your cable companies end, not yours. You only have a flashing receive on a Motorola Surfboard? There is something wrong with the signal your modem is getting, not because of the router. If you have a stand-by light on the top of the modem, try hitting that to see if you get any more lights. If not, unplug the modem and leave it disconnected for a minutes, and reconnect, if you still don’t have more lights, call your company.

Here is the Surfboard instruction PDF:

To echo what the others said I have a Motorola Surfboard modem and after initialization all 4 top lights stay lit continuously and the bottom orange light flashes. Your cable modem connection is messed up or the cable modem hardware is. Unlug the power cord form the rear of the cable modem, let it sit for a few minutes then plug in and have it re-initialize. If lights still behave as you indicated the problem is likely to be on the cable modem side.

Pfah: I spent an hour and a half on the phone to Linksys tech support with roughly the same question… Whatever happened to “plug and play” (the ideal, if not the technology per se?)


Note to everyone-you cannot, apparently, have two splitters in line between the cable signal entry and the cable modem. When I took the second splitter out and connected the modem to the first splitter, the signal came through and all lights lit up.

So this was my fault, as I put the second splitter in line, but it was NOT a problem with my network card, as the cable company’s crack diagnosis team told me.

But yes, ns, the problem with it getting a 192 address occurred even after I had uninstalled and reinstalled the card. The card was connected via cat 5 to a (at that time) nonfunctioning modem, and still renewed a 192 address. Fun.

Thanks, everyone, for your help.

Cable modem service only lets you use it with one computer, according to the service I just looked at, so they assign one address, which seems to be what you have.

But then since you talked to the techs already it seems there isn’t much more we can do.

Did you try to assign another one manually?