Help with new router!!

My roomate just purchased a new computer and a new router. The router is a Linksys Wireless B Router, the BEFW11S4. Now, we are able to get connected with the old router, we are able to get connected with just the modem, but we can’t do jack with the new one. If I go to the status area of the router (by going to I can see the status of the IP that we’ve been assigned, right? Wrong, there’s nothing there. I mean no IP that’s been assigned. I looked at the address from our old router and can see that one but I can’t get the new one to acquire anything. I’ve tried to Release the IP but that doesn’t work either.

I’m about to throw the damn thing out the window and get two tin cans and a long piece of string.

Also, I tried to call Linksys’s help number that they gave me but of course, it’s one that’s in India so I can’t understand what anyone was saying. I mean, if your going to export all our jobs across an ocean, the least they could do is get someone with an accent I can understand!

First of all, if you’re going to post computer questions anywhere, learn to provide some info. “Modem” is not specific enough. We need to know ISP, machine types, OSes, and on and on.

Note that if you have a cable modem, most ISPs only allow you to hook up a given network device based on its “MAC address”. Your new router won’t have the same “MAC address” as your old NIC, but it can be set to have the same one.

I’d tell you more about this, but since you didn’t provide enough info, I might be wasting bytes on the wrong problem and cure.

Are you referring to your internal network IPs, or your IP assigned by the cable modem through PPP (or whatever it uses)?

Have you checked your DHCP settings?

Arright, I’m assuming you guys are competent enough to have actually plugged everything in correctly, and that you are on PCs.

That being the case, go to your command prompt.
Type ‘ipconfig /all’
Look up your default gateway.
That is the IP addy of your router.

After finding that, hopefully you know how to log on the router and tweak it and whatnot.

Okay…ftg is obviously right in that my post was horrible. I plead anger caused by computer (or my lack of knowledge of them) your honor.
Let me try again and try to include all the important information.

We were running two computers off of a Linksys router through a D-link cable modem. One was XP home the other was ME. We are taking the ME off and putting on a new computer that is running XP Home. At the same time we are removing the original Linksys router we had (the BEFSR41) and installing a new one with wireless access points for a future laptop. We don’t need the wireless right now though, just the wired.

So we want to run two XP Home machines off this new router and it seems like it should be easy enough.
I think the two computers are set up correctly as I’m able to get online with both using either just the modem, or the old router.

My ISP is Comcast and doesn’t require a domain name or password. I have the router set to “Obtain IP automatically” because I know I don’t have a static IP. The cable is hooked up correctly (I think!!!) as I’m able to log into the router and see the settings.

I’m just lost as to what else to try. The router came with an installation disk that we tried but when it tries to check the internet connection it doesn’t find any.

Any help would be appreciated… Thanks again.

Ya know, I was just thinking. The thing that would make the most sense is that I have it hooked up wrong. I mean, Maybe I have the Cat from the modem to the router in the wrong plug. But I really think I have it right!

Looking at this image (I’m not at home) of the back of the router shows the 5 plugs. I know that I had the Cable wire plugged into the first one (the one by itself.) Is it possible I’m reading the plugs wrong for some reason? I wish I had a better picture of it here!

Does anyone else have any experience with this router?

Trying resetting the router to factory default. With Linksys routers I think that’s done by holding in the reset button for 10 seconds, but you may have to check your manual.

I tried that with everything unplugged (except power), should I give it a go with everything still plugged in?

Also, I didn’t mention it but the latest version of the firmware from the Linksys website is already on the router.

Note: I’m assuming that your main problem is that your router isn’t getting an IP address from your cable modem. Nothing will be able to access the internet if this is the case, but you haven’t really come out and said this yet.

Sometimes cable companies will configure their DHCP servers to only respond to known MAC addresses. Which is why most routers have a setting where you can configure the MAC address that it displays to the outside world.

Check what that setting was on your old (working) modem and replicate that setting in your new modem.


During this entire ordeal, have you unplugged the cable modem from the wall? The cable modem remebers which device it was talking to, and it won’t forget just because you press the power switch. If you unplug the cable modem for half of a minute or so, that should be long enough.

This is a bit easier than MAC address cloning, I think.

I’m pretty sure this is the problem. I didn’t want to say that it was because I don’t know that I know enough to be sure. When I check the status (on the router) I can see where it should show the IP address that Comcast should give me, but all I have are zeros. Also, on the old router it showed how much longer the “lease” was. I assume that’s the time that I could count on that IP, before it could change.

So your suggestion is to get the MAC address from the old router and input that into the new one? I believe there is a spot for that so I’ll give that a shot tonight.

I have had the modem unplugged from the cable and power, but I don’t know if I did it at the same time. I’ll also try that tonight.

Just reaffirming: If the router’s WLAN IP address is all 0’s, it means that it isn’t getting an address via DHCP, and this is the root of all of your problems. So my suggestion before is worth a shot.


Before trying to change the new router’s MAC address, I’d try the suggestion of power-cycling the cable modem to make sure its DHCP table is cleared out. If it’s configured to only give out one IP address, it will not give your new router one as long as it thinks your old router still ‘owns’ that address. You’ll only need to change the new router’s MAC if the ISP has configured the system to give out only one IP address and to only give it out to a machine with a specific MAC.

As others have stated, hookup the new router, make sure it’s set up correctly THEN power-cycle the cable modem. I’ve installed dozens of routers and this is usually the culprit. Sometimes you don’t have to do this, but I’d say about 85% of the time you do.

I happen to have the same router, and I have had the same problem a couple of times…

Under your network settings, it will have an option saying something about obtaining IP address automatically. Make sure that this is set to “YES” and everything else is blank.

Power down your PC using Start>Shutdown|shutdown. Make sure it stays down. :slight_smile:

Unplug the cable modem

Unplug the router

Wait for at least 10 seconds- go ahead and count them off.

Plug in the cable modem, wait for it to connect. (I have a Motorola Surfboard, mine has four or five lights that light up in sequence until they start blinking randomly; look for an “Activity” light to start blinking more or less randomly.)

Plug in the router

Turn your PC back on; go ahead and log in normally.

Connect to your router by opening up a web browser and typing into your address bar.

On the basic settings page, make sure that “Does your Internet Connection require a login” is NO, Account Name/Domain Name is blank, Internet IP Address is set to “Get Dynamically from ISP”, “Domain Name Server (DNS) Address” is set to “Get AUtomaticly from ISP”, and Router MAC Address is set to “Default MAC Address”.

Go ahead and click “Apply”, then “Test”. If it works, you’re good. (Although your other PCs will probably require a reboot.)

I hope this helps! :slight_smile:

If the problem is the new router’s MAC address you may be able to have this taken care of very easily by calling your cable company and explaining that your old router died and you’ve got a new one. They should be able to clear out wherever it’s stored and have your connection listen for the new device.

Given that everything sounds like it’s hooked up correctly (the lone LAN port is the link to the cable modem, correct) and the router isn’t getting a DHCP address that sounds like the problem.

You can also check the silly stuff - LAN cable is OK, it isn’t a crossover cable.


When I got home from work I found that my roomate had gone and bought a new router. I mean another one. We had both here tonight as we tried things so it wasn’t just a broken thing or anything.

I tried everything listed here and more.

I called Comcast and asked a Tech guy if there was anywhere that the MAC address might be stored there. He said no and even went so far as to help trouble shoot a few things… power cycling, checking the settings I had, etc.

No Dice.

I called the Linksys help line and (thank god) got a nice woman who spoke very lightly accented English. I was able to understand everything that she said and was on the phone for two hours trying everything from MAC address cloning to power cycling, to reflashing the firmware (even though we had the current version). She tried to have me set it up as a static IP, using the IP, Gateway, and DNS listed when using only the modem to computer - that didn’t work.

When she was all out of ideas she asked if I had a long piece of cabel, like 50 feet? I don’t have any that long laying around so I said no. She suggested that possibly the modem was having a hard time communicating with the router because of the speed of the router compared to the speed of the modem. It sounded like a bullshit excuse to get off the phone, but I don’t think there was anything else she could try anyway.

I called Comcast and spoke with a different Tech person and asked the questions again… still the same answer and this guy also tried to help me. It was nice of them because they really don’t need to since the modem is recieving the signal.

I don’t know… I think he’s ready to give up and return the two routers and try a different brand… I don’t know what to do. I know a little more about computers than him, but I certainly don’t know much.

Thanks for all the suggestions… I wish I could have made them work!

Well, just for some closure.

He gave up entirely on the linksys router and decided to go try a different one. Today when I came home he had a Netgear router so we tried that…

No dice of course.

So he went to Office Depot where some crazy lookin’ guy helped him. He said he’d heard of two other people who had the same problem. He talked him into buying a D-Link router (same brand as the modem). He brought it home, powered everything down, plugged it in and powered everything up.

Then he tried to go to the router to configure it… and it came up with his home page!

I don’t know why this one works and the other two didn’t. The only thing I can assume is that it has to do with some kind of hardware conflict. I mean, we had a linksys router before with the same modem so I don’t know why those didn’t work.

Anyway, we are now up and running again.