How do I keep Windows XP from alphabetizing shortcuts and subdirectories separately?

Within a directory, I have a bunch of shortcuts to other directories (located on another drive), along with a bunch of normal subdirectories. When I view the root directory, Windows XP separates the shortcuts and the subdirectories. I cannot get it to alphabetically list the contents of the entire directory; it only lists the contents alphabetically by type. In other words, it shows the subdirectories in alphabetical order, followed by the shortcuts in alphabetical order. How can I get XP to just list everything in alphabetical order? (Using the “arrange by name” function does not seem to work.)

Concrete example-- the following describes my predicament. The things in brackets are [subdirectories] and things in parentheses are (shortcuts)

Windows XP lists like this:
but I want it to list like this:
How can I do this?

Right-click --> Arrange Icons By --> Show in Group.

Er, no offense, but I’m guessing he’s looking for a way that doesn’t make the display completely suck. :slight_smile: When I do what you suggest, I get a display that looks like this:


[icon] A


[icon] B


[icon] C


[icon] D


[icon] E


[icon] F

Is it really that bad? It just uses a little more room to display a header for each letter. But maybe someone else knows a better way :slight_smile:

Drag and drop them where you want them. You may have to right-click and uncheck “Sort alphabetically by name” first.

I don’t think that will work. AFAIK, XP will always want to sort by something. I don’t think you can uncheck the method it’s sorting by, just check a different method. So while he can move thenm around, the next time he opens the folder, they will be back to the ay they are.

I have never seen directories and shortcuts/files intermixed. Is it really that big of a deal? I mean, sure, it might be a tad annoying that it doesn’t go ABCDEF perfectly, buy so long as you know where they are it shouldn’t matter, right?

Ah… that could be true. I am on '98 here at work so sometimes I get confused… :smack:

After some experimenting, I have found the following solution:

First, uncheck the “Auto-Arrange” feature by right clicking in a blank space in the folder and clicking on it. Them simply arrange all the icons where you want them to be, and to clean it up, again right click in a blank area and click on “Align to Grid.” Voila!

I tried what Bouv said, but it doesn’t seem to work in list mode. Any other suggestions?

If you don’t mind a really lame workaround, you can make shortcuts to the actual folders. The shortcuts will be sorted as normal files, but they will still lead you to the folders when you double-click on them.

As for the real folders, you can either leave them at the top of the screen and ignore them, or you can place them somewhere else so that all you have in the original folder are your files and folder shortcuts.

That’s for desktop icons. I believe the OP is asking about objects in Explorer windows.

Hm… that’s an idea. Hadn’t thought of that. I guess I COULD make a folder in the root folder called [Music Vault] and move all the non-shortcut subdirectories into there, and then make shortcuts to all those, and then move those into the root directory. Seems a trifle silly, but I guess so far, it’s the leading contender.