I can't delete my PMs

The title says it all really. I am unable to remove any of my PMs.

My WAG of info that they’re going to want:

1.) Your browser and OS.
2.) What process exactly you’re using to try to delete PMs.
3.) What exactly goes wrong during that process: it appears to function normally but the PMs are still there, the button does nothing when you click it, you can’t select messages to delete, it gives a specific error message, etc.

I can manually delete them out of the system for you – and we’ll do that if we have to – but yeah, let’s find out how you’re doing this first.

I just backed up all my old PMs and deleted the really old ones. Here’s what I did in detail:

  1. Went to the UserCP and clicked on “Private Messages” and then “Inbox.”

  2. Down at the bottom of the form there’s a hyperlink that says “Download all private messages.” And you have a choice of formats. I chose a format and downloaded that file to my hard drive. You don’t have to do that unless you want to.

(You could also move them to another folder, if that’s your preference. )

  1. Once I had ensured that I had indeed saved all my messages I returned to the inbox. I could have at that point mass deleted everything but instead I chose to do this page by page checking to see if I had overlooked anything. (I’m tedious that way.)

If you want to mass delete, look for the hyperlink under FOLDER CONTROLS where it says “Empty Folder.”

I went to the last page first and clicked on the little box on the right hand side of the listing where it totaled the number of messages on the page. Clicking in the blue band marked all the messages on that page. (You can selectively check/uncheck for what you want to keep and not, as you wish.)

Then I scrolled down to the bottom of the page to where it said “Selected Messages,” checked that menu item to “Delete,” and then hit the GO button.

(The options in the menu are DELETE, MARK AS READ, MARK AS UNREAD, and DOWNLOAD (in various formats).

I did this for each page in my Inbox, checking and deleting as necessary.

I then clicked over to the Sent box and repeated.

It worked okay for me.

Please let me know what I can do to help you.

The PMs appear to be gone now, but this morning I repeatedly tried deleting a number as my inbox was approaching full and they just didn’t budge. Thanks for your replies.

Possibly buffered on your computer and not updating after you deleted? Later it refreshed and cleared the buffer?

I noticed early this morning that the board was having a problem Timing out. This may have been involved.

Just want to mention a program for reading your archived messages, if you save them in XML format. I’ve tested it and it works.

The link I provided shows that it contains no spyware, just in case you are worried about that. It’s a trusted download source, and provides a link to the webpage. The program itself is a bit old, but so is this vBulletin version, so it works okay, even if you lose a small bit of formatting inside of quotes.

Personally, I get an email alert for every PM that contains the text of the message; so I just delete the PM and save the email. Works fine for me, so that’s a potential option, too.

Hah. Cool. Thanks!