Idiot needs help with Vudu Disc to Digital

I’m pretty backward at technology, but when I learned about this Vudu Disc to Digital yesterday (I know you all were talking about it a year ago) I thought it looked pretty simple. So I set up an account and got ready to scan my first disc.

I keep getting the message “Please enable Location permissions in device settings.” I have an iPhone 8 and as far as I know I have done this. I’ve looked at every setting I can find, but, as I say, I’m an idiot.

I called the Vudu support line and talked to a nice man who couldn’t help me. He sent it up a level and they’re investigating. Meanwhile, I dragged out my old phone and charged it up and I’m getting the same thing.

So is it me? It’s me, isn’t it? What am I overlooking? What setting do I need to I set to make this work?

On the phone, go to…

Settings -> Privacy -> Location Services -> Find the app and set to “always” or “while using” whichever is appropriate.

I do t see an option other than “on” and “off.” I have it set to “on.”

Hm. What version of iOS are you running? The options have been “never”, “always” and “while using” for quite a while now.

I suspect that your version of iOS is too old for the Vudu app but it should have checked that and refused to install.

Better question I guess, are you doing this in the Vudu app or in the browser? From what I can tell, on the iPhone you can only do this from the browser now. So are you sure you have location services for the browser enabled too?

I have 12.0, and I am using the browser, not the app. I understand it can’t be done in the app. So maybe I have the problem with the browser. Where should I look for that?

Disc-to-Digital is basically the only reason why I have the app installed on my phone. The scanning only works through the app, because the app needs a lot of stuff that your browser doesn’t (like location data and access to your camera).

Use the app.

Follow the same path as above, but look to see what your “Safari Websites” permission is set to…

Settings -> Privacy -> Location Services -> Safari Websites

Can’t. That function is no longer supported in the app on iOS. It’s browser-only.


It’s set to “Never.” The other option is “While using the app.” So I did that, and it worked!

Of course, the first five DVDs I tried are not in the system, but at least I know how to do it. Gracias.