Intermittent dishwasher issue

I have a Kitchenaid dishwasher, this one, to be exact. It’s about a year and a half old.

Starting three days ago, I’ve starting having this weird issue where it sometimes works, and sometimes doesn’t. The first day, it filled up with water, but just doesn’t didn’t seem to clean anything when I opened it up in the morning. I thought, hey, maybe I forgot to set it. So I put it through another run. It started up, filled up with water, and then it just seemed to sit there and stew for a couple hours. All the lights indicated to me normal operation, but I did not hear the usual swish-swash of water within it. Hmmm…

When I opened it, there was hot water in it, and water had obviously condensed and gotten the dishes wet, but I don’t think any of the “sprinklers” or whatever you call them did anything.

I cleaned out the mesh trap, checked the float, ran it again, and this time it seemed to work.

OK, so I thought I’m good to go.

Yesterday afternoon, next use, I go to run it. Same sort of thing happens. I hear water being drawn in, some motorized sounds, and then it sits for a couple hours, stewing warm, and goes into a drain cycle at the end.

Huh. So I clean it out again. Still doesn’t seem to be doing anything. So I reset the washer by cutting power to it for a minute. I select a manual mode for washing “regular clean” instead of the “Pro Wash” mode I normally use, and let it run overnight. In the morning, I’m greeted to a white light, indicating that it ran through its entire cycle and is finished, and I have nothing but dirty and damp (assuming from condensation) dishes. Before running out the door this morning, I pop in one more pod and run it.

Now it’s working again. Chugging along just fine. I hear all the normal water splashing noises and everything.

What in the heck could possibly be going on here? This is my first dishwasher in my life, so I’m not super familiar with these things. Is there anything obvious I’m missing?

I have one similar to this and this is what I’ve learned.
First, get a service plan. It might be too late for you. But gone are the days when you pay more for a appliance and expect to get better quality out of it. Your parents may have told you that a service plan is just throwing money away, but today, and in my experience its not. I buy the lowest end appliance and spend the extra money on a service plan. I’ve had repair people out for my dishwasher at least 6 times in the last 4 years, mostly because it isn’t cleaning the top rack.

Second, if its like mine, the sludge and crap that gets built up affects the cycle. The repair people dig in and clean out the clogs and sludge. It affects the power of the pump (not getting the water to the top rack) and the on/off cycle because the float sticks.

Third, the odd on/off cycle could be due to the float sticking. I suggest finding the float, pulling it off and cleaning it out. Or sometimes I just jiggle, spin the float to get it to break loose from the crud.

Fourth, I’m a bit (but not wholeheartedly) a fan of Glisten’s dishwasher magic. It contains citric acid which is what industry uses to clean food grade equipment. I try to use it everymonth or so to reduce and dissolve the crud. Sometimes I forget to do if for a while and sometimes I double up on the dose… I think it really does help…but then what do I care if it doesn’t work…I’ve got a service plan!

Fifth, it might not be any of these, and could be an actual faulty part that needs repaired and replaced. Maybe you can get a service plan now then call tomorrow and have it repaired…don’t know.

I still think ‘service plans’ are throwing money away. Appliances are cheaper than ever. Go by reviews.

Wirecutter thinks that dishwasher you bought isn’t so reliable. They think you should get a bosch.

When you do have problems like this, you can :

a. Try to fix it yourself. If you can narrow the fault down to a single thing, this is feasible.

b. Buy a used one off craiglist. Appliances are so cheap these days that used ones are especially cheap. If you can get a replacement for a couple hundred bucks, and it works fine for a few years, this is by far the most economical option.

c. Just get another one. If you have enough income, it’s not big deal. If you don’t, well, you should be renting. You shouldn’t own a house/condo if you can’t afford the $800 hit for a major repair or appliance several times a year. And if you are renting, get your landlord to replace it.

Well, I’m not really interested in buying a new one since it’s only a year and a half old and I otherwise love the thing. The options for me right now are either self repair or hire someone to repair. I can afford a new one, but it seems like a waste. My main question is more like what kind of a problem does this seem to be? My last load came out squeaky clean, as normal, so it’s a bit more difficult to pin down when it does sometimes work. For all I know, I could be jumping the gun and the next loads clean just normally.

I would try to follow the instructions in this video to take the sprayer assembly apart and check for any debris or blockages. I think yours is similar. Something like that could easily be intermittent as things move around.

Mine had a problem with crud clogging the drain. The drain filter looks pretty big, but the actual drain hose is a skinny little thing, so you can imagine how it could get with chunks of food and other stuff that somehow evade the screen.

Use a wet/dry vac to empty out standing water after a failed cycle. It sure beats trying to bail or sponge it out.

In my case (with my LG dishwasher), whenever I have a drainage issue, I put compressed air in the reverse direction into the drain line under the sink, blowing everything back into the dishwasher. This seems to dislodge whatever is causing the problem.

Note that this approach could damage other dishwashers, so it’s advisable to check out what other people have done with your particular model.

Unfortunately the symptoms you give are intermittent faults in the electronics.

(1) You know the sprayer works, a clog will not cause it to not spray at all.

(2) You know the motor works, or it would not be able to pump the water out.

(3) You know the relays driving the motor work, or it wouldn’t clog at all.

You probably need to replace the main control board. Maybe. Or a faulty sensor. You need to make absolutely sure those are the symptoms, I’m going by what you told me. You absolutely need to narrow this down.

Did you buy it with a credit-card with a extended warranty, if so you may be covered for the repair, it looks to me many major appliances are at least 1 year manufacturers doubled to 2 by the CC. (most I have seen the CC add is 1 year, so if it’s 3 years you have 4).

I wonder if it might be something along this. I had to get my kitchen drain snaked about a week or two ago when it completely stopped up. I’m wondering if it is some kind of crud issue. The drain hose itself, which is translucent, seems to be clean from what I could see, though.

At any rate, I’m running through some Glisten as we speak, and the dishwasher is functioning normally for the moment. I’ll have another look at the washer when it’s done and look more closely in places where there could be debris. I was wondering if it could be some crud in the float that is causing the cycle to end prematurely, but I don’t see anything there. That said, I haven’t actually taken it out, just jiggled it around a bit. I’m not entirely sure how it comes out, but I can figure that out if the next step is required.

The control board issue is the other possibility I was wondering about, but I want to eliminate physical defects first.

I should also say, it is still under warranty for “electronic controls” but I don’t know if that just means the control panel on top of the dishwasher (the one with the buttons you press) or the electronics in general. I guess we’ll cross that bridge when we come to it.

I think they are all one and the same.

It is possible to replace the electronics in the door, but hopefully not necessary.

We also have a KitchenAid. We love it when it works, but we also intermittently have squirrely symptoms which seem likely to be electronics.

I had one that did this, was a GE but…

The reason was that the motor was not starting, was not spinning.
Seems build up in the impeller/shaft area made enough drag that the motor could not spin itself, but flipping it made it start spinning.

I used liquid wrench to clean the impeller and shaft up and it seemed to help.

It would do what you describe, it will fill and heat and sit for the duration of the cycle
go through all the motions and make all the solenoid sounds, but it didnt wash and it didnt drain.

We’ll see. It’s a great dishwasher. (I actually may have the model wrong in the OP. I just picked one that looked like ours in a similar price point on the internet, but the control panel is different). We picked it over the Bosch at its price point because it actually had better reviews and despite all the “Bosch is awesome” people, the brands seem quite comparable to me, with an equal amount of people saying one is awesome and the other sucks. (We originally were going to go with a Bosch, but there were a couple of things that we prefered about the KitchenAid. I can’t quite remember what they were, though.)

Do you hear anything like the drain trying to drain DURING the cycle, but failing to do so. It sounds like it drains afterwards, correct? Do you notice any flashing lights during the cycle (for example, in one DIY forum, I see that KitchenAid dishwashers will flash a “clean” light during the cycle when there is a problem). Do you see any error codes?

I’ve found that DiY and Appliance Blog (and other similar sites) are good resources to talk you through this type of issue.

I found this solution posted for a machine that’s older than yours, but it’s worth a shot. One caution, since your model is newer, you may need to search for a different key combination for the diagnostic before you move on to a technician.

Here’s the page on ApplianceBlog. Again, older model, sounds like same issue.

Yeah, no error codes, no flashing lights, nothing like that. Just the normal solid blue light while it’s doing its thang, and a white light when it’s done a couple hours later. I cut the power last night to it to try to reset it as I couldn’t find a reset button sequence that launched it into the diagnostic mode (I tried five sets of alternating button presses, but there was no response I noted. But I don’t think I did one involving Sani Rinse, so I’ll try again. The reset sequence I found involved Hi-Temp and Heated Dry or something like that. I didn’t try all possible combinations, though.)

I’ll experiment a little more if tonight’s wash doesn’t work. Like I said, it seems to be working just fine now. And it cleaned the last load just fine as well. But I literally did not do anything between the last non-working load and when it decided to just start working this morning other than run it again. This current working load is just a dose of Glisten because, why not? :slight_smile:

I worked briefly as an appliance repair tech for Whirlpool/KitchenAid. If you like the dishwasher, call the manufacturer and explain your situation. It is not uncommon for them to help out a customer with either a free or discounted repair. They will also be able to recommend a local service company.

If you do call a repairman, make sure they are a factory authorized company. If the problem turns out to be a part that is warrantied, (control board) you will only be on the hook for the labor charge. If you call a repair company not contracted through the manufacturer, KitchenAid will not send warranty parts.

IMO I think the problem lies with your wash pump. If it fails your dishwasher will fill, heat, and drain, but not clean.

The easiest way to see if the wash pump is working is to take both wash arms and point them in the same direction. Run a short cycle and see if they are in the same position afterwards. If they haven’t moved, then your wash pump isn’t working.

My memory is a bit rusty, but I think to get into diagnostic mode the code is: 1-2-3,1-2-3,1-2-3

1 can be any key you choose, 2 is the key to the right of 1, and 3 is to the right of 2

For example you might press “power wash,” “heated dry,” “sani-wash”, “power wash,” “heated dry,” “sani-wash”, “power wash,” “heated dry,” “sani-wash”

I doubt you have those exact buttons, but I hope you get the idea.

Sent from my XT1254 using Tapatalk

Sweet, Twistedjay. 1-2-3, 1-2-3, 1-2-3 did send it into some sort of diagnostic mode. I have no idea what’s happening, but it’s blinking lights, going running some water, draining. I dunno. We’ll see, but at least now I know how to get it going.

The one thing I noticed now is that though the washer ran the last three times, plenty of water, clean dishes, is that it doesn’t seem to be heating the water up all of a sudden. At least when I open the thing, I don’t get the usual blast of hot air. But it definitely was generating plenty of heat the few times it didn’t work properly through its cycle.

So, let’s see what this reset brings…

Congratulations! You are an early runner for the “Stupidest, Most Privileged Thing Said on the Internet” award for 2018!

Yeah, seemed a bit of a non-sequitor to me (and someone ironic as my wife and I own more than one property and are well aware of the costs of ownership and when it’s wise to spend money on replacing appliances and when it’s good to repair it.)

At any rate, last night’s dishes were a success, and the heat did work, so I think I’m okay for the time being. I don’t know if it’s just good luck for the time being, or if the diagnostic code did something when it reset the system, or if the Glisten helped out as well, or what. But I thank everyone in this thread, as I have plenty to go on if it decides to be intermittent again.

Just an update.

The problem ended up coming back about two months ago where it would sometimes wash, sometimes not, until it got to the point about a month ago where it would not wash four out of five times. I cruised the appliance repair boards and guessed that the problem was most likely the motor pump assembly, given that this particular motor has been known to give up the ghost rather prematurely (my washer wasn’t even 24 months old; I found another poster with a different brand washer that used the same motor have his go out at 14 months.)

At any rate, I bought the part new for $80 from Sears Parts Direct (everywhere else it was $120-$140), looked up some Youtube videos, stuck it in, and the washer has been working as good as new for the last month, 100% of the time.

So good thing I didn’t just trash the dishwasher and buy a new one. :wink: