Internet Explorer Question

How do I stop Internet Explorer from caching every form I fill out online?

Even my previous Google history shows up from the drop down list on that site. I deleted the cookies and temporary internet files. I’m sure there’s another box I have to uncheck somewhere.

Go to Tools, Internet Options, Content, Autocomplete and uncheck Forms (and anything else you don’t want).