IRC and T-1 Connections

Okay, I need some help from the techies here.

I am a regular on IRC and have been for 2 years now. However, just yesterday, the network administrator of my office (where I am on IRC) switched us all over to the T-1 line, instead of the ISDN/LAN that we had previously. I tried all afternoon to connect to IRC but to no avail. I receive error message as follows: (too many remotes in path)

Someone explained why I can’t get through, last night. He just didn’t know how to fix the problem. I tried different chat clients and even Java chat. ICQ and AIM both work fine, but I don’t use those programs. So, IRC can’t connect and I don’t know how to get around this dilemma.

As any of you who are IRC users know, its pretty addicting. I help operate a Trivia channel and really need to get back on. Well, not need, but I’m going crazy not having IRC minimized in the corner of my computer.

So – How do you make IRC work with a T-1 line???

As long as I’ve been with computers I’ve never gotten IRC. The few times I tried it I found it annoying as hell. I say this not to trash IRC (I know many people like you who love it) but to tell you that I may have zero idea of what I’m talking about and what follows is a WAG:

Given that you are on a new T1 it wouldn’t surprise me if you also got a new Firewall or Proxy server to go with it. If that is the case your company could be actively preventing IRC from working. Subtly ask around to see if this is the case. If it is I don’t know of an obvious way around it not to mention that intentionally circumventing your company’s IT policy can get you fired.

If you have a new Proxy and they don’t actively restrict IRC you may need to configure your IRC client to know what the proxy server is and what port you are allowed out on. Your IT department should have that info or else you have to resort to more sneaky ways of determing what the proper addresses are.

Also realize that a Proxy server can report activity to the people who run it. Not only do they not have to look over your shoulder to see what you’re doing they can report to your manager that you are spending time in IRC. Just a heads-up for you.

Yes, we have implemented a brand new security system. Luckily for me, the network administrator, IT manager is also my personal supervisor and as long as I get my work done, he doesn’t (and I don’t think he would) say a word about my IRC’ing. If it was a problem, he would pull me aside and let me know. So, that isn’t so much my worry.

As far as the technical side goes: I don’t want to weasel my way around the system to get out and play…if it takes that much effort, then I will jsut have to forego IRC. Such is life. I am just hoping that I can find a client that I can configure to work with IRC and my network.

Thanks for your input Jeff!!


I am a unix admin and a long time IRC addict.
First, I really need more info than that which you provided. What IRC network and server are you trying to connect to? Do you get the same error message from multiple servers? Is the error message you get from the IRC server or a firewall message? Sound like an IRC server message to me.
This may be caused by the new T1 connection not resolving back to a canonical host name. Many IRC servers require this for connection.

Provide more info and maybe I can help.

The network is voodoox. The server is I have also tried connecting to our old server, which was dalnet. Here is a bit of what I am getting:

[13:47:35] *** Connecting to (6667)

[13:48:20] *** Unable to connect (Too many levels of remote in path)

[13:48:22] *** Connect retry #1 (6667)

[13:49:07] *** Unable to connect (Too many levels of remote in path)

[13:50:45] *** Connecting to (6667)

[13:51:30] *** Unable to connect (Too many levels of remote in path)

[13:51:32] *** Connect retry #1 (6667)

[13:52:17] *** Unable to connect (Too many levels of remote in path)

I don’t know if that means anything at all. I use mIRC as my client, but I have also tried leafIRC and pIRCh and various java thruways. If it is any indication, I cannot run Telnet, either - it freezes up.

In mIRC, I have gone under Options-Local Info and tried various combinations of checking/unchecking the Normal and Server, Local Host, etc. boxes.

Gawd, we’re pathetic, aren’t we?

Thanks Mike!