Is there any way to disable markdown?

I don’t want a single asterisk to turn everything into italics, and several other common symbols that automatically do something weird in markdown. Is there any setting, or any code I can put in my post that just disables markdown?

I started using double asterisks instead of a single one so they’d stop turning into bullet points.

Also, I don’t know how it looks on other people’s screens, and it could just be the theme (Vincent) that I’m using, but bolded things are actually less bold. They’re smaller (shorter) and the lines are finer/thinner. It’s similar to using a smaller font on VB.

Not that I’ve ever seen documented.

But if you use a character that markdown thinks is magic and you don’t want it to perform that magic, just precede it with backslash.

345=60 is supposed to say 3 times 4 times 5 equals sixty, but the two asterisks around the 4 are treated as an order for italics and are swallowed. Oops.

But 3*4*5=60 looks like it should because there’s a \ in front of each asterisk. That kills the magic and just makes the * another character in the text.

Use a \ backslash = “escape character” in front of the asterisk.

  • this paragraph starts out “asterisk, space, t, h, i, s”

* this paragraph starts out “backslash, asterisk, space, t, h, i, s”

And for both of you, since backslash is itself a magic character, if you want to display one, type 2 of them like this: backslash backslash gives \.


FYI in general, if you want to see how somebody else formatted something using a feature you don't know, just quote their post and read what they typed. Then cancel your post quoting them & now you've learned something yo can use in any other future post.

I’ve yet to see that work reliably on this board. For example, when I quote your post, both of those lines start with a single asterisk. Other than the actual words, they appear to be identical.
Also, the first part of your post and the part I quoted look different. You made some type of formatting change for one part of the other, but when I quote it, I don’t see anything out of the ordinary.

I do notice, however, that the preview pane on the right looks different than your post. Both of your asterisk examples are now bullet points and the top and bottom of your post look the same. Clearly my quoting them is stripping out some of the formatting (or at least some of your slashes).

If I were designing the board, I’d rather a slash (or an even lesser used character) would trigger other things to cause formatting changes instead disabling them. IOW, the default should be for things to show up as we typed them.

Cheers, that’s certainly going to make it better. I’d prefer the option of complete disablement but you takes what youse is given I guess.

When you quote to see the formatting, do it by hitting Reply to the post, not by selecting the text and hitting the Quote pop-up. Then you should see the correct formatting.

This. In fact, this is substantially how the vBulletin VBCodes worked. All formatting was done with HTML-like tags enclosed in square brackets.

Note, to make things even messier, Discourse recognizes some combination of VBCodes and some raw HTML tags in addition to the Markdown codes. Agreed, Markdown makes a mess of things.

But wait. . . It gets worse! On top of all the above, the way Discourse parses stuff seems buggy and quirky and seems to produce a variety of anomalous results.

One example: Supposedly you can type “\(c)”
or maybe “\(c\)”
if you really want it to appear as (c)
and not as the copyright symbol (little c in a circle).

But let me put just one © in the same paragraph as the above, and then a whole bunch of those in the paragraph turn into ©. It seems, though, that putting these © things in a separate paragraph doesn’t do that. (I hope all you readers see the same thing I am currently seeing in the preview window as I type this.)

And when typing “\(c)” doesn’t work to produce (c), then trying “\(c\)” sometimes works and sometimes doesn’t. It all seems to depend if there’s a “(c)” to produce a copyright symbol elsewhere in the same paragraph.

Also, Discourse has trouble in some cases parsing nested tags, or special symbols like © within tags like in a spoiler. I played with nested [spoiler] tags and found that to be very quirky. OTOH, I played with nested [detail] tags, which behave much like vBulletin spoilers, and those seem to work perfectly well.

And by the way, I can type 3 * 4 * 5 = 60 without using any backsplashes. Putting blank spaces around the asterisks in just the right places prevents them from being italic markers.

How does that work. If I reply to LSL Guy’s post it just has an arrow and LSL Guy’s name and avatar. It doesn’t show me the nuts and bolts of his post.

I don’t want Markdown disabled.

I want it taken out back and shot.

I like Markdown. It’s one of the things I like most about the move to Discourse along with quoting-by-highlighting. You can do in 2 or 4 easy keystrokes what normally takes 7 mostly difficult strokes.

First, click the [Reply] button under my post. You get a blank input box. then click the cartoon voice balloon button at the top left of the edit box. The thingy just to the left of the big B for bold.

That will load my entire post, sneaky tricks and all into the edit box for you to look at. You can also see how it displays in the preview side. And you can mess with my tricks and see how that affects what appears in preview.

As @needscoffee says, you’ve got to quote the entire post using the voice balloon button to see it “in the raw”.

Maybe I don’t know what a voice balloon button is, but highlighting the post (just the part I want or in it’s entirety) and hitting the pop up ‘quote’ button or the ‘reply’ button within that post or the ‘reply’ button at the bottom of the thread give me the same results. And, in playing with it, I’ve found that sometimes it shows me the code, sometimes it doesn’t. I’m not sure if it’s buggy, or something I’m doing differently each time and not realizing it or possibly that it’s doing different things to different types of code, in which case that’s (to a small degree) on me for comparing links to bolding to bullet points.

As I mentioned earlier, I’m not a fan of it automatically parsing ‘normal’ text. I know VB would do that once in a while, but it seems to happen a lot more often here.
Also, unless there’s a reason for it that I’m not yet aware of, it seems odd that the various quote and reply buttons would give different results.

In the editor, the button to the left of the B. If you’re replying to somebody it will insert their entire post, code and all. If you’re not, it’ll default to the OP and do the same.

That did the trick.

Hard disagree. I was much happier with the combination of explicit format statements that you couldn’t type by mistake combined with a rich set of “click menu item to format” buttons. I don’t want to have to remember a lot of magic codes, either to invoke them or to avoid them.

In general I’m with @puzzlegal just above.

But I will say that having the preview pane eliminates most excuses (other than raw ignorance) for ending up with inadvertent markdown.

Another board I use has markdown only, idiosyncratic markdown at that, no preview, and no edit. Lots of opportunity for dumbguy mistakes there. Especially since it’s a board aimed at software folks who’re often posting snippets of code loaded with special symbols, important spacing, and weird paragraphing vs. the ordinary prose text that markdown was designed for.

As to a better editor with more clickable formatting options, one of the challenges is that Discourse is so configurable. So it’s hard to know which html tags and BBCode tags and markdown “work” and which end up ignored via either explicit server-side switch settings or via the chosen theme css just not applying any visible styling in response to them.

Heck, I bet there are some themes we have available here now that completely hide some distinctions that other themes display.