Itunes: Ripping audiobooks and categorizing them properly

I’ve imported some audiobooks I had on compact disc into Itunes. However, they remain in the “Music” section. I can’t figure out how to get them into the “Audiobooks” section.

Any ideas?

I learned this on SDMB once upon a time. If they’re in mp3 or some other format, convert/rip them into .m4a. Rename all the .m4a files to .m4b and drag everything back into iTunes.

And I think that if you’re on a Mac, it’s not good enough just to change the file extensions. It got to be so much of a pain for me, that I just keep a genre in the Music category for “US-Audiobooks” rather than try to force iTunes to treat them right.

I can’t remember the settings on the Mac, aside from the extension. Possibly the file creator and type ID (yeah, the Mac still has 'em), or something in the ID3 fields.

Yeah, I’d have no idea how to do it on a Mac but it’s probably more work. In Windows, you also first need to make sure that file extensions are shown by going into Folder Options, as it’s off by default.

The best way I’ve seen to do this is with a little program called “audiobook builder” (at least on a mac). It joins all the individual files and creates the file extension that itunes likes to read these correctly. It works like a charm every time I’ve used it.

Where can that be purchased?

I use a program called Markable.

It’s not the cleanest thing in the world but it works.

It looks like the latest version of Itunes has taken care of this. There is now an option in the Get Info window that allows you to designate a file as being an audiobook, and doing so shifts the file to the audiobook section.

What’s the reason you want them to be in the Audio Books section? I suspect it may be that the iPod knows that books should remember your last position and restart from there, while songs are set to start from the beginning each time you play them.

However, you can do the “Get Info” thing in iTunes and tell it to remember the position for the particular file. Note that there’s a bug in my version (7) of iTunes so that it doesn’t work if you set multiple files to remember the position - you have to do each file individually.

Because when I’m browsing through music, I don’t want to see books. And when I’m looking for a book, I don’t want to have to dig through thousands of music files.

Plus you don’t want a 10 hour audio book to play when you are shuffling music.:eek: