Major Goof - I re-started my MacBook, and forgot my password

Plus, I can’t remember which OS the MacBook is using. The MacBook is about two years old, and I don’t believe we’ve upgraded the OS in that time. I tried the online methods for re-setting passwords on a Mac, but none of them have worked. Can anyone help a middle-aged woman with a holey memory out? Thanks.

It is Mac OS X and not Windows though, right?

Assuming yes, my understanding is that OS X passwords can be reset by using the original install disk. Here’s the directions from Apple’s own support site.

Resetting the password is easy, but beware:
Resetting the password DOES NOT change the login keychain password, which means any saved website and email logins will be inaccessible.

To reset the password, simply boot from an OS X install disk and choose the “reset password” menu item. If you don’t have a boot disk, there is a way to do this from “single-user mode,” but it’s too complicated to explain right now.

I’ve been trying to do the “single-user mode” method from this site, but it isn’t working (I get a “socket not connected” error, or “instruction invalid,” or some stuff like that).

Okay, took a quick look around the house - as I suspected, I don’t know where my install disks are.

So, do you guys know which version of the OS X the MacBook is probably using? I’ve tried the Leopard, Snow Leopard, Tiger, and Lion versions of the Single User Mode method, and none of them have worked. Such a simple mistake - such a major hassle of consequences!

I believe any set of install disks works with any install of OS X, or at least a large range.

At this point, I’d either:

  1. Find a friend with a OS X install disk and try theirs.
  2. Go to your local Apple Store, where they can help you (but they might charge)

You must type the instructions exactly.
Your machine is probably running Leopard (10.5) or Snow Leopard (10.6) (unless you upgraded in the last year to Lion (10.7)).

Do you have a password hint? If you type the wrong password in three times, it will give you a hint.

Can you find your original install discs?
Is there an Apple store nearby?

ETA: I see you’ve looked for your discs. Oh well.
Apple won’t charge to help you, but you might have to wait awhile.

If I were in your place (I am EXTREMELY technologically challenged) and didn’t know someone who knew about computers, I would take it to the Apple store, and cry and beg for help. (I do have an extended warranty and they promised at the store they would get me out of any particular fix I found myself in.)

Progress is being made - the installer disks have been found!

Whew - the apple instructions have worked! Thanks, everyone, for your help - I don’t care how unsafe it is, I AM writing my friggin’ passwords down! (No one come steal the password book from my house, okay?)

A word of advice: Print a sheet of ALL your passwords, just in case, and hide it somewhere. And don’t forget where you hid it. If you’re anywhere near my age, you can’t trust your memory.

Just out of curiosity, how long was it since your last restart?
(I have a machine that’s going on 6 years, but that’s mostly an exercise in stubbornness).

That’s actually good advice, as long as you don’t keep it too close to your laptop.

Safety deposit boxes for the win.

As long as you don’t have your password files on notes labeled “PASSWORD,” I would think it’s a great idea to have them written somewhere, in case you forget or hit your head on something.

Hmm, probably a couple of months.

Good to know that writing down passwords isn’t completely frowned upon; the way I look at it, online people have no way of getting to a little notebook stuck inside a closet in my house (not labelled “PASSWORDS,” though). If you break into my house and steal my laptop AND my notebook full of passwords, well, I’ve got some work to do.

The instructions on how to do this without an install disk are quite easy:
Restart
command+s [while booting up]
Fsck -fy
Mount -uw /
Passwd [your username]
{enter new password twice}

i just did this for a buddy last weekend. It literally took less than 120 seconds to do…

I don’t think these instructions work for all versions of OS X.