Microsoft Word question

I’ve tried Google and other message boards but have been unable to figure this one out. Whenever I open a Word attachment from Outlook and click “save as”, it defaults to a folder called “OLK2785” in “Temporary Internet Files”. In Word, I set the default under “Tools”, “Options”, “File Locations” to the folder I need but it still doesn’t work. I’ve tried deleting the OLK folder but a new one is automatically created with a slightly different name.

It wouldn’t be a problem but I have to do this several hundred times a day at work and it becomes quite tedious. Is there a setting in Outlook that needs to be changed? Thanks for any help!

I think that Outlook has these directories that it uses to store attachments that come with your email. You can save the file somewhere else, using “Save As” rather than the “Save” command, and changing which directory you want the file saved in.

As far as I know, short of a programatical solution or modifying the registry editor, you must select Save As… from the File menu of the Word document in which you’re working and specify a location other than the Outlook secure temporary file folder.

If you’re comfortable with modifying the registry editor, let me know and I’ll poke around in there to see what’s what.

Your confusion here is that Outlook isn’t making it clear that you haven’t saved the file when you open it from within Outlook.

Here’s how it works:

You receive a message with a Word attachment. The attachment is not a file on disk, but a string of characters in the body of the internet email format. Outlook sees a special code and says “Aha, the rest of this message is a Word document,” and so it shows you a word file icon to represent the attachment.

Then you have a choice, you can tell Outlook to save the attachment to its own file on disk, or you can tell Outlook to open the document with Word. In your example, you are doing the latter.

If you were to do the former, Outlook would present you with a Save File dialog that would default to the directory you specified under the options.

But by opening the document, Outlook has to communicate it to Word somehow. The designers have chosen to do this by saving a temporary version of the file in a working folder somewhere in the boonies of the file structure, and then sending a message to the operating system to open that file. Windows sees that it’s a .doc file, so it tells Word to open that file in the temporary folder. That’s the “OLK2785” folder you see.

Does that help?

bughunter is correct - Outlook is temporarilly saving the .doc (MS Word) file in some arcane place, then telling Windows to open it. Windows looks up what handles .doc files and fires up Word. So when you tell Word to save it, the default behavior is to save in the directory that the file was opened in.

I poked around Outlook a little, and I couldn’t find any way to change where Outlook puts it’s temporary files. In my case, the files go to:

C:\Documents and Settings<my login>\Local Settings\Temporary Internet Files\OLK16

And yep, there’s a registry key:
HKEY_CURRENT_USER\AppEvents\Software\Microsoft\Office\11.0 \Outlook\Security\OutlookSecureTempFolder

This is in XP with Outlook 2003. You could find it yourself by:

  1. Do “Save As” on one of the Word docs you saved
  2. Right click the Word doc in the dialog and select Properties
  3. Copy the whole Location string
  4. Search for the Location string in the registry editor.

So, you could probably change that if you wanted to. Otherwise, just save the documents as you get them - it should default to the last folder you saved a file, so you won’t be too far off.

WARNING: If you don’t know what you’re doing in the registry editor, you can cause your computer to stop booting. Use at your own risk. Etc, etc.