My endless struggle for USB 2.0

I have a Dell Inspiron 530s that only has USB 1.1, and I would like to be able to get at least USB 2.0, so I can hook up an audio interface for music recording.

I know, I know, all my stuff is old, obsolete, blah blah blah.

So I bought a 2 usb 2.0 PCI card. When I go to install them into the damn machine, the computer won’t boot. Damn, bad card I thought. So I bought another one. Same damn thing.

What am I doing wrong? I don’t remember adding PCI cards to be this difficult.

Here is the Speecy information for my computer:

Operating System
MS Windows Vista Home Basic 32-bit SP2
Intel Pentium E2140 @ 1.60GHz 60 °C
Conroe 65nm Technology
4.00 GB Dual-Channel DDR2 @ 399MHz (5-5-5-18)
Dell Inc. 0RY007 (Socket 775) 40 °C
DELL SE178WFP (1440x900@60Hz)
Intel® G33/G31 Express Chipset Family
Hard Drives
313GB Western Digital WDC WD3200AAKS-75VYA0 ATA Device (SATA) 44 °C
Optical Drives
TSSTcorp DVD±RW TS-H653B ATA Device
Realtek High Definition Audio

Oh, and here is this too if it helps:

Manufacturer Dell Inc.
Model 0RY007 (Socket 775)
Chipset Vendor Intel
Chipset Model P35/G33/G31
Chipset Revision A2
Southbridge Vendor Intel
Southbridge Model 82801IR (ICH9R)
Southbridge Revision 02
System Temperature 40 °C
Brand Dell Inc.
Version 1.0.3
Date 07/12/2007
CPU CORE 1.216 V
+3.3V 3.360 V
+5V 5.053 V
+12V 12.032 V
PCI Data
Slot PCI
Slot Type PCI
Slot Usage Available
Bus Width 32 bit
Slot Designation PCI1
Slot Number 0
Slot PCI
Slot Type PCI
Slot Usage In Use
Bus Width 32 bit
Slot Designation PCI2
Slot Number 1
Slot PCI
Slot Type PCI
Slot Usage Available
Bus Width Unknown
Slot Designation PCI3
Slot Number 2
Slot PCI
Slot Type PCI
Slot Usage Available
Bus Width Unknown
Slot Designation PCI4
Slot Number 3

Turn off the USB 1.1 functionality in the BIOS or play with the USB BIOS settings until you get one that lets the system boot with the car in place. Check the manual and see if there is a jumper on the MB that defeats the onboard USB 1.1 and frees up the IRQ.

There aren’t any BIOS stuff for USB. :frowning:

So I couldn’t keep the USB 1.1 stuff going with a new USB 2.0 card going?

I didn’t really see anything on the MB for jumpers, but I am not sure where to look.

Maybe update the bios

there is a version 1.0.18 from 2009, and you are on 1.0.3 from 2007.

Weird that such a “modern” machine doesn’t have 2.0 by default.

I agree. If the machine is circa 2007 and USB 2.0 was in machines by 2001-2202 it would have to have 2.0.
This says it does have 2.0 onboard.

It does have USB 2.0 according to the Dell Manual (note: this is a PDF).

What led you to conclude that it’s USB 1.1? Is it the performance? Have you measured the transfer rate? If you’re using a USB hub, is it possible that it’s 1.1? Have you tried different ports with different cables to see if that makes a difference?

To find out if you’re already operating in USB 2.0 (“Hi-Speed” USB, actually):

  • Open the Device Manager.
  • Under “USB bus controllers”, locate the host controller(s).
  • Most (all?) Hi-Speed-capable controllers will have the word “Enhanced” in their name.

If you have an Enhanced controller but you get messages saying “this device could perform faster”, the device may be connected through a USB hub that doesn’t support Hi-Speed, or the specific port you’re using may be limited to USB 1.1.

In theory, the USB symbol next to the physical ports should have a special mark to identify Hi-Speed capability (a “+” sign, like this). Some manufacturers don’t follow this rule, or don’t display any USB symbols at all, for some reason.

I’ve got (somewhere, unless I’ve chucked them) USB cards that won’t work if you’ve got 4+ GB. They’ll work fine in a 2 GB system.

BTW while your PC can’t take more than 4 GB, you’ll see a modest benefit from switching to 64 bit, especially if you put in a graphics card, as it will enable an extra 0.5-1 GB RAM.

What do you mean won’t boot? Can’t get to the OS, can’t get to the BIOS? Something inbetween?

On a home built I was able to add a USB 2 card to a machine that had only USB1.1 and they all worked. What comes to mind is use a different card slot, and remove other cards, even if temporary to see if you can get it to boot. You may need to update/replace the other cards.

Flashing the BIOS may help also.

Is this one of the small form factor cases?
what is the power supply rating?
if multiple cards are causing a failure to post im betting insufficient power.

Seconding the question by what do you mean by does not boot…no dell logo? Just Not loading windows?

Some older computers have strange things like USB 2.0 in the back but only USB 1.1 in the front. Even more common is more power at the back ports compared to the front. I have a device that charges through a UBS port and it took forever if plugged into the front of an older PC.

According to the Dell documentation, all USB ports on this machine are 2.0.

When I plug in a thumb drive to either the front ports or the back, I get the message “this device would work faster if it was hooked to a high speed USB port.”

When I pull up device manager, I have a long list of stuff under USB, but only two of them have this:

INTEL(R) ICH9 Family USB2 Enhanced Host Controller -293A
INTEL(R) ICH9 Family USB2 Enhanced Host Controller -293C

When I hooked up an external hard drive that required USB 2.0, it wouldn’t work. I got an error message that I needed at least USB 2.0 when I tried to install the driver that went with it. It was about six months ago so I don’t remember exactly what it said.

Do you think that 2.0 functionality could be switched off somewhere?

I am going to try to flash the BIOS, not sure how to do that yet, but I am pretty crafty.

When I add the cards to the system, it won’t boot. It will come on, then I get the blinking dash. It doesn’t load the operating system or even hit the BIOS screen that says DELL blah blah blah on it.

Its a really slim case, so you can only put in the skinny cards. I wanted to go with USB 2.0 since it wouldn’t require a molex or whatever that separate power supply for the card like 3.0 will.

Nothing that hooks into the computer that requires 2.0 will work. The only thing I have plugged into anything on any of the USB ports is the little wireless adapter for my wireless Logitech keyboard and mouse.

I tried removing the rest of the cards since I don’t use the PCI modem or PCI ethernet card that is installed (thats all that is there) but it still won’t load. It just doesn’t even make it to the BIOS screen, I just get the blinking dash like an old 286 without DOS on it.

I was thinking about upgrading from Windows Vista Basic to Windows 64 Bit Premium, but the processor on this machine sucks (Dual 1.6 GHZ) and the motherboard is already maxed out at 4 Gig. I really couldn’t find any graphics cards that would fit in the case (its a slimline.)

So I was just going to dedicate it to recording music since I use a fairly old recording software suite, ACID 4.0. The memory was a cheap upgrade, but the rest would involve most likely dropping excessive money for a graphics card that was pretty crappy, and since I can’t get a USB card to mount on the system, I didn’t wanna drop the funds on a video card that would do the same.

Okay so updating the BIOS was really easy, got that done.

I checked out the settings, there was now a USB section, and I did confirm that it has “high speed” settings, and they were enabled.

So now I am going to assume that its working, since I don’t have anything that is 2.0 only. I am going to try to take the machine apart and get one of the cards in there and see if it will let me install it now.

Wish me luck.

So now I have installed one of the USB cards, and the system booted! No doubt thanks to the BIOS update.

But… nothing happened. I went to device manager, and scanned for hardware changes. Nothing. I didn’t have that windows pop up thing that says “hardware configuration changed” when I booted, nothing asked for a driver. I was thinking that maybe it just shared a driver that was in use. So I hooked up my printer to the new USB card. Nothing.

Any ideas?

:slight_smile: Getting closer!