Network Gurus: Please Explain This Strange MoCA/WiFi Issue

So, a bit of background. For years I’ve been running a MoCA setup (Actiontec boxes) on my network due to a home office. No problems. Now, I just upgraded my cable modem to the Arris TG1682G modem, with built-in router, wifi, and MoCA. As soon as I did the modem swap, I started having weird issues with the wifi not working well, constantly dropping, and so on. So the setup (and the one that had worked fine for years) initially looked like this:

Wall–>Splitter–>Actiontec MoCA–>Cable Modem–>Ethernet connection from modem back to MoCA on port 1|Ethernet connection from modem to network switch on port 2 for local use. With the new modem, I thought I had turned off MoCA in the modem, but there’s a chance it was enabled.

I kept having all sorts of weird issues with the wifi. The wifi antennas would turn off completely and I couldn’t even use wifi to get into the router or locally inside the WAN/LAN. I’d have strong wifi signal reported, then all of a sudden it would drop to zero. I’d reboot the box, it would take ages for the wifi antennas to work, they’d work temporarily, and then they’d drop again. Things like that. I think I was having wired connection issues as well, but since those were all things like the PS3/PS4 and TV, I was obviously trying to troubleshoot with my laptop.

Anyway, I think I fixed it by taking the Actiontec box before the modem out completely and re-enabling MoCA in the modem. Wifi seems solid, the MoCA connection in the home office works, and I haven’t noticed any weird dropouts. While I’m totally willing to buy the Actiontec device somehow not playing nice with the modem and causing internet connection issues, why would that do such a number on my wifi (and possibly ethernet router) to the point that it was unusable internally? Shouldn’t I have been able to at least connection and see everything up to the modem, including being able to reliably get into the modem control?

These things are shipped and sold with Factory or Alpha firmware…

  1. you typically have to update it as soon as you get it
    2 after a while they assume users have found all the bugs, and they do last round of bugfixes and release a new firmware…
    Anyway, look for new firmware…

Nothing you said sounds like a protocol compability issue, in that there’s no “works fine with A, but not with B”… it just doesnt work reliably.