Network Mavens: a moment of your time

As many of you know, I run a computer shop, I am fairly well versed in basic networking, routers, and internet connections.

This week I got a weird one.
The hardware: Dual core Vista Home Premium, 2G ram, 250GB HDD
ISP: Comcast
Modem: uBee DDM3513 Docsis 3.0 Cable Modem
Machine is plugged directly into modem via ethernet cable, no router.

Customer calls, can’t get internet to work. Customer has had Comcast onsite techs out, who say its the computer. Connection works with Comcast techs laptop, works with my laptop.

I remove a few viruses, go through the usual internet connection stuff.

No browsing, the machine will not seem to connect to comcast DNS.

So I try manually specifying both Google DNS and Open DNS addresses for DNS resolution. - Nada

2 of 4 packets lost - destination unreachable

I can browse to the modem configuration page on the modem, so its not like I have a dead ethernet card.

Replace cables and network card - Nope
Swap for motorola Surfboard Cable Modem - Nope

Take machine back to shop, plug into our router, works perfectly
Tried plugging directly to our modem, works perfectly.

Wipe and reload machine to eliminate possibility of some exotic setting or residual virus damage causing problem.

Back to customers house - Still nothing

On a hunch I try hooking up a router to customers modem and PC to router.

Clouds part, angels sing, internet flows like champagne in the hamptons.

The question: Why?

What would stop a fresh load of windows from pulling DNS from any old comcast connection but once a router asks, well sure here ya go, browse away.

Just to double-check, did you try swapping out the cable between the modem and the PC?

Secondly, is this a 100 Mb link or a gigabit link? Direct connections between the modem and PC tend to require a crossover cable. Gigabit should auto-negotiate the crossover, 100 Mb doesn’t IIRC.

yup, cable was swapped.

1 bump for the monday morning crowd

I’m betting you needed a crossover cable; putting the router in between obviated that need.

But if that were the case, how would he have been able to “browse to the modem configuration page on the modem[per OP]?

I had difficulty connecting to a satellite modem. It would only talk to the device it saw when powered on. The tech guy connected by PC to it, booted it up and all was cool. I tried to replace the PC with a router and the modem wouldn’t talk to it. Powering the modem off and back on straightened things out.
I wonder if the guy connected a different device.

So, the one thing you didn’t try was connecting a different cable modem at the customer’s site, right?

I would guess it is some type of strange MAC address spoofing problem. The Cable modem is not being validated by Comcast because it doesn’t have an authorized MAC address, and for some reason the PC isn’t able to supply one. Once you connect a router, the Modem gets the router’s MAC address and all is OK. I have to admit, this is far-fetched, but it would explain the symptoms.

I wonder if the network card driver is rejigging the MAC address as it loads - the cable modem is grabbing the hardware MAC address before the driver loads, then Windows fires up and the MAC address changes, invalidating the bridge configuration and making the setup fail.

[quote=“beowulff, post:8, topic:627560”]

So, the one thing you didn’t try was connecting a different cable modem at the customer’s site, right?


Yup, I met comcast onsite techs out there and watched them replace the modem…no effect. I tried swapping for a different brand of modem in case there was some issue with that specific modem, still no joy.

Then my laptop should not have authenticated but did.

My only thought was this machine was purchased used and I was wonding if his MAC may have been blacklisted for some kind of TOS violations (bulk spamming or massive downloading/torrents). I would think comcast would have said something on the several phone calls to tech support.

Only thing I didn’t try was cloning the MAC address to the router and see if it dropped after that. I was looking at it as, its working, I am going to close my ticket and cash out now before something weirder goes wrong.

DNS issue?
Routing table entries for some reason?
Do you mean that 2 of 4 pings went through?

When you say “ping” to an IP address - work your way from modem, is it NAT or are you getting a real IP address?

Ping your way from the nearest to the default gateway for the ISP-provided IP info…

Back at the office, is it the same NAT range if it is NAT?
I.e. one is 192.168.0.x
and one is 192.168.1.X

Nope, the computer is pulling a valid IP from comcast that matched what they told me.

The only time I lost packets was anything outside the house. loopback, modem, no problem. Gateway, DNS, misc known sites, various degrees of packet loss.

Is there any way to reset the modem to its defaults? Have you tried that?

Yup, didn’t help