New computer

I posted a thread a few months ago, asking when it’s time to get a new computer. My 2005 PowerBook G4 is fine, but I kept running into programs that wouldn’t run on a non-Intel chip. It was starting to become annoying. I’ve just bought a set of language DVDs and CDs, and when I tried to run the first disc I got a message saying that my architecture would not support it. That was the final straw.

Months ago, the local Apple dealer had an older, refurbished 17" MacBook Pro – the kind with the battery you could change and the silver keys. Lots better than my PowerBook G4, and it was only $600. But it was sold before I could get there. I found a newer one on eBay yesterday that had a starting bid of $500. Not trusting eBay sellers all that much (for computer stuff), and not knowing how high the bidding would go, I went to the local Apple dealer’s website. I ended up getting a floor model 17" MacBook Pro that had been out of the box for about eight months. It’s a 2.2 GHz (vs. the G4’s 1.5) Intel quad-core i7, 4GB 1333MHz DDR3, and a 750(?) GB hard drive.

I really like the screen, and the gobs of extra memory. I’m still not quite used to the ‘stealth’ trackpad button. On the G4 it’s an actual button. On this machine, it’s integrated under the trackpad and is invisible. I’m running into issues with Lion, which I’ve asked about in GQ. It feels like they hired someone from Microsoft to hide things and to delete useful things I’m accustomed to.

I also bought a Firewire to copy my old machine to this one. I don’t think I’ll do that, though. I’m sure I have too much mung on the G4 that I don’t need. I do need to copy my iTunes library though. The language software came with audio CDs, and I want them on my iPod.

Oh, this one has a webcam. No idea how to use it, or what to use it for. I have Skype, but never use it.

Looks like I’ll have to buy a new copy of Office for Macs. I had 2004 on the G4, but when I transferred the files over I found that PowerPC software is no longer supported.

ETA: Oh BTW, and I have a CD stuck in the old computer. The Eject button never worked since I had the keyboard replaced, so I tried to eject using the iTunes icon. It didn’t come out. So I clicked Eject CD from the iTunes Commands menu. No joy. I tried rebooting while holding the trackpad button. Nuh-uh. I’ll swing by the Apple place mañana.


Office 2011 is probably the best version of office since ’98.

Microsoft products annoy the shit out of me. I use them every weekday, and they just keep getting more annoying. But you can’t live without them! I need Excel, Access, and Word, even if they do behave illogically. :stuck_out_tongue:

Hey, I have some good news. After letting the G4 sit (shut down) for a while, I decided to give the mouse+Startup one more try. The disc came out this time. :slight_smile:

Aside from getting used to the new OS, a couple of other observations:

The disc slot is on the right side of the computer instead of in front. That’s nice, since I often have the computer on my lap and the G4 ejects into my belly. But now I have to get used to having the slot 90º from where it ‘should’ be.

All of my ports are on the left side. I like having one of the USB ports on the right, as on the G4.

The magnetic power connection is awesome. :slight_smile: The plug on the G4 never did work right, from new. I’d have to twist it to make sure it’s connected. The magnetic one just works.

Speaking of magnets, the new computer has them to hold the screen shut. The G4 had a latch. Ham-handed airport baggage handlers tweaked the lid of my G4, so it’s not as easy to open as it used to be. Magnets are better.

The notch where you lift the screen on the MacBook has sharp corners. A little uncomfortable when using the trackpad.

There should be a very small hole just below your CD/DVD player that will accept something the size of a small paperclip. This is the manual eject and should release your drive door. Otherwise, it’s Hammer Time.

Nope, not on a slot-loader. (Like in your car; i.e., not a tray like on PCs.) In any case, I did get it to eject on mouse+restart.


That’ll teach me to be more familiar with Apple products.